Skip to content

NWN Explorer

Is there a working version of nwn explorer for NWN EE.
I suppose not. Can someone give me some directions to NWN Explorer source code (and what program it was written it would be usefull) and to what is needed in order to make resources within Basic nwn files appear as normal?


  • shadguyshadguy Member Posts: 154
    edited January 2018
    Googling just now turned up this:

    It looks to be done in C++, and it looks like it's an older version of nwnexplorer.

    There is a vault entry suggesting the tool is under active development at Higher Ground, so I stumbled on this, but don't see source:

    It may be worth reaching out to @FunkySwerve.

    I'll post an update if I find something newer.

  • T0R0T0R0 Member Posts: 86
    Acaos mentioned that he is looking into it here
    No ETA is mentioned.
  • shadguyshadguy Member Posts: 154
    Thanks @T0R0. Sorry I missed that post, @Acaos.

  • GlorwingerGlorwinger Member Posts: 41
    @shadguy @T0R0 The main issue I have found is that the .key files were moved into the data folder. That means the path to the .key folder is the same as the .bif. If the folder (data) is appended to the path to find the .key the .key file STILL returns "data\" so when the path to the .bif is created it has \data\data\. I stumbled across this using NWN Explorer while I was fixing the nwnnsscomp compiler.
  • Sunssarathi2029Sunssarathi2029 Member Posts: 32
    Anyone have an idea what to open .KEY files in?
    I found that we can get some resources working by copying original nwn key files to the game folder and then manually setting explorer there. But it is not perfect and i need to find out differences in .KEY Files.
    NWN EE:

    Attachment is nwn explorer 1.1 (i cant get to options in reborn) and original .KEY files extract to base nwn folder and manually set path to it in explorer to get a little working version.

  • Sunssarathi2029Sunssarathi2029 Member Posts: 32
    edited February 2018
    never mind found the difference.
    nwn_base is for everything apart of localization while nwn_base_loc is localization only.
    copying .KEY files is buggy as hell, but works.
  • Sunssarathi2029Sunssarathi2029 Member Posts: 32
    Does anyone here know how to install cocom complier?
  • shadguyshadguy Member Posts: 154

    Thank you for the update, will give this a try this week!

  • DorrianDorrian Member Posts: 15
    @virusman Thank you!
  • shadguyshadguy Member Posts: 154

    I like the new nwnexplorer. The previously available version crashed for me as soon as I went anywhere near the File menu; this is fixed for me (Win10) now. I like the Tools stuff you've added - some neat stuff there.

    I don't see much happening when I try run emitters on (for example) a water elemental model, or on a save tileset model with water emitters (for example). Is it implemented? Am I perhaps missing the intent?

    Would is be reasonable to extend the number of Recent Files from 4 to 10 in the File menu?

  • virusmanvirusman Member, Developer Posts: 173
    I only fixed a few crashes and made it compatible with new file types, model fields and key/bif structure of NWN:EE. If emitters were not implemented in NWN Explorer before, they won't be working now.
  • virusmanvirusman Member, Developer Posts: 173
    Sources for 1.8.0 are now on Github.
  • shadguyshadguy Member Posts: 154

    OK; the emitters never worked before, so that's good background to know. In any event, I appreciate the update, rebuild and source sharing!

  • voidofopinionvoidofopinion Member, Moderator Posts: 1,248
    Amazing work!

    I never knew just how much I used Explorer until it no longer worked!
  • JapualtahJapualtah Member Posts: 165
    Thx for NWNExplorer, much appreciated!
  • KermobzdahKermobzdah Member Posts: 3
    NWN Texture Pack tree is empty in 1.8.0 unless you have renamed "txpk" folder to "texturepacks" as it used to be in Diamond Edition, but if you do that it will affect textures quality in the game. For some reason I can't correct texture search path in Options, I press OK but nothing happens.
  • Timmercado1975Timmercado1975 Member Posts: 8
    edited May 2018
    How are you guys getting around the chitin.key problem using Virusman's 1.8.0? It just won't open for me, and I can't even find chitin.key in my EE install folder.

    Please note: I've moved my basic game install OUT of \documents...
    ...And placed my game in D : \!Beamdog\00839\data for the main install, with all my custom content going into D : \!Beamdog\00839\data\data. Of course I've altered the .ini to direct each category (haks, screenshots, texturepacks, etc) to my new one, as I read I was able to on these forums.
    Post edited by Timmercado1975 on
  • shadguyshadguy Member Posts: 154
    @Timmercado1975 , if you put stuff in the BeamDog dirs, it may get nuked when the game updates.

    By convention, asssets are being placed under My Documents because that's how Microsoft asks software to behave in order to be considered "good citizens" under their contemporary Windows.

    RE: Your original question, I haven't got NWNexplorer working with NWNEE yet. We're still migrating other assets to a new server before we focus on moving our game server to EE. So, tools aren't holding us back as of yet. Good question though. :)

  • Timmercado1975Timmercado1975 Member Posts: 8
    edited May 2018
    ((My previous post got deleted... Not sure how.))

    @shadguy , thank you very much for your response.

    But is this true even if I sub-folder it inside a deeper level of data folders? (I am NO computer expert; I try stuff out, and read a lot of stuff on the forums, and try out stuff people who know better than I do say to try out :P )

    As in, if Beamdog updates the game, it goes to the FIRST data folder. Yet, all of the stuff in my data\data will still be there... At least that's my hope?

    I just really don't want it installed into my documents. Like some here that I read, I too am trying to manicure the size of an SSD that I use for my OS so that background ops work a bit faster. So I'm hoping there is a secure and efficient way to install this game into my D drive (non OS, non SSD).
  • shadguyshadguy Member Posts: 154
    @Timmercado1975 - I think it will clear everything out. You can try testing out the specifics for what you're trying to do by opting in and out of the Development build in either Steam or the BeamDog client, I suppose.

    I've got my game's legacy/v1.69 stuff installed in C:\Games. I have .ini files in My Documents redirecting NWNEE to C:\Games. So maybe you can do something similar to minimize the My Documents footprint of your install.

    It feels dumb to me to go through that middle-man, but meh - I have that working and other more interesting fish to fry.

  • KermobzdahKermobzdah Member Posts: 3
    How does model compiler work? I just run it and see command line window for a few milliseconds. Or should it be used through NWN Explorer somehow?
  • shadguyshadguy Member Posts: 154
    I believe it is a command line tool.
  • zordren3742zordren3742 Member Posts: 207

    How does model compiler work? I just run it and see command line window for a few milliseconds. Or should it be used through NWN Explorer somehow?

    info on how to use MDLComp is here
  • zordren3742zordren3742 Member Posts: 207
    virusman said:

    Updated to work with EE assets:
    It doesn't detect the installation path automatically yet but you can specify it manually.
    As a bonus, it supports new mdl parameters: materialname and renderhint.
    Here is a model compiler build that should support those:
    I haven't tested it myself, though. If you encounter any issues, please let me know.

    Hey I just tested the new mdlcomp. It will compile and the models will show in game, but they will not render the new normal and spec maps, they do render the new maps when they are not binary. I even renamed the new one to make sure it was not using the one in my gmax or nwnexplorer folders. Same result. I have no idea how much work it will take to get normal and spec working in binary, but thank you for working on these tools anyway virusman.
  • virusmanvirusman Member, Developer Posts: 173
    Yeah. The game won't generate tangents for compiled models (a known bug), and nwnmdlcomp doesn't support those either (it won't put them in the binary model when compiling). I have a sample .mdl now and will try to add support for that when I have time.
  • pscythepscythe Member Posts: 116
    Great that this no longer crashes like it use to. But for base_2da.bif it is showing resXXX.2da instead of the actual filenames. This makes it rather hard to get at the right .2da file, specially when Ctrl-S only search for filenames and not contents, and Export only exports single files not the whole shebang, so the grep option is out too.

    Do we have another way to open .bif files?

  • virusmanvirusman Member, Developer Posts: 173
    Open the .key file or specify the NWN folder and it will find the .key for you.
  • pscythepscythe Member Posts: 116
    edited June 2018
    Tried specifying the NWN folder but it complains that DIALOG.TLK is not found. Keeps going back to the Diamond Edition.

    EDIT: Found a copy of Ganymed's BIF Editor that did the trick.

    Still would like to have NWN Explorerer working tho. It is behaving very weird. When I click on the Open button and go into the EE data directory, it only shows me some of the .BIF but not all the .BIF files and the .KEY files doesn't show up at all despite the file filter being *.*. Manually typing in nwn_base.key in doesn't help either, it just says file not found.
    Post edited by pscythe on
Sign In or Register to comment.