Skip to content

nwnplayer.ini

I have a problem with the nwnplayer.ini file, i can not get it to read from the server.
If i remove it from the container, when i restart the server the default one is recreated
then when i replace it with mine, re-restart the server and it's as if nothing happened, some idea?

this is the command i used the first time i created the container

docker run -it --net host --restart unless-stopped -e NWN_PORT=5121 -v $(pwd):/nwn/home -e NWN_MODULE=TestNWNXEE -e NWN_SERVERNAME="Text NWNX" -e NWN_PUBLICSERVER=1 -e NWN_ONEPARTY=0 -e NWN_DMPASSWORD=MyPaswd -e NWN_PVP=1 -e NWN_PAUSEANDPLAY=0 -e NWN_ELC=0 -e NWN_ILR=0 -e NWNX_ADMINISTRATION_SKIP=n -e NWNX_CHAT_SKIP=n -e NWNX_CREATURE_SKIP=n -e NWNX_EVENTS_SKIP=n -e NWNX_DATA_SKIP=n -e NWNX_OBJECT_SKIP=n -e NWNX_PLAYER_SKIP=n -e NWNX_THREADWATCHDOG_SKIP=n 8156_003:latest





tnx, Ali

Comments

  • Knight_ShieldKnight_Shield Member Posts: 45
    edited February 2018
    I had the same problem. You need to use command line.

    example: ./nwserver -module "your module" -maxclient 30

    http://www.neverwinternights.info/dedicatedserver.htm
    Post edited by Knight_Shield on
  • AlibertoAliberto Member Posts: 80
    edited February 2018
    I also pass some parameters as environment variables, but there are some settings that i can not manage like these:
    Server Vault By Player Name=1
    Sticky Player Names=1
    the strange thing is that i always used docker, and until 8154 ver i used it without problems.
    I will try today to redo a clean procedure from the beginning, let's see what happens

    edit: does not work
    Post edited by Aliberto on
  • Knight_ShieldKnight_Shield Member Posts: 45
    I was just looking at your first image.

    I see that not all the files have correct permissions. chmod -R 755 /yourdirectory

    I'm not a total expert but I have run these servers on linux for sometime now.

  • AlibertoAliberto Member Posts: 80
    change permissions is the first thing I tried .... tonight i'll try to put the 5154 up again, maybe it's just a problem of the image I'm using for 5156
Sign In or Register to comment.