Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!


Good to see this game being revitalized! It inspired me to launch another Shadows of Undrentide toon. Just finished it earlier, ran him through Shadohaunt following. I had to finish the mod with a mounted paladin the whole way through, but outside of that, the module seemed to work on EE. Appropriate things carried over to HOTU, without getting too spoilerish.

PS, if anyone knows how to fix a paladin/Mount bug, please let me know via PM. The bug carried over to HOTU, and I can’t get him to dismount at all. Regards.


  • EnialusMeliamneEnialusMeliamne Member Posts: 399

    With a shout out to Prolefic for attempting to come to my rescue, it seems a solution has been found. KEY POINT (for the TL;DR below). Don't leave your character mounted when you're finishing a module with an auto-export functionality. It seems that when your character saves, it saves it with the mount aspect as part of your actual toon. The unmount function becomes a useless venture.

    The rest of the story: I tried a derivative of the DM script (runscript x3_fix_horse), and re-attempted using this script (dm_runscript x3_fix_horse) Prolefic provided this morning (after enabling debugmode on all occasions of course). Both attempts netted me a dwarven body without a head. My Pally is a human, so the scripts solve the horse issue but present their own problem. That said, I did attempt to use the radial dial across multiple mods (Pretty Good Char Builder, launched a chapter of SOU with a vaulted copy of the character I ran through Shadohaunt, as well as HOTU), and the message came up that the character wasn't mounted (paraphrasing). I attempted both party dismount and individual dismount options in each instance. I did complete SoU with my paladin on his horse at the end, so that might be the culprit. I did load my last save prior to completion on SOU, and he unmounted as normal. Vaulted that character (unmounted), loaded up shadohaunt just now, and no issues with summoning, mounting or unmounting.

    All of that said, it seems that Shadohaunt is indeed EE compliant, as I didn't find any noticable bugs on playthrough (besides the horse piece which seems to be a bigger picture issue anyway).


  • ProlericProleric Member Posts: 494
    My guess is that Shadohaunt, like most older modules, wasn't updated to support horses after 1.69 came out.

    You can export mounted from one horse-friendly module to another (e.g. SoU to HotU) but going via an older module can corrupt the PC. So, as you say, exporting dismounted is safer.

Sign In or Register to comment.