Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Removing damage immunity itemproperties from skin bugged?

ShadooowShadooow Member Posts: 343
I think I stumbled on this in past but forgot. Now I ran into this issue again when working on PRC Lite.

Basically, after removing itemproperty Damage Immunity Electric or Fire 100% the itemproperty stayed active despite not being on item anymore. This is worse in that the effect permanent, doesn't go away with resting, dying, destroyal of the skin item and the effect cannot be retrieved by GetFirst/NextEffect. Only restart/reload helped.

Is anyone else aware of this? Worth to report BD to fix?

Comments

  • ShadowMShadowM Member Posts: 503
    edited May 2018
    Did you try unequip / re-equip after item property removal? If that does not work then probably should report it. I had similar issue with moving around properties on skin and had to add a quick unequip/equip action too it.

  • ShadooowShadooow Member Posts: 343
    did some more testing, and not sure why, if its different damage type but after removing skin the faulty effect disappears (so I suppose re-equip will work), but still annoying workaround

    ShadowM
  • ShadooowShadooow Member Posts: 343
    aand it is already fixed in NWN:EE, havent seen that anywhere in notes but my repro savegame works correctly on EE

    well done BD

    ShadowMpscythe
  • nivniv Member, Moderator, Developer Posts: 374
    In 1.69, item properties would attempt to re-find the effect to remove based on type and effect state (like integers). Obviously, this was extremely brittle.

    In NWN:EE we're now storing the actual property a effect came from (server/module-unique incrementing ID), and thus there's no problem matching up effects to their originating itemproperties. Any and all "wrong/no effect removed" issues should have gone away. If not, please report it as a bug. :)

    ShadowM
Sign In or Register to comment.