Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Resolved] Unpacked modules not working

weavejesterweavejester Member Posts: 10
edited June 2018 in Builders - Toolset
I've been trying to work out how to open unpacked modules in the toolset, without any success. The last stable patch notes say:

The toolset can now open unpacked modules: You need to have it unpacked in a directory the same name as the .mod file (without the .mod extension).

So I unpacked a module into a directory and placed it in the "modules" subdirectory. Unfortunately it doesn't show up. It doesn't show up in the module list, and trying to load it reports that "The specified file could not be found".

I've tried unpacking with Niv's neverwinter_utils.nim, and I've tried renaming the temp0 folder when the toolset opens a module. Neither work. I've also tried creating a new module with the same name, to see if a blank .mod file was necessary as well. Nothing so far has worked.

Has anyone got this feature to work? If so, what's the secret sauce?


  • weavejesterweavejester Member Posts: 10
    Ah, moments after posting this I managed to find the solution. Isn't that just the way?

    Just in case anyone runs into the same problem: you need both the .mod file and the directory for it to work. If you have both of these things then when you try to open up the module the toolset will give you the option to open the directory instead. Saving the module will update both the directory and the .mod file.

    It's a weird implementation, and I can only assume that it prioritises the directory over the .mod file, but I'll need to do some tests and find out.

  • weavejesterweavejester Member Posts: 10
    edited June 2018
    So it turns out that the toolset prioritises the directory, but the "Test Module" functionality in the toolset loads the .mod file instead. When the toolset saves, it'll update both the directory and .mod file.

    This is slightly problematic. Unpacked modules would seem like they're better for version control, but updates to the unpacked module will only show up in the toolkit and not the client, at least until a save is triggered that updates the corresponding .mod file.

    I guess eventually the client and server will be able to handled unpacked modules as well, but until then there are some unusual gotchas in this workaround that aren't very well communicated.

    Post edited by weavejester on
Sign In or Register to comment.