Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Problem with Adalon bug and Drow Portraits

I could use some help!

Okay, I have a bunch of mods installed. Adalon's quest for the Drow city turns all the NPC's into Drow characters (except for the PC for some reason). Okay, fine, and when I completed the Drow city I got the Adalon bug, where she would just sit there after turning your characters back to normal and does nothing. So, you have to crash the game to get out.

I looked over these forums and found some patches to get past the Adalon bug. It worked. Adalon teleported me to the exit, and the NPC avatar's were returned to their normal non-drow state. The problem is the portraits are still drow portraits for my NPC's (not sure if these are from a mod or the regular game), and I can't get rid of them. I've slept, I'm in Chapter 6, I've tried a clua trick that set the drow change for the character, and I've opened up EEKeeper and manually reset their portraits back to the original settings. I've tried a lot of things to no avail. So, I have five drows traveling with me still. lol

Does anyone have an idea how I can get my normal portraits back for my NPC's? It seems like it has to be a flag that I need to change. Because when I do the save in EEKeeper the NPC's have their normal portraits, but when I open up that saved file the drow portraits are back. Baffling!

Thanks, to anyone who can help.

Comments

  • lunarlunar Member Posts: 3,346
    edited June 19
    If it is this mod:
    http://www.shsforums.net/files/file/1091-isandirs-portrait-pack/

    Then the code for portrait change is this (k#drowportrait.baf) :

    // Normal portrait
    IF
    !Global("PlayerLooksLikeDrow","GLOBAL",1)
    !Global("K#DPortrait","LOCALS",0)
    THEN
    RESPONSE #100
    SetGlobal("K#DPortrait","LOCALS",0)
    ApplySpellRES("K#D%ID%0",Myself)
    END

    // Ust Natha portrait
    IF
    Global("PlayerLooksLikeDrow","GLOBAL",1)
    !Global("K#DPortrait","LOCALS",1)
    THEN
    RESPONSE #100
    SetGlobal("K#DPortrait","LOCALS",1)
    ApplySpellRES("K#D%ID%1",Myself)
    END

    So, if 'playerlookslikedrow' global is 1, and 'k#dportrait' local global is NOT 1, the script applies a spell that auto changes the portraits to drow ones. You need to check and change 'Playerlookslikedrow' global. Check that global with eekeeper in your save game, if it is 1, set it to 0. k#dportrait global also should be 1, it can be in global section or local variable section of every npc.

    Borek
  • FiddlerFiddler Member Posts: 29
    edited June 19
    Yep, I am using that portrait pack. I will try tonight. Thank you!!!

  • FiddlerFiddler Member Posts: 29
    edited June 23
    Well EEKeeper already had 'Playerlookslikedrow' = 0, so one of the fixes did that. As I said I was able to get the avatars back to normal.

    But, to remove the portraits I had to go to Effects, and the I removed the Portrait Change effect for each character, which was set to the drow portraits.


    Well this worked, and everybody has the normal avatars and normal portraits. But, it is now bugged. The current quest I was in, for the thief guild, they won't talk to me anymore, and if I try to leave a map, the game crashes. The odd thing is, if I load a save from Chapter 4 for example it still crashes when I try to leave a map. So, all my saves somehow got affected.

    Anyway, is there anyway I can get these drow portraits back into affects? Because right now my game is corrupt. And it's either I figure this out, or start all over again.

    btw, thanks Lunar for the advice. I just think I screwed it up, and should not have removed the drow portrait effect, and I just should have disabled it somehow.

  • FiddlerFiddler Member Posts: 29
    Nevermind, I figured it out :)

  • lunarlunar Member Posts: 3,346
    For future reference, if someone else has the same problem, what was your solution?

  • FiddlerFiddler Member Posts: 29
    edited June 26
    To tell you the truth if everyone just followed your advice, it works. So, if people stop there they will be okay, and the game will be fixed. The one thing of note, is that I had to add back in the new portraits using EEKeeper. ie NIMOEN, IANOMEN, etc...

    What I didn't mention was I tried a ton of other stuff that you did not mention, and to try and fix it. I ran scripts, I updated mods, I tried to clean my install etc.. A whole bunch of stuff that you did not mention. So, I think I screwed up big time. But, to get my game back I moved over a saved copy of my game folder, that I had saved after all my mod installs that did the trick. I forgot I had it. lol

Sign In or Register to comment.