Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Neverwinter Nights: Enhanced Edition has been released! Visit to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Mod's not installing properly, invalid tags everywhere, in BG:EE without SoD

SatrhanSatrhan Member Posts: 26
edited July 12 in General Modding
Hi, as the title says I'm having an issue installing Spell Revisions and Item Revisions for BG:EE. I had these (and others) installed and working up to yesterday, but I decided to change my mod setup a bit. Rather than manually uninstalling everything I just uninstalled the game, deleted the folder, and got a clean install from steam.
When I install the mods the install process is successful and doesn't give any warnings or errors. However when testing the game I get 'invalid: ' tags on pretty much every spell, item, and description. I have no clue what the issue is, as far as I can tell I'm not doing anything different from last weekend when everything worked fine.
Does anyone have any idea what the issue could be? I'm installing the latest versions of both, and I don't have SoD (think I read somewhere that could cause issues, but that can't be the case here).

Edit: Problem is not contained to SR and IR, but seems to affect pretty much every mod. I've done several clean installs now, to no avail.

Post edited by Satrhan on


  • southfla79southfla79 Member Posts: 120
    did try reinstalled the mods on a fresh install? The only thing I can think of, and this is after countless installs of those two mods and many, many others with no issues, is a hosed dialg.tlk file.

  • RaduzielRaduziel Member Posts: 3,226
    @Satrhan Are you playing on Steam?

    Can be due to the mismatch of BGEE and SoD updates - they are currently on different versions.

    Have you used modmerge (in case of Steam)?

  • SatrhanSatrhan Member Posts: 26
    edited July 11
    Yes I uninstalled the entire game, and deleted the installation folder and all modified files within it to be sure.
    I don't have SoD, don't own it and don't have it installed. I thought maybe the 2.5 patch was released somewhere the past day, but that's not the case either as far as I can tell.
    I didn't use modmerge, that's only necessary if you have SoD right? Either way, mods installed just fine before.

    Edit: I just tried again, with a completely clean steam install (without SoD, no other mods installed yet either), still no luck.

    Post edited by Satrhan on
  • SatrhanSatrhan Member Posts: 26
    edited July 12
    @Raduziel Do you have any idea what could be the issue?
    If I can't fix it now I guess I'll just do a playthrough without them, and hope the other mods I'd like do work like they're supposed to.

  • RaduzielRaduziel Member Posts: 3,226
    @Satrhan Both my ideas involved SoD (patches mismatch, lack of modmerge).


  • SatrhanSatrhan Member Posts: 26
    Rats, guess I'll play without them then. Thanks anyway.

  • subtledoctorsubtledoctor Member Posts: 9,759
    edited July 12
    dialog.tlk is borked. It can happen with uninstall/reinstall. Try a clean game install, i.e. with a clean dialog.tlk

  • SatrhanSatrhan Member Posts: 26
    edited July 12
    Well that didn't last long. Seems the problem is not only happening with SR and IR, but it happens to more (all?) mods. For instance the dialogue with the watcher that lets you skip Candlekeep, items added by rogue rebalancing, weapon proficiency adjustment from Tweaks, all invalid. This is getting frustrating, this all worked fine a few days ago.

    @subtledoctor I've done at least four clean installs over the past two days, made sure to delete the game folder too. Made no difference.

  • subtledoctorsubtledoctor Member Posts: 9,759
    Permissions issue maybe? Sounds like the mods are fine, it's something in your computer getting in the way of the mods altering dialog.tlk.

  • SatrhanSatrhan Member Posts: 26
    That could be it actually. For some reason everything is read only, not just here but every folder on my pc. It's too late to fix now, I'll see what I can do tomorrow.

  • SatrhanSatrhan Member Posts: 26
    Well, it took several tries at reinstalling, creating a new steam folder, finally moving the entire steam install folder, and restoring my pc to before the last batch of patches, but one of those seems to have fixed the problem. SCS is installing now, after that I'll see if things work correctly beyond Candlekeep but I'm cautiously optimistic.

  • SatrhanSatrhan Member Posts: 26
    edited July 17
    Short update, I have installed in the following order (I think, should have written it down);
    NPC Project, Unfinished Business, Spell Revisions, Rogue Rebalancing, Item Revisions, Faiths and Powers (just the cleric kits), Might and Guile (just the monk speed toggle), Refinements (just Robes for monks), Portraits Portraits Everywhere, Tweaks, SCS, BP series scripts, and IWD voiceset pack, and Lefruits's ui mod.
    It's working about 98% as intended, just a few minor issues.
    1. Bhaalspawn abilities have an invalid description, they do seem to work as intended though.
    2. Viconia didn't get the Shar Cleric kit from Faiths and Powers. I didn't think anything would overwrite that. Did manage to add it to her using EE Keeper, but it has only added the innate abilities she would get, it hasn't changed her selection of usable weapons and armor.
    3. The shadow druid in Larswood summoned some snakes that were labeled invalid, and two cheetah's that were rather interestingly named "What of the thieves guild? Could you not remain there?". Which is original, as far as names go. Both animals did fight just fine though.
    4. Not sure if this is actually a bug or just something I misunderstood, but aren't monks supposed to be able to drink potions of ... giant strength? My dark moon monk can't.
    5. Could just be an intended effect, but it very strange; charm spells cast at my party inevitably not only causes the target to be charmed, but the caster also becomes friendly?

    Post edited by Satrhan on
  • subtledoctorsubtledoctor Member Posts: 9,759
    edited July 18
    2. I think FnP armor/weapon usability is tied to the sphere system.

    4. Scales of Balance has a componebt to allow anyone to drink any potion.

  • SatrhanSatrhan Member Posts: 26
    Ah that would explain why the kit is a bit different, thanks.

    Anyone have any ideas to points 3 and 5? Loads of summons that aren't your standard monster (ogre, hobgoblin, wolf, etc) have messed up names, either invalid or a random sentence that's obviously part of some conversation.
    Charm spells definite do weird things. As soon as someone starts casting those at my party, enemies start flipping to my side. Summons enemies make also regularly start on my side as soon as they show up.

  • shylamanshylaman Member Posts: 141
    Sounds like I am not the only one having issues recently. I have been playing and installing the game on both Windows and OS X since the 90s. Tutu, BGT, Wine wrappers, EE, EET, etc. I had time off this week and decided to do another run through. I hadn't played in at least 6 months as work kicked my butt. I decided to update the games (I have Beamdog versions) on my my MacBook Pro and this week has been nothing but trouble. Mods that were working not working. Random errors on only individual components. Mostly seemingly to do with EET. And at the same time G3 and SHHS are down and can't access the forums to ask for help.


    I feel your pain.

  • SatrhanSatrhan Member Posts: 26
    @shylaman Yes it's rather annoying when things that should work don't. I've managed to get everything working right for the most part, but it took some effort. G3 and SHS are back up again btw.

  • erianneerianne Member Posts: 13
    edited July 21
Sign In or Register to comment.