Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Mod Problem BG1 NPCs for SOA mod

HolzpapaHolzpapa Member Posts: 8
when i try to install the mod: BG1 NPCs for SOA
i get this SKIPPING: [NPC Name& NPC Name: ToB]
ToB Is Required to Install This Component
how can i fix this ?

Comments

  • ThacoBellThacoBell Member Posts: 7,626
    What mod are you trying to install? The only npc mods I know of are for individual npcs.

  • HolzpapaHolzpapa Member Posts: 8
    BG1 NPCs for SOA mod

    it should add all the companions from bg 1 into bg2, my hope was that i get xzar and monti back :D

  • ThacoBellThacoBell Member Posts: 7,626
    That sounds like a huge mod. Do you have a link to it?

  • ThacoBellThacoBell Member Posts: 7,626
    Thanks. Okay, it looks like this mod hasn't been updated since 2012. That could very well be the biggest issue. I don't have time to test anything in game, but it looks like MOST of the components install okay. The very first component and the voice pack are the only two that fail. It looks like the mods is not finding a certain file. A lot of changes to the game engine have happened since this mod was made, so I'm frankly amazed that this much installs.

    As for the "ToB required to install", this is a throw back to before the EEs. Because vanilla BG2 may or may not have ToB, mods had to have components for BG2 and ToB be separate. With the EEs thats no longer necessary. So either the mod simply doesn't look for the EE version, or the mod does and simply skips ToB only components and includes them in the SoA install by default.

    Derp, I really should have asked this first. Are you using the Enhanced editon, or vanilla BG2?

  • megamike15megamike15 Member Posts: 1,174
    the mod was never made compatible with bg 2 ee. which is for the best as your better off using the stand alone npcs if you want bg 1 npcs in 2.

  • Mantis37Mantis37 Member Posts: 772
    It's a shame though, there are some great ideas & interesting new areas in it.

  • LammasLammas Member Posts: 108
    All right, this is quite a bit off-topic but since it had all the BG1 companions I guess I'll ask about something I never thought I'd even think or remember about again:

    One of the only mods I've ever installed in BG's ever was called I think "The Darkest Day". It was a pretty good mod (in theory) that introduced some new NPC's, new gear, new kits and a lot of new quests but it was never properly finished and had a lot of bugs and crashes. Anyone know if that was ever finished properly? It was a SOA mod that was not compatible with TOB as far as I remember.

    I'd love to give that a try, some teenage nostalgia tied to that mod and wishing for the longest time that it would work properly.

  • DJKajuruDJKajuru Member Posts: 2,777
    Lammas said:

    All right, this is quite a bit off-topic but since it had all the BG1 companions I guess I'll ask about something I never thought I'd even think or remember about again:

    One of the only mods I've ever installed in BG's ever was called I think "The Darkest Day". It was a pretty good mod (in theory) that introduced some new NPC's, new gear, new kits and a lot of new quests but it was never properly finished and had a lot of bugs and crashes. Anyone know if that was ever finished properly? It was a SOA mod that was not compatible with TOB as far as I remember.

    I'd love to give that a try, some teenage nostalgia tied to that mod and wishing for the longest time that it would work properly.

    I remember it working on ToB when I played it. Also,I remember it being properly finished but I might be wrong. No EE version, though :/

  • Mantis37Mantis37 Member Posts: 772
    You can play it on EE, I played a BWS version of it before.

Sign In or Register to comment.