Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

No sound - update: How to fix it!

DerDuKeDerDuKe Member Posts: 88
edited December 2012 in Windows PC (Archive)
Hello folks,

Although I can hear a *click* when pressing "play" to start the game, I do not have any ingame sounds at all. No *clicks*, no voices, nothing. Is anyone out there with an idea how to fix that issue? Thanks in advance!

Edit (additional information):

OS: Windows 7 64-bit
Installer: BG:EE Standalone Installer
Sound Card: I guess it's an onboard Realtek

----------------------------------------

Edit (FIXES):

It's not clear yet what exactly causes the sound problem. A missing file (OpenAL) might be the reason for the missing ingame sound. Possible solutions:

i) "http://connect.creativelabs.com/openal/Downloads/Forms/AllItems.aspx
download the file: oalinst
unzip, install, blah blah blah
try running baldur's gate again. i did, and had sound! :)" (reported by @mursame2005)

or

ii) Download and install this file: http://connect.creativelabs.com/openal/Downloads/oalinst.zip (reported by @amikob)

or

iii) FOR WIN XP:
"Start > Run > dxdiag
Sound Tab
Slid the "Hardware Sound Acceleration Level" down the to minimum setting ("No acceleration")." (reported by @RomulanPaladin)

iv) FOR WIN 7 and 8:
"1. Go into device manager.
2. Select the X-Fi device under "Sound, ... controllers".
3. Update driver.
4. "Browse my computer..."
5. "Let me pick..."
6. "High Definition Audio Device"." (reported by @Kruno)

or

v) Re-install BG:EE with beamdog client (no need to remove the standalone version). Start BG:EE with the beamdog client and install OpenAL by doing so. Quit BG:EE, start the standalone and make sure you have ingames sounds now. (reported by @Arktosa)


Please let me know if one of the above suggestions helped you!

Post edited by DerDuKe on
«1

Comments

  • ArktosaArktosa Member Posts: 73
    Seems im not the only one to have this issues. Did you used the standalone installer ?

    jonaswashe
  • DerDuKeDerDuKe Member Posts: 88
    Arktosa said:

    Seems im not the only one to have this issues. Did you used the standalone installer ?

    @Arktosa

    Hi fellow! ;-) Yes, I did use the standalone installer. But I have no idea whether this affects the ingame sound in any regard?!

  • ArktosaArktosa Member Posts: 73
    Yeah im checking it on my real pc right now cause I was on my laptop... But i've been watching some dudes on twitch.tv livestreaming the game telling me that the standalone has some issues.

  • DrudenhausDrudenhaus Member Posts: 8
    edited November 2012
    I have the same issue, but with a different configuration (SPDIF out to DAC).

  • VirgilVirgil Member Posts: 1
    Having the same issue on Windows 8 x64, with a Soundblaster X-Fi using SPDIF out to connect to an Astro A50 head set. I also get the 'click' in the launcher, but nothing from the game.

    I am able to work around the issue by changing my default audio playback device in Windows to the headset USB connection, but having to swap it in order to play and then change it back afterwards is quite annoying. Disabling the USB connection as a playback device did not fix the issue, only setting it as the default did.

  • ArincArinc Member Posts: 5
    Same issue as well. Windows 7 x64, Soundblaster Xi-Fi using SPDIF out.

  • AsmodiAsmodi Member Posts: 10
    Same issue for me as well. I'm running my sound through the HDMI from one of my 6990's, ATI HDMI audio.

    Windows 7 Ultimate 64 bit
    AMD FX 8150
    ASUS Crosshair V w/onboard Creative X-Fi
    16GB GSkill RipJaws 1866mhz
    Radeon HD6990 x 2
    OCZ Vertex 3 240GB x 2 (Raid 0)
    2TB Western Digital Caviar Black HDD

  • wissenschaftwissenschaft Member Posts: 229
    edited November 2012
    I got the same issue. No sound in game. and all I'm using is my usb plug for my headset. I had to manually install OpenAL32.dll. I wonder if there are other .dll files missing related to sound that I need to install.

    Post edited by wissenschaft on
  • RistaraeRistarae Member Posts: 1
    Had the same problem, try running the stand alone installer again, that seemed to fix the sound issue for me at the least... also seemed to make the intro cinematic run smoother

  • DerDuKeDerDuKe Member Posts: 88
    edited November 2012

    I got the same issue. No sound in game. and all I'm using is my usb plug for my headset. I had to manually install OpenAL32.dll. I wonder if there are other .dll files missing related to sound that I need to install.

    @wissenschaft:

    I used the standalone installer to download BG:EE and then transfered it to my home computer afterwards with an USB stick. I then also had to manually install the OpenAL32.dll.

  • amikobamikob Member Posts: 4
    Ok I'v found a solution. Just dowanload this OpenAL driver 570kb install it and then report if it worked :)
    http://connect.creativelabs.com/openal/Downloads/oalinst.zip

  • wissenschaftwissenschaft Member Posts: 229
    I shall try this when I get home. I hope it works because besides slow movies, BG:EE will be running with no problems.

    I knew it had to be another driver I was missing. At least, I hope thats the problem.

  • savailsavail Member Posts: 10
    edited November 2012
    Hi all,
    I have the same problem - sound isn't working properly. There are some disruptions during intro video and sounds are played in the user interface very rarely. I tried downloading your file but it didn't work to me :(. Maybe someone has other suggestions?
    My specs are:
    Operating System: Windows XP Home Edition (5.1, Build 2600) Dodatek Service Pack 3 (2600.xpsp_sp3_gdr.120821-1629)
    Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4000+, MMX, 3DNow (2 CPUs), ~2.1GHz
    DirectX Version: DirectX 9.0c (4.09.0000.0904)

    and sound card is "Realtek HD audio output" I guess.

  • wissenschaftwissenschaft Member Posts: 229
    The file Amikob posted apparently just installs OpenAL32.dll but I have already done that. Without OpenAL32.dll, the game doesn't work at all. But with it, I still go no sound.

    I will try the file anyway when I get home but I doubt it will solve the problem.

  • DerDuKeDerDuKe Member Posts: 88
    I just finished downloading BG:EE with the beamdog client.
    I then started the standalone installer version and still got no ingame sound.
    After that I started BG:EE via the beamdog client and it had to install this OpenAL file before it could start the game. The game then started and I got to hear ingame sounds (yeah!).
    I closed the "beamdog version" and started the "standalone version" and surprise surprise: I got ingame sound for this version as well! I don't know whether this is the easiest way to get it running with sound, but it works. It's also possible that @amikob 's link helps already. Will update the op with possible solutions now. Greetings and may the force be with you (or something similar I guess... :-))!

  • alaundoalaundo Member Posts: 131
    Installing amikobs file didnt help, still have no sound wether by launcher or standalone. Starting to get so fuking pissed at this buggy pos..

  • borinotborinot Member Posts: 3
    didn't help here neither, the sound only works using analog out, doesn't work with optical out. I

  • DerDuKeDerDuKe Member Posts: 88
    Hm... So the only solution is to reload it with the beamdog client which is basically a re-install. I guess you gotta try that one @alaundo and @borinot ...

  • BarlakCWBBarlakCWB Member Posts: 2
    Greetings!

    Well, I have these problems here:

    Intro movie flickering/lagging (I don't know the term for this).
    No sound.

    I've tried what DerDuke proposed (lauch client), but didn't work.

    My specs:

    Win7 Ultimate 64 bits
    GeForce GTX-550 Ti (plugged in a multimedia monitor through HDMI cable)
    AMD FX 8120 processor
    8Gb DD3 RAM
    Audio onboard (ASUS M5A78L-LE)

    Any hints? :/

  • AsmodiAsmodi Member Posts: 10
    edited November 2012
    Tried re-installing with the Beamdog client as well and it did not fix the issue for me either.

    Edit: Neither did installing that OpenAL file.

  • wissenschaftwissenschaft Member Posts: 229
    edited November 2012
    Try this:
    ourz said:

    Ok, go to control panel, sound and sound devices. Click sound devices tab, and for your selected sound ouput unit, click advanced. Go to the performance tab, there you will find a slider for hardware acceleration.

    This is for winxp, have no idea how to do it on other OS.

    A slider must be set on 2 (from 4 in my case)

  • AsmodiAsmodi Member Posts: 10
    wissenschaft, if that was directed towards me, I'm on Win7 and as far as I can tell there is no hardware acceleration option to be found anywhere.

  • KaldaienKaldaien Member Posts: 17
    edited November 2012
    Asmodi said:

    wissenschaft, if that was directed towards me, I'm on Win7 and as far as I can tell there is no hardware acceleration option to be found anywhere.

    Windows Vista/7 (6.0/6.1) actually use a different driver model for sound. Hardware acceleration is irrelevant in the traditional sense. In fact, without something like OpenAL, EAX no longer functions in the new driver model - it used to be a DirectSound extension, which is no longer supported beyond Windows XP.


    Regarding others comments on manually installing OpenAL32.dll:

    I am a professional engine developer, and have quite a bit of experience with OpenAL actually. One thing I can say is that installing OpenAL32.dll alone is insufficient, you ***ABSOLUTELY*** need to run _oalinst.exe_ from Creative Labs' website (I imagine the Beamdog client should have taken care of this runtime dependency, as I know steam would have) to get OpenAL software working on Windows.



    UPDATE:

    To make life easier, I have provided a link to the file you need to use to PROPERLY install OpenAL:

    http://connect.creativelabs.com/openal/Downloads/oalinst.zip

    Zeckul
  • AsmodiAsmodi Member Posts: 10
    I figured as much. Thank you for the clarification though Kaldaien. I ran the oalinst.exe from Crative and it did nothing :-(

  • DerDuKeDerDuKe Member Posts: 88
    Kaldaien said:

    Asmodi said:

    wissenschaft, if that was directed towards me, I'm on Win7 and as far as I can tell there is no hardware acceleration option to be found anywhere.

    Windows Vista/7 (6.0/6.1) actually use a different driver model for sound. Hardware acceleration is irrelevant in the traditional sense. In fact, without something like OpenAL, EAX no longer functions in the new driver model - it used to be a DirectSound extension, which is no longer supported beyond Windows XP.


    Regarding others comments on manually installing OpenAL32.dll:

    I am a professional engine developer, and have quite a bit of experience with OpenAL actually. One thing I can say is that installing OpenAL32.dll alone is insufficient, you ***ABSOLUTELY*** need to run _oalinst.exe_ from Creative Labs' website (I imagine the Beamdog client should have taken care of this runtime dependency, as I know steam would have) to get OpenAL software working on Windows.



    UPDATE:

    To make life easier, I have provided a link to the file you need to use to PROPERLY install OpenAL:

    http://connect.creativelabs.com/openal/Downloads/oalinst.zip
    This link was already posted by amikob and unfortunately it did not help. Why? I don't know. Maybe OpenAL is not the (only?!) reason for missing ingame sounds?

  • EZYEZY Member Posts: 12
    i have the same problem...this sucks

  • RomulanPaladinRomulanPaladin Member Posts: 188
    This solution worked for me:

    Start > Run > dxdiag
    Sound Tab
    Slid the "Hardware Sound Acceleration Level" down the to minimum setting ("No acceleration").

    All the sounds work properly like this.

  • EZYEZY Member Posts: 12
    edited November 2012
    The problem on my end seems to be the game doesn't run sound though spdif out or digital out. Which is quite strange considering that I've never had this problem with a game including the old BG games.

    there is no hardware acceleration option for me under the sound card.

  • RomulanPaladinRomulanPaladin Member Posts: 188
    EZY said:

    there is no hardware acceleration option for me under the sound card.

    Er, are we talking about the same thing? The setting I was referring to is accessible in dxdiag.exe, not necessarily the sound card application itself.

  • EZYEZY Member Posts: 12
    edited November 2012
    yes, I tried this, didn't have an option for this under sound. Under my sound tab, it references my sound card with no hardware acceleration in site

Sign In or Register to comment.