Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Soultaker dagger... please help me... I messed up

SkySky Member Posts: 3
Hello!
Please help me. I messed up. I went to Durlag's Tower before Ulgoth. (Spoilers ahead)

When I defeated the Demon Knight, I either left the Soultaker dagger in the room OR I sold it, not knowing it was a quest item needed to face Aec'Letec.
I searched all of the Tower... nothing.
I checked every available person I knew who could buy items from me... no dagger.

So, my friend helped me get the EE Keeper. We put the dagger in my inventory in one of my save games. It's there now.
When I talked to the Hurlan character in Ulgoth, he still reminds me to go get the dagger.

If I had to, I could go back to an old saved game and redo much of my game... I did almost everything in Baldur's Gate. I'd love to avoid redoing all of those quests!

Am I doomed?

Comments

  • typo_tillytypo_tilly Member Posts: 5,681
    I don't know what it would be, but there should be some sort of quest trigger you can switch on in the console. Someone should know. Keep checking back here. :)

  • ZaxaresZaxares Member Posts: 472
    edited August 23
    It sounds like you probably missed getting the dagger from the corpse of the Demon Knight (it might be one of those rare situations where it's automatically added to your inventory, but if your inventory was full at the time, it just vanishes altogether), and that would have triggered the script that updates the quest. Maybe try reloading to a save game before the Demon Knight, make sure you have space in your inventory, and try again?

    If not, you can probably try fiddling with the global variables that tracks the quest. I don't have time to look into it at the moment, but I can try later this evening.

    EDIT: OK, so after peeking into the variables it looks like the correct state for the variables Hurgan needs to continue the quest are:

    Global("Cult1","GLOBAL",1)
    Global("Hurgandemon","GLOBAL",0)

    You can try modifying them in your save game with EE Keeper, then try talking to Hurgan again and see if that progresses the quest. Btw, did you get attacked by cultists on your return to Ulgoth's Beard? I suspect that's the encounter that sets the "Cult1" variable to 1, but it probably didn't trigger because you didn't have Soultaker on you when you returned to the village. You could also try leaving Ulgoth's Beard, then returning to it with Soultaker in your inventory and see if the cultist attack spawns normally.

    Also, this thread should be in the BG1 forum, not BG2. ;)

    Post edited by Zaxares on
    typo_tillyJuliusBorisov
  • SkySky Member Posts: 3
    D’oh! I apologize for this being on the wrong thread. I’m mad at myself! I spent a long time searching these forums looking for Soultaker and after I logged in to make a new post, my bad eyes told me I was clicking BG1: EE. I’m sorry.

    I wish I could remember if I even saw the dagger after I defeated the Demon Knight. It’s 100% possible my inventory was full when it died. I’d done all of the Tower beforehand and had collected much! I admit I didn’t know that could happen, it vanishing!

    I was not attacked upon entering Ulgoth’s Beard, and I’m certain it’s because I lacked the dagger! When I get home, I will jump on my computer and try that idea (leaving Ulgoth, then returning to see if that triggers that stubborn Hurgan!). That idea makes a lot of sense.

    I had a friend help me with the EE Keeper (I’ve always played without it, so it’s sadly new to me), so I’m unsure about the “global variables,” I’m sorry! I’ll have to do some experimenting with that if the idea above doesn’t pan out.

    If I’m forced to redo some of the Tower, I’ll make sure I have room in my inventory before I face off against the demon!

    Thank you for your help, it’s much appreciated!

    JuliusBorisovtypo_tilly
  • ZaxaresZaxares Member Posts: 472
    No problem! Hope the solution works. :)

  • SkySky Member Posts: 3
    First of all, thank you to whoever moved this to its proper location.

    Secondly, Zaxares, I could kiss you! That worked! I was so worried I would have to redo so many quests, and that has been avoided entirely. I appreciate it so much, and thank you thank you thank you!

    (Now onto Aec'letec!)

    typo_tilly
  • ZaxaresZaxares Member Posts: 472
    Sorry, I only accept kisses as rewards from lovely elven lasses. ;) Glad to hear it worked though! Which solution did you use, adjusting the variables or just revisiting Ulgoth's Beard with Soultaker in your inventory?

    And good luck with Aec'Letec!

  • BalquoBalquo Member, Developer Posts: 2,733
    edited August 25
    Do you still have the save when you first noticed the dagger missing? If so, could you attach it?

Sign In or Register to comment.