Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BGEE and macOS Catalina can't find save games

So I waited for a couple of point releases before installing Catalina 10.15.2. I just tried to launch BGEE, which I know is 64bit. It launches, but it isn't finding my save games or my settings. I can tell about the latter because it starts unscaled and lists information from the DragonSpearUI mod. when I get it scaled, I can select Load Game, but nothing is listed.

Does anyone know what the problem might be? I'm near the end and really don't want to start over. Thanks.

Comments

  • bobbd2000bobbd2000 Member Posts: 9
    Just solved the problem. Catalina is very picky about which apps can access your files and folders. Just because an app had access under Mojave or prior macOS versions, doesn't mean it has access under Catalina. Even if the app created the files or folders in the first place.

    I was reading about how to solve some Catalina issues and that jumped out at me. So I launched System Preferences, open the Privacy tab under Security & Privacy, unlocked by entering my admin password, and then added Baldur's Gate Enhanced Edition and gave it Full Disk Access. And lo and behold, when I launched, I had full access to my save games and the settings were as I left them before Catalina.

    In case you're thinking that granting a game full disk access is too much, keep in mind that Catalina protects all system files and folders even more than Mojave did. Granting BGEE full disk access is no more dangerous than the access is had under Mojave.

    So, problem solved. Maybe this will help someone else.

    Permidion_Starksmyth25JuliusBorisov
Sign In or Register to comment.