Skip to content

NWN:EE multiplayer not letting me online

zealcezealce Member Posts: 2
So I got NWN:EE on Steam for the recent sale. I played the OC module to learn the mechanics and have recently tried to start playing multiplayer on Arelith's Surface world. Unfortunately, when I tried to make a character, the game gave me an error message that my CDKey or Player name mismatch. After looking up possible solutions, I have tried changing my player name multiple times, but the error keeps stopping me from making a completely new character. I have not been able to even access the multiplayer component of the game yet because it keeps telling me about this CDkey and Player name mismatch, I have not messed with my CDkey in any way, but it still won't let me on. I would like to try multiplayer and would like some adivise,

Thank you, Zealce.


  • zealcezealce Member Posts: 2
    I got it working, thanks boys
  • KaizenKaizen Member Posts: 1
    I am also having the same problem. I can play on the Ravenloft server no problem and on the Arelith PGCC but I can't get on any of the other Arelith servers. I have looked up my CDkey and made sure it matched the public cdkey and it does. Any suggestions and help would be appreciated.
  • AbuzzerAbuzzer Member Posts: 1
    Hello! I can not connect on my Android if i want to play multiplayer....
Sign In or Register to comment.