Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Solved] Resting resulting in unpausable pause, Beamdog -> Steam

AugorAugor Member Posts: 2
edited May 2020 in Troubleshooting
Me and my friend are having a curious problem, with resting in-game.

So, to start off here's what we are working with. I have a steam version of BGEE and SoD and my friend has Beamdog version of BGEE and SoD, latest official version of the game

We have few mods installed in our games. I have ran the DLC Merger, due to playing steam version, which he does not have (due to not needing it). On top of this we have installed BG1NPC v.24.6 and BG Unfinished Bussiness v16.0, in that order.

We've made sure that we are running the same version of the game and have exact same settings and options chosen for the mods. All of this works together as we are able to play together online and the mod content functions as it should.

However, we ran into an issue that's bit peculiar (the peculiarity comes towards the end).

My friend with Beamdog client is the host in these scenarios and I with steam client am joining as a player.

Resting outdoors, whether it is in in town outdoors or in wilderness (weren't able to test dungeons). His game plays the resting animation (campfire) as it should but mine does not. This results me getting stuck in a grey scale pause -mode. Which both of us are unable to unpause. We are able to still interact with the world to the extend as if it would be a normal pause, our characters do react if we select them, and we can give commands as normal.

Resting in an inn, however, functions as it should and we both get the resting video played and game unpauses as normal.

I've read up on the matter and it seems it's similiar to the a problem from a while back. Then it was suggested to make a copy of the "rest.wbm" twice and rename them into "niteday.wbm" and "daynite.wbm". This we both did and nothing changed of our situation. There were also suggestion about changing the video renderer in the graphic settings, alas nothing changed.

What makes it peculiar is the testing we conducted. If we would start up a game alone (whether it's offline or online game, as long as we were alone without the other) we were able to rest as normal at inns or outdoors/wilderness. So, when I was playing alone it worked fine and I got the video played for me and it unpaused and continue as normal, same for him. We also learned that if I'd leave the game when it was stuck in an unpausable state, the game would resume for him and I could rejoin and continue as normal.

Then we tested if I (steam client) host and he (beamdog client) joins as a player and we learned, that when I'm host, we are able to rest as normal outdoors/wilderness. The video played for me and for him, and after it finished (whether we skipped or not didn't matter) the game unpaused as normal.

So, there's something about Beamdog client being the host and steam client being the joining player that messes up the resting outdoors/wilderness. Sadly we would like to continue playing the game with him being the host (beamdog client) and me being the joining player (steam client).

Thus, I'm here to pick the brains of the wiser folk. Would anyone have any insight to the problem we are having. A potential fix for it? I've only been able to find the niteday/daynite workaround along with a thread where they started to use direct connect and it fixed the problem. There's few workarounds we are able to employ to play the game, but of course if anyone has a potential idea for a fix, I am all ears. Would be great if we could employ a fix and not having to worry about rejoining everytime we wish to rest outdoors/wilderness.

Post edited by Augor on


  • AugorAugor Member Posts: 2
    Going to bump this as I've finally figured out a way to fix the problem, and I want to leave a potential solution for future if someone comes looking.

    The problem lies in the daynite, niteday as we previously thought it might, but to fix it making a copy of "rest.wbm" and renaming it accordingly didn't suffice.

    On top of making a copy and renaming the "rest.wbm" file, we also had to take a look at the "Baldur.lua" file in documents->BGEE folder. This file had differences between steam and beamdog version of the game, notably the "movies" section were missing "niteday" for the beamdog, and both for steam. Thus all we did was to add niteday and daynite for both and suddendly resting worked like a charm. On top of this we also made sure that the files on the movie section was exact for both and made sure we had all of the .wbm-files present.

    A curious problem with a solution that, at least I, wasn't initially even considering to be the root of the problem.

Sign In or Register to comment.