Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

8193.13 toolset under wine broken - FIX

meaglynmeaglyn Member Posts: 95
edited May 2020 in Technical Support
The latest retail update breaks the toolset under wine on my Linux box.

/data/space/beamdog_lib/00785/bin/win32> wine nwtoolset.exe -userdirectory /data/space/Neverwinter\ Nights/
0009:err:module:import_dll Loading library OPENAL32.DLL (which is needed by L"Z:\\data\\space\\beamdog_lib\\00785\\bin\\win32\\nwtoolset.exe") failed (error c000035a).
0009:err:module:attach_dlls Importing dlls for L"Z:\\data\\space\\beamdog_lib\\00785\\bin\\win32\\nwtoolset.exe" failed, status c0000135

This worked before the update. I tried making an all caps copy of that dll but it didn't help. Am I missing something?


Post edited by meaglyn on


  • SherincallSherincall Member Posts: 387
    Try copying the executable out of `bin/win32` into a sibling dir, like `bin/linux-x86` or `bin/toolset` and running it from there. Alternatively, try renaming/deleting `bin/win32/openal32.dll`.

    The dll in the folder is 64bit for the game, and wine has a slightly different DLL load behavior than native in this case. Native will ignore that DLL and go into system32/ or equivalent, but wine reports a load failure and dies.

  • BlakBatBlakBat Member Posts: 8
    I can confirm that renaming openal32.dll is enough to get the toolset working again.

  • jimdad55jimdad55 Member Posts: 55
    Had the same problem and Julius on Steam solved it. My solution was to c/p the .exe file into bin/MacOS and it opened normally.

  • meaglynmeaglyn Member Posts: 95
    Awesome! Just moved the binary to linux-x86 where the other things I run live and changed my launcher. All good again. Thanks, all of you.

  • jimdad55jimdad55 Member Posts: 55
    @meaglyn, have you noticed any crashes since you moved it? I've got mine working again but way more crashes than before. It's almost as if it's on a timer. After about five or six minutes with the toolset open trying to do two things quickly seems to bring the dreaded beachball. I've got about five or six areas in my module so it may be that but just in case I'd save more often.

  • meaglynmeaglyn Member Posts: 95
    I played with it a bit more and have not had any more issues than usual. I get error message when I close the script editor and it tries to rebuild the resource tree on the left. But if I click through everything still works. That's been like that forever though...

  • gpeddinogpeddino Member Posts: 48
    I had the same problem on Mac, and deleting openal32.dll did the trick. Thanks!

  • jimdad55jimdad55 Member Posts: 55
    Those working on a Mac, if you get a chance could you try something for me?

    The file we were asked to delete/rename concerns "Open Audio Language" I believe. Since then I have taken out some custom sounds I used in the module I am working on and the crashes have largely stopped. ( Nothing wrong with the files - they worked perfectly before this). To test it out I went to the Advanced tab in Properties and changed an animal's soundset from cat to tiger . Immediate crash of the module. Repeated every time.

    Don't know if this is just my setup or more general.

Sign In or Register to comment.