Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Cannot load Modules

WebShamanWebShaman Member Posts: 487
This is the problem I am now having, having updated to the newest version of NWN EE from Beamdog directly:

I cannot load any Modules.

I can join PWs where I play, I can load a Module up in the NWN Server (can't join it however as a Player) and I can even join the Module as a DM (with the DM Client).

It does not matter what Module it is.

I am running Windows 10, with Nvidia. I have done the adjustments to the Nvidia settings to allow the Toolset to work (and it does).

I can create new characters in any modules btw - the problem is when I try to use one of my pre-generated characters (in a mod like Pretty Good Character Generator). If I try to directly load up the module as a new game, it times out and crashes. I even tried loading it up in the NWN Server (it loads fine) and tried to join - it shows me logged in on the GUI, but the NWN game itself crashes. I can join as a DM without problem.

Note that everything used to work fine before I installed the newest version of NWN EE from Beamdog.

I am thinking that maybe something is going on with my local vault pre-generated characters?

Can anyone help me here?


  • CalgacusCalgacus Member Posts: 272
    edited June 2020
    Just in case it is related: I have just started replaying the OC with the latest patch and whenever my pc gets killed and I try to load the a saved game I get an error message -
    Could not load the module.
    Could not unpack the module
    -- get and bounced back to the main menu. From there I can reload my saved game. Even if I don't get killed I cannot reload a saved game from that deeper menu.

    PS: Maybe the code for that inner menu does not always read values from the nwn.ini file where I have changed most of my NWN folders to my a folder on my D drive. Hence after the menu displays the saved games the piece of code that tries to open them looks in the wrong place ( my C\...\Documents\Neverwinter Nights\ folder instead of my D\Neverwinter Nights\ folder).

    @WebShaman did you change any NWN folders in your nwn.ini file?

    Post edited by Calgacus on
  • CalgacusCalgacus Member Posts: 272
    edited June 2020
    Now I am at the end of Chapter One of the OC and when the next chapter tries to load I get that same error so I cannot proceed with the campaign. This is now a showstopper for me. Since the boards are not swamped with other people reporting the issue I guess there is something about my system that is odd. I have nothing in my development or override folder and nothing in my userpatch. There are many itemes in my steam override folders - but mostly just portraits and models.

    -- OK, got it, as suspected once I move my saves folder back to its usual place on my C drive and update my nwn.ini file to point there ( as shown below ) the problem is gone.
    HD0=D:\Neverwinter Nights
    MODULES=D:\Neverwinter Nights\modules
    SAVES=C:\Users\username\Documents\Neverwinter Nights\saves
    # was prviously set to SAVES=D:\Neverwinter Nights\saves

  • SymphonySymphony Member, Developer Posts: 136
    edited June 2020
    @WebShaman This sounds like NWN has 0 access to your user directory. The game tries to save files there, but if it cannot, the game can still run. Sometimes. With default settings. The game might have read access, that would be why your modules appear, and your characters appear. When you start a game, the game takes the .mod from it's original location, and stuffs it into the CURRENTGAME folder. This is like a live-saved game that is re-writing the module in the folder (instead of the original) as you play, kind of like the toolset, but, deleting creatures and stuff by killing them instead of the delete button in the toolset.

    When you play multiplayer, your files are on the server computer. When you use nwserver, as a player you are probably restricted to the server vault, but as a DM you can use your "local vault", which changes the permissions a bit.

    This is possibly some sort of Windows folder access problem. It could be a permissions problem, it could be something new. I've had players have problems like this because Dropbox or OneDrive offered to 1) Backup your stuff 2) Save space on your machine!, and they do this by taking the stuff off of your computer and onto their internet servers, and you download the files when you need them. This kind of "calls dibs" on the folders and filenames that NWN needs to use, it cannot get them from the internet like your file explorer can, and it can't make new ones in the reserved space the files "already exist", and things get weird and ugly.

    If this sounds familiar to you, look into that. If it doesn't, find your Neverwinter Nights folder in Documents (and tell me if there's like a Neverwinter Nights.0 folder, or no Neverwinter Nights folder), and rename it to something like NWNOLD, and then launch the game again. It won't have your characters and modules, it will be like a fresh install, but you will be able to tell if you can make new games, new saves, new characters, etc. Your original files will all be safe in the NWNOLD folder until you need to move them over, or rename the folder back to Neverwinter Nights (after deleting the new one I guess).

    @Calgacus Your issue is slightly different, but I have responded to your ticket.

    Post edited by Symphony on
  • JFKJFK Member Posts: 213
    After the last dev update I've been experiencing similar issues. I filed a bug report.
    My symptoms are that I can start any new OC, load any saved game (custom or OC) just fine. But I cannot get to any New -> Other Modules... modules, crashing after a long wait when I click that button.
    I do think there was a Windows (10) update recently, but I'm not sure if that's the issue or not.
    I renamed my Documents/Neverwinter Nights folder and started the game. Other Modules... load as expected.
    Not sure what I should do now though. I have paths edited so I can store the big stuff on my big hard drive, and the small stuff on my SSD.

  • cirjay238cirjay238 Member Posts: 8
    I want to buy those premium modules in the in-game store. But due to these bugs im very hesitant to purchase them.

  • JFKJFK Member Posts: 213
    cirjay238 wrote: »
    I want to buy those premium modules in the in-game store. But due to these bugs im very hesitant to purchase them.

    I haven't had any problems with the Premium Modules loading.

  • SymphonySymphony Member, Developer Posts: 136
    @cirjay238 If you're talking about the in-game store in iOS, that's a completely different topic.

    The issues above have to do with NWN User Directory folder usage in Windows. Meanwhile, the premium modules in Windows don't go into the user directory anyways, they go into the install directory, which might be in your Steam directory, or your GOG library, etc.

    The "Other" modules mentioned in this report are not "other modules than the original campaigns that are Premium, as, the Premium Modules have their own submenu.

Sign In or Register to comment.