Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

NWN EE Random Freezes - sometimes resulting in a hard crash.

I have been having some strange issues with NWN of late - which seem related to whenever I am connected to my network. When I am, NWN will periodically go non-responsive (music and sound still plays, but the game screen and gamplay itself will freeze). This happens often during play - and is guaranteed to do so at least once when loading the initial "splash screen" that appears straight after the intro videos. Sometimes it recovers in 10 or so seconds, sometimes not.

NWN provides no logs of this - the only contents of "nwclientLog1.txt" being "nwsync: reconfigured successfully".

On closer inspection, it seems if I disable my Ethernet connection, it works perfectly. This lead me to taking a peek at what was happening with a processmon. Results of which are that NWN seems to continuously try connecting to "Jim-Chillblast" (the hostname of the PC I run the game on), with different ports. These take a few seconds each time and it continuously loops around this with apparently no end in sight. This APPEARS to be the thing that's creating these freeze and crashes, but I have no idea what to do (if anything) to fix it.

I have tried disabling IPv6 to no avail and there is nothing out of the ordinary with my connection - other than my router not supporting NAT Loopback. Given the request is a local one, pointing to a local resource (the originating computer), I doubt this has anything to do with it - but thought it worth mentioning as you never know.

DXDiag reports no issues with graphics or sound drivers... and literally everything else works fine. I have tried all the obvious stuff such as uninstalling, verifying files, compatibility mode, removing mods, deleting the settings folder in Documents etc. At a loss as to how to fix it at present - if there is indeed anything I can do. It makes the game completely unplayable though.

You can see in the attached screenshots how long the TCP requests take (and there are a lot of them - all to the same place). So what's going on here? Why does this happen when connected to the internet/LAN, but not otherwise - and what on earth can be done to fix it?

gveqstnrji7x.png
ufkijt2jxie9.png

Comments

  • nivniv Member, Moderator, Developer Posts: 400
    Hey,

    * Do you run any kind of antivirus?
    * Is this via Steam? Is Steam Overlay enabled?

    NWN:EE itself doesn't connect to 9977 tcp, or any other port on localhost, by itself.

    JuliusBorisov
  • JimbobslimbobJimbobslimbob Member Posts: 206
    Hi Niv. The machine is running standard Windows Defender, nothing additional. I have tried with the Steam overlay off to no avail. I have also tried with the firewall off and Nvidia overlay turned off and get the same results - it only ever works correctly when Ethernet is unplugged or disabled.

  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited September 2020
    A (weird) update:

    I noticed NWN kept asking on the network about a particular IP address (192.168.0.8) - which no device on my network has. I thought that perhaps the continual queries to it (and fails) could be causing issues.

    NWN kept trying to save a files in
    192.168.0.8\Archive\resources\source\Models_01\Animations\NULL.mdl
    192.168.0.8\Archive\resources\source\Models_01\CreatureModels\NULL.mdl
    192.168.0.8\Archive\resources\source\Models_01\PlayerModels\NULL.mdl

    ...so, for a test, I tried setting my computer's IP to this and it started working without freezing again. WTF!!??

    So... what is going on here? Why is NWN constantly trying to save model files on 192.168.0.8? I cannot keep my IP as this for "reasons", so need to know why and how to stop this.

    EDIT: Infact you can even see this occurring in the above screenshots.

    Symphony
  • nivniv Member, Moderator, Developer Posts: 400
    edited September 2020
    Can you check nwn.ini to see if some weird alias is set up perchance? The only thing I can think of is the model compiler trying to save stuff out, but that only triggers if you have the appropriate CLI switches set up.

    NWN itself certainly won't try to save anything to 192.168.0.8, or Archive/resources/.

    I have no idea what's going on here.

    JuliusBorisov
  • nivniv Member, Moderator, Developer Posts: 400
    Ohh, I found it in the code. I stand corrected.

    This is related to supermodel loading, and a humongous hack back from 200x.

    It's trying to read from the "n:" drive when a supermodel cannot be found. Apparently that resolves to that particular IP on your end.

    Do you have any "broken" custom content (with missing supermodels) in your load chain?

    Good grief.

    JuliusBorisovJimbobslimbob
  • nivniv Member, Moderator, Developer Posts: 400
    Will be fixed in .16. TYVM.

    JimbobslimbobJuliusBorisov
  • JimbobslimbobJimbobslimbob Member Posts: 206
    Nice - Appreciate the assistance with this. I was just about to post up some Wireshark stuff relating to it (and port 9977 SYN requests), but it seems you have it under control.

    God only knows why this started happening for me, but I would guess it could affect others as well. I eagerly await the fix. In the meantime, I may as well post up the screenshots. NOTE: These ONLY occur during NWN being open, it's absolutely 100% not another process doing this.

    Cheers!

    Ref screenies:
    hhefuoh8fi95.jpg
    rtsluipcr6qd.png

  • nivniv Member, Moderator, Developer Posts: 400
    Do you have a N: drive in windows? That's what it's trying to read. No worries, it's just trying to read supermodels. It won't be writing anything.

  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited September 2020
    Additional: in regards to your question regarding "broken" custom content... I don't THINK so, as I have uninstalled, deleted remaining folders, deleted settings folder in Documents and the like. If there is something I missed, then I would be interested to know what it was - perhaps add that in some way to NWN logging? Just a thought - would make troubleshooting this easier.

    EDIT: No folder locations are incorrect in my NWN.ini that I can see:
    [Alias]
    HD0=C:\Users\[REDACTED]\Documents\Neverwinter Nights
    MODULES=C:\Users\[REDACTED]\Documents\Neverwinter Nights\modules
    SAVES=C:\Users\[REDACTED]\Documents\Neverwinter Nights\saves
    OVERRIDE=C:\Users\[REDACTED]\Documents\Neverwinter Nights\override
    HAK=C:\Users\[REDACTED]\Documents\Neverwinter Nights\hak
    SCREENSHOTS=C:\Users\[REDACTED]\Documents\Neverwinter Nights\screenshots
    CURRENTGAME=C:\Users\[REDACTED]\Documents\Neverwinter Nights\currentgame
    LOGS=C:\Users\[REDACTED]\Documents\Neverwinter Nights\logs
    TEMP=C:\Users\[REDACTED]\Documents\Neverwinter Nights\temp
    TEMPCLIENT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\tempclient
    LOCALVAULT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\localvault
    DMVAULT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\dmvault
    SERVERVAULT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\servervault
    DATABASE=C:\Users\[REDACTED]\Documents\Neverwinter Nights\database
    PORTRAITS=C:\Users\[REDACTED]\Documents\Neverwinter Nights\portraits
    AMBIENT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\ambient
    MOVIES=C:\Users\[REDACTED]\Documents\Neverwinter Nights\movies
    MUSIC=C:\Users\[REDACTED]\Documents\Neverwinter Nights\music
    TLK=C:\Users\[REDACTED]\Documents\Neverwinter Nights\tlk
    PATCH=C:\Users\[REDACTED]\Documents\Neverwinter Nights\patch
    OLDSERVERVAULT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\oldservervault
    NWSYNC=C:\Users\[REDACTED]\Documents\Neverwinter Nights\nwsync
    DEVELOPMENT=C:\Users\[REDACTED]\Documents\Neverwinter Nights\development
    MODELCOMPILER=C:\Users\[REDACTED]\Documents\Neverwinter Nights\modelcompiler

    Regardless, thanks for your help and I look forward to the fix!

  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited September 2020
    niv wrote: »
    Do you have a N: drive in windows? That's what it's trying to read. No worries, it's just trying to read supermodels. It won't be writing anything.

    N:\ is a mapped VPN network drive on my computer - only in use when connected to it.

    Haha - just checked - its IP is also 192.168.0.8! A temporary fix might be disconnecting that mapped drive then? It's inaccessible unless I am connected to the VPN - which could be the cause of the freezes when NWN is trying to read non-existent model files from it.

  • nivniv Member, Moderator, Developer Posts: 400
    Yes, making sure N: doesn't exist is a viable workaround until this is fixed in the game. Thanks for your patience on that. :)

    Jimbobslimbob
  • nivniv Member, Moderator, Developer Posts: 400
    Should be fixed in .16, shipped yesterday.

    JuliusBorisovSymphony
Sign In or Register to comment.