Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

{Help} A mod caused my Fighter class unable to wear any type of armor?

Karl_FranzKarl_Franz Member Posts: 7
I have installed tweak anthology, full plate&packing steel that is mostly suspicious edited the armor restriction for classes.

Now my fighter and related dual Classies eg.fighter/druid can't wear any type of armors , plate, chainmail, leather none of it can be wear by my fighter pcs. :#

Need some help, where can i find the file that could edit the class armor districtions, the game is become unplayble with fighter can't wear any armor. :'(

i have installed many other mod so can't reinstall mods to find which mod edited the armor restriction.

Find out some kit+class combination won't allow you to wear any armor, might as well be the kit that didn't allow me to use any armor or it bugged.

So, where to edit the kit and class armor restrictions.

Comments

  • ThacoBellThacoBell Member Posts: 11,901
    You didn't roll a Kensai, did you? They can't wear armor.

    Balrog99
  • Karl_FranzKarl_Franz Member Posts: 7
    @ThacoBell , just fighter for my pc. And the full plate mod now got me in a really awkward situation, the author set plate armor can not wear by mage, and robe can't not wear by cleric. now my poor Aerie with dual classies Mage/Cleric can't wear any type of armor.

    ThacoBell
  • sarevok57sarevok57 Member Posts: 5,378
    yikes, there are some solutions, but they are not what you are going to want to hear;

    #1

    this may be the "easiest" but it will be a pain because you will be doings this lots; what you can do is use EE keeper and force the armor on, it will still be red or whatever but it will be there in your armor slot, but if you ever take it off or grow up a level, then the armor will come off and you will have to ee keeper it on again

    #2

    you can get a game editing utility like near infinity and then go throw the pain staking process of checking every piece of armor and makin sure that the correct class combos can wear it, good news; realistically you only need to do it once per piece then put in your over ride folder and all should be good, bad news; you will have to do this with no doubt EVERY piece of armor in the game

    #3

    this one is no fun, but sometimes necessary; completely uninstall all the mods and the game and everything and delete all stuff ( although you can keep your save file ) and then re install the game and start installing mods 1 by 1 to see which one specifically does this, or perhaps it might not bug out the second time?

    #4

    other than that, you are pretty much SOL as the saying goes

    ThacoBell
  • StummvonBordwehrStummvonBordwehr Member, Mobile Tester Posts: 909
    edited November 17
    Hi @Karl_Franz
    I dont think “Full Plate and Packing Steel” is EE compatible - at least for the latest versions (edit: the EE version 2.2 being the latest compatible). That may be the reason for the errors.

    They is another mod that does something like Full Plate... The mod is Scales of Balance. The first component is called Yet Another Revised Armor System (YARAS), and does something like Full Plate... You could check it out, and see if it was something for you:
    https://github.com/UnearthedArcana/Scales_of_Balance
    And its compatible with IWD:EE as well.

    Post edited by StummvonBordwehr on
    Grond0
Sign In or Register to comment.