Skip to content

Durlag’s Tower L4 Stuck - Bug

I’m at level 4 of Durlag’s Tower labyrinth and I’m stuck from progressing.

I run through the whole level multiple times now, successfully completed two of the three compass riddles. My issue is the Stone Golem in the spider room - I answered incorrectly too many times and now all he says is “Durlag knows the penalty for speaking once more to the guardian. You are not he.” And he throws a fireball.

I’ve tried talking to it with different characters, sleeping, leaving the level and going back via staircase, talking to Durlag and his wife - nothing helps and thus I cannot seem to progress to the compass room the third and final time.

I can leave using the staircase or having the wife teleport me out, but I also can’t get back in when teleported out as there’s no way to re-enter the chess room.

TLDR- The stone golem won’t talk to me and so I can’t progress Durlag’s tower. If I leave then I can’t finish the labyrinth level because I can’t get back into the chess room.

HELP!

(FWIW I’m on Switch, latest version 1.0.4)

Comments

  • jmerryjmerry Member Posts: 2,644
    Huh. Checking that golem's dialogue, there's no second chance. You talk to it once, and if you answer anything wrong you're out of luck. I think the only recourse you really have, if you want to face the demon knight, is to go back to an earlier save.

    On the other hand, you shouldn't have a problem leaving, and exploring all but the very end of what's down there. Once you've gone down once, entering any of the elemental rooms will teleport you to the chess room. (There's a marker variable, bd_ar0506_event. If it's 0 and the elemental guardians are dead, the area script in the elemental rooms sets it to one and activates the teleport cutscene. If it's 1, the teleport cutscene increments it to 2, sends your party to the chess room, and then drops it back to zero.)
  • l3thological3thologica Member Posts: 8
    I don’t have any earlier saves.

    Also, I tried going in all four elemental rooms. I had read about that, but it didn’t work for me. (I did a side-save, teleported out of the tower, and tried going back through to see if that would reset the golem).

    I’m not sure what you mean about markers though. I’m on console, not PC.
  • jmerryjmerry Member Posts: 2,644
    I was just describing how the game's internal logic works - how the scripts involved handle the teleport. Those scripts should be the same in all versions of the game. What I quoted was from the latest game version (patch 2.6) in one of the computer versions.

    The teleportation down not working the second time? Now that's a bug. I know it was an issue at some points during the 2.6 beta; if it's live on the Switch version, that deserves official action. Report it.
  • l3thological3thologica Member Posts: 8
    edited March 7
    I went ahead and submitted a report. I think it’s kind of messed up for the game to block advancement for not answering a question right, though.
    Post edited by l3thologica on
  • l3thological3thologica Member Posts: 8
    “Sorry ma’am, I can’t rescue your son, there’s a statue that doesn’t like me.”
    “Sir, I apologize but I can’t recover your family’s heirloom dagger. I misspoke to some magical clay.”
    “Excuse me, Durlag. I can’t expel the demon from your tower. Your enchanted decoration won’t speak to me.”
Sign In or Register to comment.