Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[BUG] Possible to obtain the reward for the "Samuel the deserter" quest twice.

TanthalasTanthalas Member Posts: 6,738
edited November 2012 in Fixed
Problem: When talking to the "Flaming Fist Mercenary" in AR5500 while having Samuel's body in our inventory, the Flaming Fist Mercenary will notice it and ask about it. If we try to lie to him and he sees through it, we will immediately be granted the 50 gold reward (screenshot 1). If we then choose option 2 to hand over the body, we get another 50 gold reward (screenshot 2).

Expected Behaviour: The "Flaming Fist Mercenary" catching our lie should not immediately grant us the reward. We should only get the reward after we actually agree to hand over the body.

NOTE: This bug is not present in vanilla BG1.

NOTE2: Bleh, its a minor thing. Not worth the effort.

Post edited by Tanthalas on
meagloth

Comments

  • BalquoBalquo Member, Developer Posts: 2,733
    Everything is worth the effort!

    It appears the following has erroneously been put in Action 3 in flam4.dlg
    TakePartyItem("MISC13")
    GivePartyGold(50)

  • TanthalasTanthalas Member Posts: 6,738
    @Balquo
    Lol, the not worth the effort thing was about a minor glitch in the dialogues, I was having a hard time describing the problem.

    Basically the extra glitch is that when talking to the Flaming Fist Mercenary for the first time AND if you have Samuel's body in your inventory he'll ask you about it, and you can get away with lying regardless of the option you choose.

    However, if its the second time you're talking with the Flaming Fist Mercenary, he'll catch your lie (depending on a Charisma check perhaps?).

    In my opinion, it doesn't make sense for the same lie giving different results.

    I hope I explained this well.

    meagloth
  • CorianderCoriander Member Posts: 1,667
    The original bug was fixed along with changes to the quest earlier, so I'll look at the dialog issue.

  • CorianderCoriander Member Posts: 1,667
    K, fixed it.

    The Flaming Fist Mercenary no longer falls for your lies the first time you talk to him.

  • TanthalasTanthalas Member Posts: 6,738
    edited July 2012
    The first problem is not fixed. We still get the 50 gold twice.

    The second problem with the lies was fixed though.

    Post edited by Tanthalas on
    meagloth
  • TanthalasTanthalas Member Posts: 6,738
    @Coriander

    We still get the quest reward twice, the moment we get the double gold was only moved to another point in the conversation. I can't post a screenshot of the battle log but this is how its working now:

    Once the guard says the line:

    "Good job, here's your reward."

    The dialogue window is still open and we get the following battle log entries:

    The Party Has Lost An Item.
    The Party Has Gained Gold: 50
    Your journal has been updated.- Samuel the deserter.

    But then when I close the dialogue window by pressing the "End Dialogue" I get awarded another 50 gold.

    meagloth
  • BalquoBalquo Member, Developer Posts: 2,733
    edited September 2012
    @Coriander
    @Tanthalas

    I've fixed it. Also found an incorrect journal entry that should only be given if you do not have Samuel. Currently it was given if you do.

    COPY_EXISTING ~flam4.DLG~ ~override~ DECOMPILE_DLG_TO_D REPLACE_TEXTUALLY EXACT_MATCH ~TakePartyItem("MISC13") GivePartyGold(50) EraseJournalEntry(27086) EraseJournalEntry(27085) AddJournalEntry(27087,QUEST_DONE)~ ~~ COMPILE_D_TO_DLG <<<<<<<< flam4.d REPLACE_ACTION_TEXT flam4 ~AddJournalEntry(27085,QUEST)~ ~~ ADD_TRANS_ACTION ~flam4~ BEGIN 3 END BEGIN 1 END ~AddJournalEntry(27085,QUEST)~ ADD_TRANS_ACTION ~flam4~ BEGIN 12 END BEGIN END ~EraseJournalEntry(27086) EraseJournalEntry(27085) AddJournalEntry(27087,QUEST_DONE)~ >>>>>>>> COMPILE ~flam4.d~

    EDIT: Edited the OP title to include *fix included*

    Post edited by Balquo on
    Tanthalascmorgan
  • SethDavisSethDavis Member Posts: 1,812
    Potentially fixed - After brushing off the dust of ages @Balquo's moth-eaten fix has been applied

    Tanthalas
  • BalquoBalquo Member, Developer Posts: 2,733
Sign In or Register to comment.