Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Launcher Crashing after attempting to update. (resolved!)

DarkovanDarkovan Member Posts: 90
edited December 2012 in Windows PC (Archive)
i was playing the game fine earlier today for with no troubles, when i went to continue playing again a few moments ago the launcher told me an update was available and asked if i would like to download it or not. I hit yes i would but the launcher immediately crashed. I attempted to run the launcher again but now it just crashes immediately. It does nothing now, double click icon - crash and repeat. I tried running the launcher as admin, same thing, double click icon - crash. Also attempted to run as Xp service pack 2, 3 and vista, same thing.

On a side note and completely different problem:
When i was playing the game earlier i had your new Monk in the party however, everytime i rested he started spam initiating dialog with my player character, he would continue to spam no matter what i did and completly prevented resting i had to remove him from the party to continue playing. ( i tried reloading and resting he just started spamming again, went to new zones before resting and again he spammed me).

Post edited by Darkovan on

Comments

  • DarkovanDarkovan Member Posts: 90
    Processor:
    Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz (4 CPUs), ~2.3GHz
    Memory:
    2048MB RAM
    Display Devices:
    2x ATI Radeon HD 4800 Series in Crossfire

    Windows 7 32bit Ultimate.

  • DarkovanDarkovan Member Posts: 90
    I have found that i can still launch the game directly from the games executable in
    Install Location\Baldur's Gate Enhanced Edition\Data\00766\baldur.exe
    Launcher still not working however.

  • ataleroatalero Member Posts: 5
    I am having the exact same problem. No start when trying to install the game, and then straight crash to desktop. I tried everything you tried. Installing itunes, for some ridiculous reason. Installing both the client and the self installer. Installing them both to C drive. Running as Admin with every compatibilitry avaliable. Even tried Win 95 for shits and giggles. Oh, and the "update" to the installer dopes nothing either. I tried launching the Baldur executable from the C drive directly and it told me it was missing the DLL.

    I have an HP Pavillion laptop with an i5 intel proceesor and Intel HD graphics, 8 GB ram. Running Windoes 7 Premium 64 bit. I know the game has intel graphic issues, from the other forum (Beamdog). But I can't even get that far. Torchlight 2 runs great, as well as other new games. And they work great without having to jump through hoops to get them to run. Why does a port of a more than 10 year old game not run?

    Honestly, shame on me. I have the game on GOG, and it runs fine, but never got it running properly with Tutu. So, in rthe name of laziness, I decided to install this "enhanced" version. I wanted to support them, even though I think the price is a bit steep for you're getting. GOG is $10 cheaper, and it actually runs. But really Beamodog? No testing? No word for any of the development team when several people on both forums have been citing this as an issue? Nothing?

    I emailed beamdog supoport about the issue and have heard nothing yet. Will give it a while, but this is becoming a refund issue now. How does one go about getting a refund from these guys?

    --------------------------------------------------------------------------------

  • MontblancMontblanc Member Posts: 1
    Same problem as atalero, and also same desired solution. That is, refund.
    Though I think those 19.99$ are never to be seen again.

    I checked specifications, and everything appeared to be OK.
    Then I downloaded the installer, but I can't run even the Launcher to install it.

  • ataleroatalero Member Posts: 5
    What gets my goat is that they posted that it is not Intel graphic compatible AFTER they released it to the public (check out the beamdog website). That disclaimer was not there when I bought the game. So if you bought it before, with old specs, you are srewed. This is misleading, and I think teh only solution is a refund. I requested it and am waiting to hear back.

  • DarkovanDarkovan Member Posts: 90
    Sorry guys, my error is slightly different, my launcher and game both worked fine, was playing for hours no problem. My error occurred later on when it attempted to download an update of some kind, its only after it tried to update that the launcher its self is broken.

  • DarkovanDarkovan Member Posts: 90
    Im concerned that if i cant run the launcher i wont be able to install any bug hotfixes, such as my second bug listed above.

  • DarkovanDarkovan Member Posts: 90
    Oh, im using the standalone launcher btw.

  • cantripscantrips Member Posts: 12
    I have the exact same problem as Darkovan. Got that message that an update was available, the updater failed to download the update, and now I get this when I try and run the game:

    Description:
    Stopped working

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: BGEE.exe
    Application Version: 0.2.4.0
    Application Timestamp: 50b08f15
    Fault Module Name: KERNELBASE.dll
    Fault Module Version: 6.1.7601.17651
    Fault Module Timestamp: 4e21213c
    Exception Code: e0434f4d
    Exception Offset: 000000000000cacd
    OS Version: 6.1.7601.2.1.0.256.4
    Locale ID: 1033


    The game was working for me before this "update". I'm also able to run the game from \Data\00766\baldur.exe

  • cantripscantrips Member Posts: 12
    I discovered if you delete everything in the BG directory (except the Data folder) and re-run the 3MB installer, it replaces all of those files and the launcher will work again. However I'm still not able to apply the patch, it crashes when I press 'Apply Update'.

  • cantripscantrips Member Posts: 12
    The installer is BGEEInstaller.exe

  • awin123awin123 Member Posts: 55
    Same issue with the Beamdog launcher, this is just stupid. I had this exact same issue on launch, fine launch sucks I get it, but now I can't even play the damn game because of patches.

    I get ZERO crash log info and I didn't get any log info at launch either, the installer and Beamdog launcher just simply crash and do not work so while I'd love to provide something more helpful than just complaining I can't.

    Stop releasing this crap without fully testing it, for god sake.

  • DarkovanDarkovan Member Posts: 90
    thanks guys, glad its not just me on this one.

    on a side note in reguards to my second bug, when i returned to the town i recruited the monk from he started spamming me again asking if i was there to invite him back to the party, i had to kill him to make it stop, also, his boots sold to the vender for 13,000 gold also a bug?

    Shameless bump for support.

  • DarkovanDarkovan Member Posts: 90
    cantrips said:

    I discovered if you delete everything in the BG directory (except the Data folder) and re-run the 3MB installer, it replaces all of those files and the launcher will work again. However I'm still not able to apply the patch, it crashes when I press 'Apply Update'.


    hot tip, thanks.

  • DarkovanDarkovan Member Posts: 90
    Shameless bump for support.

  • chilimannenchilimannen Member Posts: 6
    Which drive letter is assigned to your game HDD ? I've had this problem applying updates with my game installed onto anything else than c: drives .. created a usb dummy, applied drive letter c:, copied folder struct and installed client, applying updates WORKS.

    Back your data folder and try this.

    I had the same error with steam, dummy usb solved updating as well.. the beamdog client also broke when trying to update..

  • DarkovanDarkovan Member Posts: 90
    its on my D:\ so ya, not on C:\

    if thats the case it sounds like it might be a registry issue, anyone know which line is pointing to C: ?

  • DarkovanDarkovan Member Posts: 90
    I copied the folder to C:
    Didn't help, launcher is still crashing -> still cant update.

  • TyxerTyxer Member Posts: 10
    Have you tried deleting the following folder?
    C:\Users\_Username_\AppData\Local\BeamDog

    That one holds you login information and Cache, it should reset the downloader.

  • DarkovanDarkovan Member Posts: 90
  • DarkovanDarkovan Member Posts: 90
    Shameless Bump for Support, week 2.

  • rexorvalgrindrexorvalgrind Member Posts: 4
    You have to update the launcher first to apply the patch, I had the same problem, crashing when I tried to Apply Update, so finally I press Play instead thinking that I wont be able to update the game. For my surprise (XD) the game crashed (yes! I´m the intel integrated ones), I closed it badly and when I restart the game a prompt has appeared telling me that the laucher was going to be updated, after a few seconds the installer opened and when I pressed Apply Update the update started downloading.

    Soooo, I think I´m really lucky

  • DarkovanDarkovan Member Posts: 90
    Yea except i cant update the launcher, i get the message that there is a an update for the launcher availible, do i wish to update the launcher or skip? If i hit update launcher nothing happens for a moment then i get 2 crash messages. After that i cant run the launcher, it just crashes the second i click on it. I have to delete the files for it an re-run the installer to get the launcher working again, however i still cant update - the same just happens over and over.

  • gynoidgynoid Member Posts: 5
    Had the same problem, so I tried changing the launcher's compatibility mode to Windows XP SP2. I was then able to download the update without the launcher crashing/freezing. Might work for you?

    Darkovan
  • DarkovanDarkovan Member Posts: 90
    OMG! it worked lol, i swear i did try this many times just after launch, i guess one of the recent updates fixed it so that it worked in compatability mode. Thanks for getting me to try that again! <3

  • RolfaoRolfao Member Posts: 2
    I uninstall everything and then re install the launcher, but now it says that i don't have enough space to download the game! (and i have more than 500 gb)
    I don't know what to do!

Sign In or Register to comment.