Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Crash on launch bug - windows 7 with ATI graphics

I'm running a Win7 32-bit system which is up to date, with up to date drivers for an ATI Radeon Mobility HD 5430, and have been having the same crash-on-launch problem as many other people. I've tried running as admin and in various compatibility modes, tired runnin it simultaneously with itunes and have downloaded the various visual basic files and openal, with no joy. I've also tried moving the data files to a plain directory straight off the c:\drive.

When I went looking for baldur.ini (as is suggested in the master fault thread), it was not in the [User]/Documents/Baldur's Gate - Enhanced Edition folder; that folder is entirely empty. A quick look at the event log shows that apparently I have a fault with atioglxx.dll, the full text in the log being

Faulting application name: Baldur.exe, version: 0.1.0.0, time stamp: 0x50b66b64
Faulting module name: atioglxx.dll, version: 6.14.10.10188, time stamp: 0x4c892629
Exception code: 0xc0000005
Fault offset: 0x002830f0
Faulting process id: 0x151c
Faulting application start time: 0x01cdcefdcd7718e0
Faulting application path: C:\bgee\Baldur.exe
Faulting module path: C:\Windows\system32\atioglxx.dll

Any further suggestions are welcome.

Comments

  • FootFoot Member Posts: 4
    I had this exact problem running the game on my netbook running win7 on an ati radeon graphics chip. Fixed the issue by upgrading my graphics drivers through the ati website. Your problem should hopefully be fixed with the same solution.

  • FunkballsFunkballs Member Posts: 3
    edited November 2012
    I also have this problem.

    On launch it says: "There was a problem with Baldur's Gate Enhanced Edition"

    When launching directly from baldur.exe it does nothing and the process dies after a few seconds.

    Repairing the install from the launcher runs a file check and does nothing implying the files are valid.

    No baldur.ini file is created in documents\Baldur's Gate - Enhanced Edition

    Error Log says:
    Faulting application name: baldur.exe, version: 0.1.0.0, time stamp: 0x50b66b64
    Faulting module name: atioglxx.dll, version: 6.14.10.11653, time stamp: 0x4ff3e437
    Exception code: 0xc0000005
    Fault offset: 0x00d84900
    Faulting process id: 0x1540
    Faulting application start time: 0x01cdcf20466765c5
    Faulting application path: C:\Games\Baldur's Gate Enhanced Edition\Data\00766\baldur.exe
    Faulting module path: C:\Windows\system32\atioglxx.dll

    ATI Radeon Mobility 4670
    Intel Core 2 Duo T9600 2.8GHZ
    4GB Ram
    Windows 7 Professional 64-bit

    I have the latest ATI Drivers downloaded from their site
    Driver Package 8.97.100.3-120703a-145534C-ATI
    OpenAL is installed and working correctly
    Visual Studio Redistributable 2008 is installed and working correctly
    I've also tried reinstalling and launching from a simple location (c:\bgee\)
    I only have one graphics card and no intel gpu.
    I've tried everything in the
    http://forum.baldursgate.com/discussion/8405/read-before-posting-master-technical-faq#latest thread to no avail.

    Original 1998 game runs fine :\
    Starting to question my purchase...

    Post edited by Funkballs on
Sign In or Register to comment.