Skip to content

Shield of Balduran stopped working please help

This just started happening. One encounter it reflects Paralyze, Hold Person, Fear, CSW, etc. Next encounter, it's not. I tried searching for previous discussions but had little luck - the search feature on this forum is... feature poor.

I even went back to an earlier save, for an encounter when it worked, and now it's not working for that encounter, either. These encounters are in the Southern Tunnels area of the Underdark.

The only thing unusual that happened between the "working" and "not working" encounter was that Imoen leveled up from M14 to M15, and I pressed her "Level Up" button and added a couple spells to the new slots.

I've tried unequipping it and re-equipping it (that's sometimes necessary with things like Boots of Speed), trading it with another character and back, and quitting and restarting the game. Nothing fixes it.

My only other idea is to uninstall and reinstall via Steam.

Running BGII:EE 2.6.6 on Mac OS 12.4 Monterey .

Comments

  • bughunterbughunter Member Posts: 3
    edited August 10
    Aha - poking around in some very old forums suggested it was some interference with MR.

    PC was wearing Robe of Vecna and Amulet of Power. Removed those, and the Shield of Balduran, and re-equipped them all, in that order, and now it's reflecting Beholder rays again. (see Edit 2 though)

    (Edit: that's an acceptable workaround, but the question remains: what caused it to suddenly behave that way?)

    (Edit 2: Well that worked MOMENTARILY until I switched PC's weapon from melee to missile via quick weapon slot, and now the Shield is back to bugged. It's not working at all, even on a companion, Minsc.)

    (Edit 3: A little more info: I can recreate this workaround, but only if I do NOT have the Strong Arm bow equipped. No matter how I equip it, either using the quick item button in slot 2 or using the inventory screen, nor in what order - before or after juggling the armor and amulet and shield. If the bow is equipped, the Shield of Balduran does not work. And this is new behavior.)
    Post edited by bughunter on
  • StummvonBordwehrStummvonBordwehr Member, Mobile Tester Posts: 1,158
    Hi @bughunter

    I do believe it is intended behaviour. If you equip a two handed weapon (bows, x-bows, 2 handed sword and such), you off equip your shield.
  • jsavingjsaving Member Posts: 1,079
    Yes, equipping a bow means you the player are deciding not to use a shield.
  • bughunterbughunter Member Posts: 3
    DERP. That's what I get for posting at 3am.

    Well, that solves part 2.

    If your SoB bugs out, redeploy your Robe of Vecna.
  • DurenasDurenas Member Posts: 508
    edited August 24
    This seems like a relic from when magic resistance actually would prevent friendly spells from affecting you(this included heals, as well). It's likely that the spell effect that the shield of balduran uses is such a custom effect that it's not flagged as 'beneficial' in the usual sense. maybe because it causes -1 strength?
Sign In or Register to comment.