Skip to content

Unable to paint triggers

I hope I'm not asking something that has already been asked. The search function on this forum seems to be very limited (or maybe I'm the one that's limited LOL).

I'm trying to paint triggers in the toolset. I'm doing it the way I always did it in the original NWN back in the day - I click the trigger in the palette, click each corner of where I want it to go, so far so good, and then I right-click to complete it, and..... nothing happens. No feedback of any kind. It just sits there waiting for me to place the next corner of the trigger. I also tried F2. I tried many, many other keypresses, key combinations, and hotkeys just in case something changed.

So I created a brand new module with no haks or anything, and tried it with the built-in generic trigger. Same result.

Then I thought maybe the toolset ini had some strange setting in it that messed it up, so I deleted that and let it create it fresh with defaults. No change, same problem on a fresh module with no haks.

I even tried clearing out the override, created a brand new module with no haks, and still got the same problem. I also tried validating the game files in Steam. I even fiddled with the settings in Nvidia's control panel. Restarted the computer.

I'm not sure what to do next. I don't see it being a performance problem, since I have a very fast computer (10-core with 128g ram and an M.2 SSD), unless it's just TOO fast. Does anyone have any insights, advice, or anything that might help? Not sure how I'm going to make a module without triggers...

Thank you!


  • TarotRedhandTarotRedhand Member Posts: 1,421
    Did you try double-left-click to close the trigger?

  • ProlericProleric Member Posts: 1,213
    That's how it's done. For a detailed account, see the Toolset Manual (available from Neverwinter Vault).
  • MelkiorMelkior Member Posts: 151
    That tricked me for a while with both encounters and triggers (encounters are just a specialised type of trigger; they're created in the same way). I believe that I too had to ask before someone told me that you just double-click when putting down the final corner and then it automatically joins that final corner to the first point you clicked on in order to close the loop and create the final corner.
  • IlderiaIlderia Member Posts: 4
    edited September 20
    Well, I posted a reply a couple of days ago with a link to a tutorial that says right-click and F2, but that post never seems to have made it. (it said something about being approved, I guess because of the link.) As it turns out that tutorial was for NWN2, not NWN, and I did a lot of modding for that game too, so that's probably where I remember that from. Thank you! <3<3<3
  • IlderiaIlderia Member Posts: 4
    Out of all of the things that I tried, that is the ONE thing that I didn't. Thank you so much! <3<3<3

    So the question is, when did they change that? All of the old tutorials like this one still say to right-click once or press F2, and that's exactly what I remember doing.
  • TarotRedhandTarotRedhand Member Posts: 1,421
    edited September 21
    That tutorial is for NwN 2 not NwN/NwN EE. The name of the project sort of gives it away - NWN2 Toolset How-To Triggers. AFAIK It has always been double left click for NwN.

    Post edited by TarotRedhand on
  • TarotRedhandTarotRedhand Member Posts: 1,421
    edited September 21
    The tutorial you want is - The Guide to Building Volume I – The Aurora Toolset Manual. There is a second volume that deals with designing modules if you are interested - The Guide To Building Volume II - The Design Manual.

  • IlderiaIlderia Member Posts: 4
    edited September 22
    Ya, I understand that now. I used to mod both NWN and NWN2, and I did it for years. The only reason I looked up the tutorial was because I couldn't get the trigger to paint, and that's because I was remembering NWN2 instead of NWN. And then I looked it up and ended up on a NWN2 tutorial without realizing it. LOL

    I guess I'm just getting older than I care to admit.

    Either way thank you for the help. :)
Sign In or Register to comment.