Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Several bugs in Baldur's Gate 2 Enhanced Edition: Items disappear from containers, etc.

I started a new game in Baldur's Gate 2 Enhanced Edition, after importing my character from Baldur's Gate 1. Everything was fine at first, but lately there have been several bugs. I noticed all of these issues while I was in the temple level on the Umar Hills quest.

1.) Items disappear from containers. I had numerous spell scrolls and quest-related documents inside a scroll case. I don't usually open the case when I am not at merchants so I'm not sure when the problem started but I went to take some out so that my mage could learn the spells and there was nothing in the case. I then checked my gem pouch, key ring, and book of rings containers and found that they were all likewise empty despite the fact that I had put numerous items into them. I later spoke to a merchant in the Athkatla bridge district and found that my containers were empty when I was in his store as well.

2.) The map had gone back to being unexplored despite my already having explored it. I hadn't played the Enhanced Edition for a while before I started this current game so at first I thought that this was just some new feature related to my taking the sun stones, but when I went back to the surface I found that the surface map was gone too as if I had never explored it and also the wolf that helps you and dies near the temple entrance was alive again as were the shadows that attack the party there. She had her dialogue and then died just as normally happens.

3.) When I got to the edge of the level I found that I could only travel to the gates district in Athkatla and that all the other areas were no longer accessible, I had been able to travel to several other areas prior to my going into the temple.

4.) I tried to use the ctrl J cheat to quickly get to the edge of the level so that I could see if these problems were also affecting other parts of the game. I found that the ctrl J cheat no longer works and nor does the ctrl R cheat that heals party members. I haven't tried to use any other ones.

All my recent saves have these problems, even ones from when I know these issues were definitely not there while I was playing them. I have one save from about a week ago (game time) in which the items in the containers are still there, but I would ideally like to not have to go back that far since I would need to repeat several quests points and at least one major battle. I also have no way of knowing if all these problems will simply happen again if I do repeat the past game week.

Does anyone have any suggestions as to what I might do in order to fix this?

Thanks!

Comments

  • Gate70Gate70 Member, Developer Posts: 3,773
    Hello
    It sounds like one of your saves was corrupted and has lost information (areas and containers are held in the SAV file as ARE and STO elements for example but also likely to affect merchants with changed stock). Saving from that point will have broken any later save, if you check your save folder the unaffected save is probably larger than the later ones.

    This can be caused for a number of reasons (e.g. security/antivirus software, crash while saving, full disk etc.). While we have tried to identify and notify when it happens this has not always worked and there have been a number of false positives where "insufficient disk space" messages are produced.

    Your only options are to either revert to the last unaffected save, or to try and use a tool such as NearInfinity to reconstruct ARE and STO content from your last good save into the latest usable save. If you have in the meantime revisited any of the lost areas, re-populated bags or traded with affected merchants it becomes somewhere between much more difficult and not possible to reconstruct a save.

    GusindaJuliusBorisov
Sign In or Register to comment.