Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Keep Losing Access to Cleric Spellbook after Nashkel Mines

ElysaeElysae Member Posts: 5
I've had the above-mentioned issue pretty much persist over several installs now. Meaning all clerics in the party upon completing the Nashkel mines lose access to their spellbooks (becomes greyed out as though they weren't a divine caster). Already memorized spells are fine as are clerics recruited after this point. Can't comment on druids as I never use Jaheira, but ranger/clerics and CHARNAME can be affected, too, though it seems with less frequency. 
As the problem doesn't always occur, I'm guessing, it's some sort of variable or effect getting stuck, though I can't tell which. Comparing an affected to an unaffected cleric in Keeper, I can't see any obvious differences in their effects and locals. Global variables I just know too little about to do anything with.
Several installs, in this case, meaning different OS installs, clean game installs with different patch levels and different mod loadouts. With the mods all of them shared being NPC Project, Scales of Balance, UB, Gavin, and Xan.
I've tried reloading and restarting, single to multiplayer save transfers, killing and raising affected NPCs, booting and re-recruiting, de- and releveling via EEkeeper and completely changing their class and then back again. Nothing fixes it.
As I tend to be level five or six by the time I head to the mines and thus often have no need to check my spellbooks for quite a while, I can't pinpoint the exact trigger.  The earliest I've ever noticed it was right after getting back to Nashkel and before talking to the mayor. The latest was Cloakwood. In affected games, I can then trace it back to the after the boss fight in the mines or however far back my saves go. 
Memorizing spells through Keeper is getting a bit annoying. 
Does anyone have any idea what's causing this or how to fix it?


  • GusindaGusinda Member Posts: 1,608
    Hi @Elysae, have you tried mod free, then building up the mods, one at a time, to see if one might be creating a problem? You might be able to use the same saved game (if Gavin is in your party, you might need to install him first) to test results.

    Do you have a saved game with the problem that you could upload, and a copy of your current WeiDU.log (renamed to .txt)?


  • ElysaeElysae Member Posts: 5

    hi. I've tried the save in the unmodded Steam folder rather than the modded copy with the same result. Over a decade of trying to build my perfect install and it always fails because of something minor...
    Your suggestion reminded me of the game I benched to start this one. Both use the same "mod build", both are in Chapter four, and both contain Viconia. The current one is bugged, the benched one isn't. Though I did in- and uninstall SCS in between. For comparison's sake, I'll attach both.
    A few more probably minor details:
    - In the affected game I had to rest several times to get the chapter two dream, in the unaffected it came on the first rest.
    - In the affected game Dorn became a fallen blackguard when charmed(or rigid thinking) CHARNAME sniped a commoner inside the Nashkel inn.
    - "Bad" Viconia, when opened with EEKeeper, has dozens of copies of various stat: and spell: modifiers that the good one doesn't have. If I still had any saves with other clerics, I'd check them, too, because it definitely doesn't affect just her (had it happen in a divine casters only game).

  • GusindaGusinda Member Posts: 1,608
    @Elysae, not sure why it is happening, but the problem with Viconia is that she has a 'Fallen Paladin' status marked against her. Once removed, the cleric spell scrolls came back online.

    I used NI to remove the flag, but to remove through EEKeeper, open the saved game and go to the characteristics tab, change her class to paladin, and uncheck the fallen flag. Return her to class to Cleric/Thief and save the game. You should be able access the spells.


Sign In or Register to comment.