Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Beamdog Client stuck in download

prwoprwo Member Posts: 69
I'm trying to update to the newest NWN:EE Development build, but the download is stuck at 92.05MB remaining @ 0 B/s

When I restart it, it tries to download, but soon the rate drops to 0 without having downloaded anything.
I cannot Verify the game or Play because both buttons are disabled.
Pausing and Continuing the Download doesn't do anything.

Beamdog Client Version 2.1.11
NWN game Version v78.8191 [aa295596] Development

I've tried on another computer with a freshly installed beamdog client, but it doesn't get to download anything either.
(I've checked firewall settings already and other programs download just fine.)

Has anyone experienced this?


  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,837
    We are confirming the issue and will try to fix it.

  • prwoprwo Member Posts: 69
    Another information: the very same beamdog client could successfully download the whole NWN:EE Retail branch.

  • prwoprwo Member Posts: 69
    I did another experiment: I uninstalled the beamdog client and deleted the Beamdog Library folder completely. Then I reinstalled Beamdog Client Setup 2.1.11-ia32.exe
    Downloading NWN:EE Development is stuck after about 1GB
    Downloading NWN:EE Retail works

  • prwoprwo Member Posts: 69
    Note: I was able to fully update to the latest development branch on my weekend computer before.
    According to nwnmain.exe's timestamp this update was on 2019-10-12
    This was before my other computers started to have struggles doing the same update a few days later on.

    This is the Beamdog configuration on said weekend computer:

    NWB:EE shows v79.8192 [75353e20]

    Aurora Toolset's "About" dialog shows:
    Game Version: v1.79
    NWToolset Version: vts78

    nwnmain.exe SHA-1: 6066a96adad7603efc1b071927059ad6df155942
    nwtoolset.exe SHA-1: 3c00448a8c34e3ca9c2ca52055b600d6d3490f35

    Beamdog client's "Settings" dialog shows:
    Version 2.1.11

    Beamdog Client.exe file version:
    Beamdog Client.exe SHA-1: d3664e1334ae92875906317f601bd3060e9dfbef

  • prwoprwo Member Posts: 69
    I deleted the folder Beamdog Library\00829 from my workday computer (where the download was stuck) and replaced it with a copy of the one from my weekend computer (where the download had worked 2 weeks ago).
    Started the Beamdog client Version 2.1.11 (Beamdog Client.exe file version: and it verified the Development branch as complete now.

Sign In or Register to comment.