Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

screen edge camera turning will not work

H0RSEH0RSE Member Posts: 114
edited January 19 in Technical Support
Been trying to get edge scrolling to work in-game, and it will not. It also will not display in full-screen, despite what the nwn.ini setting say.

Current settings:

Borderless=0
FullScreenDesktopMode=0
FullScreen=1
glFinishBeforeFBO=0
UseLargeFont=0
Width=2560
Height=1440
BitsPerPixels=32
RefreshRate=144
TexturePack=3

It says fullscreen is enabled, but it is not. I run a bluelight filter app on my PC, and it is set to disable whenever fullscreen apps are running (such as games) and it does turn off when I am in a game... but it is not turning off when I run NWN, so although it looks like it's running fullscreen, it is not. And for some reason, the game always loads running in 2560x1421 resolution. When I try to change it to my native 1440, it takes multiple tries and sometimes even alt+tabbbing in and out of the game for it to finally apply, but even when it does, (as mentioned) it's not actually running in fullscreen.

I know that was a bunch of different problems I listed, but the core issue is I need to get edge scrolling to work. The game (for me) is unplayable without it. And yes, "enable screen edge camera turning" is enabled in the options.

Post edited by H0RSE on

Comments

  • H0RSEH0RSE Member Posts: 114
    so I figured out how to fix it. Had to go into my settings.tml file (not nwn.ini) and under [graphics.window] change mode to = "exclusive"

    Also had to correctly adjust the resolution numbers there as well.

    JuliusBorisov
  • DwayneDwayne Member Posts: 79
    Beamdog needs to start fixing some of these problems. There are too many settings that just don't work that worked in the past. Nobody should have to do what you did to get it to work.

    BelgarathMTH
  • Sylvus_MoonbowSylvus_Moonbow Member Posts: 1,026
    edited January 20
    And why is that, when settings.tml is the new normal?

    Everything works by changing settings in that file (or CTRL-SHIFT-F12 in-game), vs. the old way of nwn.ini. If anything, nwn.ini should simply be deleted if it is possible on any new installation and future upgrade to avoid any further confusion.

    That's how NWN:EE works now. Get used to settings.tml, Dwayne.

    JuliusBorisov
  • H0RSEH0RSE Member Posts: 114
    edited January 20
    And why is that, when settings.tml is the new normal?

    Everything works by changing settings in that file (or CTRL-SHIFT-F12 in-game), vs. the old way of nwn.ini. If anything, nwn.ini should simply be deleted if it is possible on any new installation and future upgrade to avoid any further confusion.

    That's how NWN:EE works now. Get used to settings.tml, Dwayne.

    I think you are missing his point...regardless if it was .ini or .tml, the fact that I had to physically go into the file and change it, because changing the setting in-game would not work, is the problem.

    If I set the resolution in the options menu and have screen edge camera checked, then it should work, but it doesn't, and that is the problem.

    And not everybody (I would bet not even most people) know about the crtl+shift+F12 shortcut, which is besides the point anyway.

    DwaynericoyungBelgarathMTH
  • DwayneDwayne Member Posts: 79
    That is exactly what I was talking about. If you check it then it should do what is listed. In the past these things worked. The ee edition is listed as fixing and improving nwn. This is not doing either. Does Beamdog even check to see what effect their improvements are doing to the game? As far as I can tell the answer is no.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    Hey, @Dwayne - we're constantly reading the feedback and reacting to it. If you read through the patch notes for 8193.x patches, you'll easily notice exact fixes and features which came as a result of our reaction to community feedback.

    If changing the setting in-game doesn't work, then it's either a user error or a bug which should be investigated. Please report at https://beamdog.atlassian.net/servicedesk/customer/portals

  • WilliamDracoWilliamDraco Member Posts: 62
    Likely people are missing the "Commit" button at the top of the debug-config menu. Given the length of the list it's easy to miss that you have to scroll back to the top and commit any changes you make.

    JuliusBorisovPstemarie
  • ShadowMShadowM Member Posts: 532
    Likely people are missing the "Commit" button at the top of the debug-config menu. Given the length of the list it's easy to miss that you have to scroll back to the top and commit any changes you make.

    A simple fix is to make the commit box / Rollback / filter section should be in it own window box that stay at the top even as you scroll.

    WilliamDraco
  • ricoyungricoyung Member Posts: 81
    I just started NWNEE up today after a long hiatus and I ran into this problem also... so what the h*ll am I supposed to do to fix this, that was previously working?

    I guess I didn't get the memo/heads up

  • H0RSEH0RSE Member Posts: 114
    edited January 28
    ricoyung wrote: »
    I just started NWNEE up today after a long hiatus and I ran into this problem also... so what the h*ll am I supposed to do to fix this, that was previously working?

    I guess I didn't get the memo/heads up

    What I did to fix it was to go into the settings.tml and navigate down to the [graphics.window] settings and change them to this:

    [graphics.window]
    mode = "exclusive"
    [graphics.window.fullscreen]
    height = 1440
    toggle-to-borderless = false
    width = 2560
    [graphics.window.position]
    [graphics.window.windowed]
    borderless = true
    height = 2560
    width = 1440
    [graphics.window.windowed.position]
    mode = "remember"
    x = 0
    y = 0


    of course, you will change the height and width settings to whatever the resolution of your monitor is. Everything else, enter as is. That's what worked for me.

    JuliusBorisovricoyung
  • ricoyungricoyung Member Posts: 81
    Thank you very much for that! Totally worked :)

    JuliusBorisovH0RSE
Sign In or Register to comment.