Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Game Crashing with Mods

BertleBertle Member Posts: 35
Hello everyone! This is long so bear with me.

So for a while now, I've been having a problem with BG2EE. Everything is merrily working well for a long time, then all of a sudden I'll go to reload a recent save and find the game will crash upon opening it. All my recent saves from that time period do the same, but if I go back to an old save (like for instance the Chapter 2 start save) it loads fine. There doesn't seem to be any rhyme or reason to when this happens - no specific location or time period that I can discern. If I delete the sav file the game loads fine - except I then have to deal with a world that thinks I haven't been anywhere before which is super annoying and sometimes game-breaking.

These issues have only started happening since I've started using mods. I've played BG2 more times than I can count, and now find it super boring to play the vanilla game. I really only want to play with mods, so that it adds new npcs/quests/experiences to the game. I tried using beamdog to verify my game and basically reset it to vanilla mode. Once I did that, I could open my save that previously crashed no problem, which leads me to believe the problem is with one of my mods.

I could delete my mods one by one, try to load the save after each one, and see if I can find the problem that way. But I don't want to do that if I don't have to because A) I have a long list of mods installed and it'll be a pain in the butt, and B] once I delete a mod I'm actively using in my current game, I can't just reinstall it and pick up where I left off, I'll have to restart. And I don't want to restart because I am having a grand time in my current game.

SO! Basically I am looking for a shortcut to find the problem without deleting everything. Has anyone had this problem before and worked out which mod is causing it? Has anyone heard of anything like this before? Has this been reported as an issue before? Or am I the first to come across this problem?

TL;DR - I like mods. Mods are corrupting my save. I am looking for a shortcut to solve the problem. Anyone have this problem before?


  • BertleBertle Member Posts: 35
    oh shoot, should this be posted in troubleshooting instead? Does troubleshooting deal with mod-troubleshooting questions? Please let me know if so and I will delete and repost in the right place

  • gorgonzolagorgonzola Member Posts: 3,621
    did you change anything in you mods setting on the run?
    it is often suggested that once a game is started with a certain set of mods is not wise to change adding new mods or deleting certain ones.
    a lot of different things can happen, ie in the inventory of someone there can be an item introduced with a mod that has been deleted so the game searches for a file that is no more existing.

    if you did not change your mod setting the issue should be an other, maybe using not compatible mods, or installing them in the wrong order.
    i don't know if here, troubleshooting or general modding is the proper place to post this thread and i am not also expert in modding the EE, as i usually play it vanilla and use the original game for mods, but at least, answering to my question if the problem arose by himself or if you changed the mods setting on the run can give some information to those that know better then me.

  • BertleBertle Member Posts: 35
    Thanks for your suggestions gorgonzola! I always download all the mods I am going to use together before starting a new game. I try to be careful for incompatibilities and use EE Mod Setup to set them up, which should catch incompatibilities and download in the correct order, but there's always a chance something went wrong.

    I think I have found the issue - the Faren (NPC) mod seems to have put a FHsw1.itm file in my override folder (I am guessing it was the Faren mod that did this given the FH prefix). When I delete this one file, the save loads just fine. I am not tech savvy enough to know what this file was likely for or the consequences for the mod by deleting it. Nor do I have any guess why it was causing the problem. If someone does have an idea, please let me know!

    For now though, I think I am going to accept my losses and not use Faren, as I have been trying to figure this out all day and am very frustrated.

  • gorgonzolagorgonzola Member Posts: 3,621
    glad that you solved the issue.

Sign In or Register to comment.