Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

TLK Files [Solved]

CaomhCaomh Member Posts: 36
edited June 2018 in Tools & Plugin Developers
Hello I am using TLKEdit-R13b and it does not seem to be working properly for me. It opens up the TLK and I am able to add a new line. However once I point the 2DA towards it, nothing happens.

Has anyone used one that has worked when doing something with the EE version?

Also in case my usage is wrong here is what I do:

1) Open up the TLK file and create a new line. (Example 2312)
2) I add text to that new line.
3) I open up the 2DA file and point my new class to the TLK line. (2312)
4) I use the nwn hak to create a new hak.
5) I add it to the module (module is empty it is the only hak)
6) I start a new game to test.

Edit: Marked as solved

Post edited by Caomh on

Comments

  • ZeroarkZeroark Member Posts: 22
    edited June 2018
    Are you editing the base dialog.tlk or using a custom one? (I.E: The one you set as tlk on your module)

    If you are doing the first one, I don't know. If you are doing the latter you have .... Look what I found around:
    And as a reminder for all custom .tlk entries:

    The very first line (strref) is line 0, which must be "Bad Strref"

    And when referencing your custom tlk entries (.2da files or scripts), you must add the number "16777216" to the entry in your custom tlk table. For example, your first custom entry will be Strref 1 in your table but all references to it must be 16777217 (16777216 +1 = 16777217). That's why I use a spreadsheet to translate the custom tlk strref into the actual strref that NWN will use.
    So, basically you gotta add 16777216 + (Your number) on the 2da you just edited and it will pull from your custom tlk!

  • CaomhCaomh Member Posts: 36
    @Zeroark
    I am editing the base dialog.tlk found in C:\Users\\Beamdog Library\00839\data\tlk

    As you mentioned I have added the new line follows the sequential numbers.
    The first line is indeed bad stref.

    Could you list which tlk editor you are using and where you downloading it from? If it is the tool then knowing one you have used for NWN:EE and know works for NWN:EE would be quite useful.

    Likewise if you could mention how to load a new tlk file I could experiment with that as well.

  • ZeroarkZeroark Member Posts: 22
    If you want to load a new tlk, you have to create a module and go to Edit > Module Properties.
    Once there go to "Custom Content" and select the tlk you want at the bottom.

    I haven't edited TLKs in a while, but back in 1.69 I used this one:
    https://neverwintervault.org/project/nwn2/other/tool/2datlkgff-editor-aka-tlkedit2

    But it looks like this one is highly recommended as well (Haven't used it tho)
    https://neverwintervault.org/project/nwn1/other/tool/axe-murderers-killer-tlk-editor

    As, to override the the dialog.tlk, I think you gotta go to:
    (NWN:EE Instal Path)\lang\(NWN Language)\data

    And there, overwrite dialog.tlk, at least that's what I got from this thread
    https://forums.beamdog.com/discussion/32575/dialog-tlk-where

    I'd recommend going with the Custom TLK route, rather than overwriting the base dialog.tlk

  • CaomhCaomh Member Posts: 36
    One reason why I did not use the second one you listed is because it states this:
    Requirements:
    To use Killer TLK Editor v3.0 you must be running Windows XP. I could not test it on previous versions of Windows so it might work OK on them as well. You don't have to have Neverwinter Nights installed to use this editor.

    NWN was made for Windows XP while NWN:EE does not support XP. I am going to test the custom route to see if it fixes things, however as the 2DA is pointing to the proper file and line there is no reason why it should not work. I should also reset the dialog.tlk to its original state as I may have done something to hose it with my original edits.

    Some good news so far is the first link you posted gives me TlkEdit-R13d while I was using TlkEdit-R13b. D is further in the alphabet than b so hopefully it is more advanced.

  • ZeroarkZeroark Member Posts: 22
    Yeah, as I said when looking for recommendations I found that one. Didn't notice that disclaimer tho. TlkEdit is pretty good actually and d should be a latest version than b.

    Dunno about the override of dialog.tlk, that's so different from 1.69 and I haven't honestly tested it yet.

  • CaomhCaomh Member Posts: 36
    Reverting the tlk was easy. When I restarted the Beamdog client it noticed something was different and asked me if I wanted to change things back. Checking the tlk one last time showed everything was as it should be. Still it displayed this error in the attached file.

    Which makes me wonder if there is a different tlk file that I don't know about.

  • ZeroarkZeroark Member Posts: 22
    Still using the override method? Because it looks like your doing it right, but you are using the wrong line number (Try looking for that string on the Tlk, probably that can give you a hint)

  • CaomhCaomh Member Posts: 36
    edited June 2018
    I have not used the override method. As mentioned I have verified the numbers are correct which makes the results odd. Perhaps you might attempt to add a new one as well?

    Edit: Tried making it a custom one with no success.
    Attached is a picture of the tlk and one of the racialtypes

  • ZeroarkZeroark Member Posts: 22
    I've done so in the past with no issues. I've literally just moved my old 1.69 haks / tlk to EE with no major issues whatsoever (See attached pic #1)

    Also, ataching my Classes.2da as an example, hope it helps:


  • CaomhCaomh Member Posts: 36
    edited June 2018
    The PRC can be used from 1.69 and 1.75 and earlier. One thing mentioned in the past has been an easy way to do so is make a 1.69 PRC mod and then import it to NWN:EE. However simply trying to update a mod out of the box with the PRC has caused failure more than once.

    Simply put unless you use the tools and do so on NWN:EE then it is not helpful. No your files were not helpful. Classes and Races are two separate things. They require editing two different things. According to Beamdog you would need to display the packages 2DA which is referenced in the Classes.2DA. In the Classes.2DA the only row which currently matters is the last one (Packages) which must corresponds with the Packages new line entry.

    Attached is Beamdog's release notes as of 1.74

    Edit: I should also note that I am using the Custom Contentv3_0 guide by Eligio Sacateca. All of which calls for editing the dialog.tlk A file which does not exist in NWN:EE instead it is replaced with dla.tlk. Now it is possible that Bemadog simply renamed the file or it is possible that they did something else as well. Every last 2DA file structure has been changed and most of them have been posted to the Neverwinter Vault.

    I will reiterate that I am grateful for you taking out your time to attempt to help me, however there are very real differences between 1.69 and 1.75. I request when attempting to provide answers please base it on 1.75 and please take time to work with in 1.75. That was if there is a small change from 1.69 it can be caught.

  • ZeroarkZeroark Member Posts: 22
    This is no PRC, but some classes I made like 8 years ago by myself. I don't know about PRC, since I never used it, and I only limited myself to make classes that I found col.

    I know that I pulled a totally different file as example (Classes vs Races) but since the syntax for everything else didn't matter, and the only important point was the TLK, I wanted to use that as reference only. I didn't mean to use it as a reference for the whole file.

    I double checked both files, racialtypes.2da on 1.69 and 1.75 and only the "Icon" column is new, so that's why I told you that they work even on this version, because the syntax didn't change at all.

    GOING BACK TO THE POINT...

    As I mentioned it's quite difficult working with the dialog.tlk, because unexpected things can happen. What I recommend you is,if you have a test module, to create a whole new TLK file and use that as an example. I've made a sample which is working, that I hope it helps you in your task.

    https://neverwintervault.org/project/nwn1/other/custom-races-sample

    pscythe
  • CaomhCaomh Member Posts: 36
    @Zeroark
    As mentioned in my previous post. What you posted (The 2DA files) for classes is not useful for several reasons. The first being I am working on Race and not Class. The second being it is of a file format from 2003 not the current ones worked on 2018 which require being set up differently. The last and most important reason. You didn't actually respond to this thread which I created requesting specific help.

    After stating my problem I asked:
    Has anyone used one that has worked when doing something with the EE version?

    As you mentioned "GOING BACK TO THE POINT..."

    Please stop derailing my thread. If you are able to assist with knowledge using tlk tools in NWN:EE I would be very grateful. As I posted the 2DA files required for altering races if you see anything which is not set up properly. Please leave a comment on what is incorrect.


  • ZeroarkZeroark Member Posts: 22
    On this file you posted above:


    Change the numbers as follows:
    Name = 16804457 (16777216 + 27241)
    ConverName = 16804458 (16777216 + 27242)
    ConverNameLower = 16804459 (16777216 + 27243)
    NamePlural = 16804460 (16777216 + 27244)
    Description = 16804461 (16777216 + 27245)

    As I mentioned before, you have to add 16777216 to your Custom Tlk on the 2DAs for them to be pulled. What your 2DA is doing, is pulling from the dialog.tlk, because you didn't add 16777216 to your row number.

    That should resolve everything.

    DerpCityCaomh
  • CaomhCaomh Member Posts: 36
    @Zeroark

    Thank you so much for posting the solution. My problem was when when I read post the row number + 1 in one of the guides I checked to look at that. Until your post I did not notice that the TLK editor had an option for custom row which displayed the numbers you posted.

    Between that and the guides you posted on class creation it should be possible to be able to do both. I do have one question however. Is it possible at this time using these methods to add new spells?

    For now I shall be taking a break from NWN for other projects, however this knowledge will be here for me and others in the future and for that, thank you so much.

  • ZeroarkZeroark Member Posts: 22
    @Caomh
    Hello again. No problem. I posted the hints above but I think you misunderstood me, so I just clarified it again.

    The TLK methods apply to all 2da files, so you'll have to use the "Custom Row Number" on all, if you are working on your own tlk. The ONLY exception is if you are working on a dialog.tlk that would override the original one, else all TLK references should follow that numbering method.

  • DemolidoR_DemoliTioNDemolidoR_DemoliTioN Member Posts: 19
    edited May 2020
    Hi guys, how do i fix these squares tha appeared when i tap enter to jump a line?


    tp5pv85590ft.png

  • ZeroarkZeroark Member Posts: 22
    Hi guys, how do i fix these squares tha appeared when i tap enter to jump a line?


    tp5pv85590ft.png

    Hello,
    Can you share the text you have on your TLK? It'd seem you have a weird character that cannot be parsed by the game font and showing that square instead.

  • DemolidoR_DemoliTioNDemolidoR_DemoliTioN Member Posts: 19
    Zeroark wrote: »
    Hi guys, how do i fix these squares tha appeared when i tap enter to jump a line?


    tp5pv85590ft.png

    Hello,
    Can you share the text you have on your TLK? It'd seem you have a weird character that cannot be parsed by the game font and showing that square instead.

    Hi,
    Thank you for answer. I was useing 2DA / TLK editor program, then i downloaded Killer TLK editor v3.0 and now resolved.

    Thank you!

Sign In or Register to comment.