Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

No music bug

gpeddinogpeddino Member Posts: 39
edited November 2020 in Technical Support
I've been working on a module and all music and ambient sounds simply can't be heard when I test it. Placed sounds work normally, though. Is there a fix for that?

Post edited by gpeddino on

Comments

  • ZaxaresZaxares Member Posts: 1,209
    Do you mean hearing music and ambient sounds while still in the Toolset? If so, it's been a long long time since I last looked in the NWN toolset, but I think they don't play automatically while in the Toolset, no.

  • gpeddinogpeddino Member Posts: 39
    No, everything works fine in the toolset. But when I try to play the module, there's no music or ambient sounds at all. I even tried scripting functions to make them play, to no avail.

  • ZaxaresZaxares Member Posts: 1,209
    Mmm, I'm a loss then. I only ever dabbled around in the Toolset years ago, mostly just to craft custom magic items for my DM campaigns. Hopefully someone more familiar with the Toolset can help you!

  • gpeddinogpeddino Member Posts: 39
    Okay, here's an update. I did some testing and noticed a few things. I play on a Mac and I run the toolset via Wine. I don't know if that changes things in any way, but there you go.

    Here's the thing: when I use Customize Environment and set the Night/Day Cycle to Always Dark, the track that plays is the Music, Day track. If I leave Music, Day as blank and choose any track for Music, Night, nothing plays. I don't know if that's deliberate but it seems like a bug to me, specially considering that the ambient sounds don't work like that.

    By the way, that only happens in-game. Everything works fine in the toolset.

Sign In or Register to comment.