Skip to content

Can't open or create ANY module with the toolset

I recently reinstalled Neverwinter Nights, and the game itself is running perfectly. However, the first time I tried to run the toolset, then load a module, I get the error message:

Access violation at address 0051c9a4 in module 'nwtoolset.exe'. Read of address 00000040.

I've spent a couple hours searching the internet trying to resolve this, but it seems past support issues or currently open issues are not searchable anymore with the change to the support desk. The only similar problem seems to be people with compatibility issues with NVidia, and even though I don't think this is the problem, I tried the solutions anyway. No luck there either.

What I have already tried:
* Deleting My Documents/Neverwinter Nights folder, then running the game, exiting, then running the toolset. Same error.
* Removing the "environment mapping on creatures" option in the toolset. No effect.
* In my NVidia Control Panel, I set a program option for nwtoolset.exe for Threaded Optimization to be 'Off'. No effect.
* The Open Modules dialog lists modules stored in both '[InstallDir]\data\mod' and 'My Documents\Neverwinter Nights\modules'. Opening modules stored in either path have the same result.
* Creating a new module generates the same error message after clicking 'Next' in the Module Name Dialog, and no new module is created.
* Verified Integrity of the Game Cache in Steam.
* Running the toolset as administrator. It should be by default, but I explicitly chose the option. No change.

What I am using:
* NWN latest public build via Steam
* Windows 7
* Phenom II x6 1090T (desktop circa 2011)
* Steam game installation and game files are both on the same SSD; neither are in '\Program Files'.

Its probably been more than a year since I last played NWN EE. I was able to use the toolset back then as well. Also, since no one else seems to be hollering about a broken toolset, I can only assume the problem is on my end... but I haven't a clue what that could be.


  • CalgacusCalgacus Member Posts: 273
    Is it possible that the toolset cannot create the temp0 folder under the modules folder? Permissions issue on the modules folder maybe? or on an old temp0 folder? When opening a module the toolset needs to create that temp0 folder.
  • AvatarOfWarAvatarOfWar Member Posts: 9
    Gave it a shot, but that doesn't seem to be the case. When I open an existing module, it does create a \temp0 folder and does seem to extract all the resources in the module to that directory, then gives the same error message. Or at least, I assume its "all" the resources in the module, but I don't know how to verify that. "To Heir is Human" extracts 162 files, so if it doesn't let me know.

    Creating a new module also seems to create two files in a newly created temp0 folder (repute.fac and module.ifo) before it also gives the error message.

    The toolset also properly cleans up the temp0 folder when the toolset exits.
  • AvatarOfWarAvatarOfWar Member Posts: 9
    I just tried opting into the "oldstable" beta branch and the toolset worked perfectly in that version. Returning to the public build but using the oldstable copy of the toolset didn't work (not that I really expected it to). But at least this narrows down the problem a little.

    Using an earlier version of NWN EE isn't practical though, so this issue is still open.
  • nivniv Member, Moderator, Developer Posts: 410
    @AvatarOfWar Does the same thing happen if you opt into the development branch on Steam?
  • AvatarOfWarAvatarOfWar Member Posts: 9
    Yeah, same bug with the development version. However, the development version downloaded a new copy of the toolset, but the 'About' screen still says its the same version (vts80).
  • AvatarOfWarAvatarOfWar Member Posts: 9
    I just tried updating my video drivers. NVidia version 457.3 is now installed. Video card is a GTX 970. It didn't help either. I don't think its a graphics issue... but since most of the toolset changes were to graphics I figured it was worth a shot.
  • nivniv Member, Moderator, Developer Posts: 410
    Do you have antivirus? It could be AV preventing readwrite access to Documents/NWN/ (though that would also affect the toolset settings file ..).
  • LeonDeGammeLeonDeGamme Member Posts: 32
    Any solution for this? I have the exact same problem.
  • ZephiriusZephirius Member Posts: 329
    Yeah, I can't save the module. Access violations...Can't save the module either - System Error Code 5 - Accesss denied???
  • ZephiriusZephirius Member Posts: 329
    I appreciate the hard work, but I'm stuck dead in the water without the ability to save!!!
  • ZephiriusZephirius Member Posts: 329
    Yep. It was my Norton Antivirus! It was flagging NWN toolset.exe as a "bad actor."
  • ZephiriusZephirius Member Posts: 329
    Some missing textures in the Barrows Tileset now...
  • ZephiriusZephirius Member Posts: 329
    ...on the 7x7 model. Its bridge is missing it's textures...
  • TarotRedhandTarotRedhand Member Posts: 1,286
    Norton is notorious for the amount of false-positives it reports. BD should complain to them about it.

  • wildernandwildernand Member Posts: 1
    edited August 2021
    Access violation at address C052C054 in module 'nwtoolset.exe'. Read of address 00000040. Deleting the Temp0 folder didn't help. there is also an assets folder I'm going to try deleting to see if that helps but I don't think that is the problem. the problem seems to be writing to the folder temp0. none of the above suggestions fixed the issue.
    Post edited by wildernand on
Sign In or Register to comment.