Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Nwsync file type error

echooechoo Member Posts: 42
edited July 8 in Technical Support

I solved this by reinstalling everything onto a clean linux VM.

I'm trying to generate nwsync content for my mod, and I'm running into an error that halts nwsync_write.exe

It is complaining about an unrecognized file type within CEP 2.65. Oddly, I've not had this error when nwsyncing CEP in the past.

I have my hak directory changed from the EE default, as set in my nwn.ini config. Not sure if this matters.

Any suggestions?

The last few lines of my nwsync_write output:

I, [2021-07-08T08:38:58] -- nwsync_write: Adding hak from mod: H:\NWN\NWN Diamond\hak\tkf_hands_skin.hak
W, [2021-07-08T08:38:58] -- nwsync_write: erf header field locStringSize has invalid value (safe to ignore)
I, [2021-07-08T08:38:58] -- nwsync_write: Adding hak from mod: H:\NWN\NWN Diamond\hak\tkf_loadscreen.hak
I, [2021-07-08T08:38:58] -- nwsync_write: Adding tlk from mod: H:\NWN\NWN Diamond\tlk\cep260.tlk
I, [2021-07-08T08:38:58] -- nwsync_write: Preparing data set to expose
E, [2021-07-08T08:38:59] -- nwsync_write: ResRef _handr005  u  .26224 is not resolvable (we don't know the file type); origin: Erf:H:\NWN\NWN Diamond\hak\cep2_add_phenos2.hak(H:\NWN\NWN Diamond\hak\cep2_add_phenos2.hak: _handr005  u  .26224)


I'm using the newest nwsync version from github (0.4.2)

Post edited by echoo on


  • echooechoo Member Posts: 42
    I tried using nwsync_write on my mod within linux. There's no file type error this time, but it halts again with an "IOerror"
    I, [2021-07-08T09:09:26] -- nwsync_write: [0%] Writing: /media/sf_NWN_Diamond/nwsync/tkf/data/sha1/18/26/1826d4aae991d5c10dbd51d0c79e4f44ee6c8301 (iit_book_241.tga)
    I, [2021-07-08T09:09:26] -- nwsync_write: [0%] Writing: /media/sf_NWN_Diamond/nwsync/tkf/data/sha1/2c/c9/2cc9933d787e134e81446ef1aa31486e62d0eea7 (
    I, [2021-07-08T09:09:26] -- nwsync_write: [0%] Writing: /media/sf_NWN_Diamond/nwsync/tkf/data/sha1/ec/9d/ec9d5af2e35767d4b553f55e1655ab715bbf06f2 (wblhw_t_192.mdl)
    util.nim(16)             readStrChunked
    Error: unhandled exception: wanted to read 1024 but only got 0 [IOError]

Sign In or Register to comment.