Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Revenants uses the incorrect animation

AndreaColomboAndreaColombo Member Posts: 5,452
edited July 22 in Troubleshooting
Revenants are making use of the Zombie animation across all games (BG:EE, SoD, BGII:EE) even though a dedicated revenant animation exists.

The INI is already there—0x7701—just needs assigning to revenant CRE files.

Here's a quick and dirty WeiDU code that will do it:

COPY_EXISTING_REGEXP GLOB ~.*\.cre~ ~override~
       READ_STRREF 0x8 name
              PATCH_IF (~%name%~ STR_EQ ~Revenant~) BEGIN
                     WRITE_ASCII 0x28 0x7701
              END
              BUT_ONLY[s][/s]

Note that there's also a dedicated revenant soundset within the game's files that is not being used. The files are "revenXX" where XX is the number. Here's the WeiDU code to do that:

COPY_EXISTING ~7701.INI~ ~override~
       REPLACE_TEXTUALLY ~attack=ghoul03,blank,blank~ ~attack=~
       REPLACE_TEXTUALLY ~damage=ghoul08~ ~damage=reven08~
       REPLACE_TEXTUALLY ~die=ghoul09~ ~die=reven09~
       REPLACE_TEXTUALLY ~attack_slash=ghoul05,blank,blank~ ~attack_slash=reven05~
       REPLACE_TEXTUALLY ~attack_slash_frame=2,0,0~ ~attack_slash_frame=2~ 
       REPLACE_TEXTUALLY ~attack_backslash=ghoul06,blank,blank~ ~attack_backslash=reven06~
       REPLACE_TEXTUALLY ~attack_backslash_frame=2,0,0~ ~attack_backslash_frame=2~
       REPLACE_TEXTUALLY ~attack_jab=~ ~attack_jab=reven05~
       REPLACE_TEXTUALLY ~attack_jab_frame=0~ ~attack_jab_frame=2~
       REPLACE_TEXTUALLY ~battle_cry=ghoul03,ghoul04~ ~battle_cry=reven03,reven04~
       REPLACE_TEXTUALLY ~selection=ghoul03~ ~selection=reven01,reven02~
       REPLACE_TEXTUALLY ~selection_frame=0~ ~selection_frame=0,0~

In the meanwhile, let me tag @Galactygon as an FYI. I reported this to Beamdog via their support page (ticket BGCS-3397), but failed to mention that the dedicated soundset is not already part of the INI file and needs to be assigned separately. Figured I'd mention it here and let someone from the Beamdog team know.

Post edited by AndreaColombo on
Galactygon

Comments

Sign In or Register to comment.