Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

#7517 [TOB] iPAD: Force field in Yaga Sura's lair not dropping in spite of quest xp being awarded.

SkaffenSkaffen Member Posts: 709
edited February 2014 in BGII:EE Bugs (v1.2.2030)
Observed behaviour: force field blocking the stairs to level 2 is not dropping in spite of having all four wardstones and quest xp for removing the field being awarded.

Expected behaviour: open the bloody door!

Needless to say: this is a gamebreaking bug!

@CrevsDaak Can't upload a game now, going to work and writing this from my ipad but here's a screenshot:

Edit 10.2.2014: @MacHurto has posted a workaround further down - you need to keep clicking, some parts of the stairs will let you pass while the rest gives the errir message. It's still a serious bug though.


Post edited by Illydth on


  • CrevsDaakCrevsDaak Member Posts: 7,135
    Yeah, saw this before and I had a draft of the thread I started to write yesterday after discovering this.
    I've used Mind flayer form+Time Stop to kill him, but it's game breaking because technically he'll still being invincible.
    I can upload a save game later if needed, it's heavy edited but I did not touch the variables.

  • SkaffenSkaffen Member Posts: 709
    So you encountered the same problem? That means we really have a gamebreaking general bug? @Dee this is serious since you can't use the console for workarounds!

  • CrevsDaakCrevsDaak Member Posts: 7,135
    Yeah, I "fixed" it by killing him with Mind Flayers form, but definetly it's game breaking for solo runs.
    @Skaffen can you upload your saved game? I'll think I'm able to fix this.

  • SkaffenSkaffen Member Posts: 709
    Here's my save game from before clicking on the bloody field projector.

  • SkaffenSkaffen Member Posts: 709
    Thanks, will try that later but a permanent solution is required. Could you reproduce it with my savegame and raise a ticket?

    No idea about others. @atcDave you are a regular ipad player - did you finish ToB without encountering it?

  • atcDaveatcDave Member Posts: 1,933
    Skaffen said:

    Thanks, will try that later but a permanent solution is required. Could you reproduce it with my savegame and raise a ticket?

    No idea about others. @atcDave you are a regular ipad player - did you finish ToB without encountering it?

    No I haven't got that far yet . I was actually waiting on a patch because problems with the circus tent in SOA!

  • SkaffenSkaffen Member Posts: 709
    edited February 2014
    Well due to the android release all patches on hold as you probably know :( And given by the state of android if you follow that thread we'll have quite a wait ahead of us... Circus tent you can do quite easily if you pick up Keldorn first or have someone else that can cast true seeing.

  • CrevsDaakCrevsDaak Member Posts: 7,135
    edited February 2014
    @Gate70 tried again, un-edited saved game, still beta version.
    That save's edits are PC only (all abilities set to 25, still I just got destroyed by Abazigal, I've underestimated him), I'll got to that point again in my SoA solo run done in 3 days, amazing PG and insane exploit of Easy difficulty...

    Post edited by CrevsDaak on
  • MacHurtoMacHurto Member Posts: 726
    edited February 2014
    I did it yesterday. Some areas of the stairs say there is a force field but if you hit the edge of the map and the cursor appears, the characters move there and you travel to the next area and collect the hearts. Just click around until you find a spot that is accepted. It is anoying but not game breaking (at least on my ipad).

    Hope it helps

  • SkaffenSkaffen Member Posts: 709
    Yes it works. Still bugged and I would never have found it but at least there is a workaround and maybe clue on the underlying problem.

  • CrevsDaakCrevsDaak Member Posts: 7,135
    Just happened again, and mind flayer'd him to death again :p

  • IllydthIllydth Member, Developer Posts: 1,641
    I'll load up the save on my iPad ASAP (probably this weekend) and see if I can repo this and get a report open. I've got the prod version installed at this point (I think).

  • IllydthIllydth Member, Developer Posts: 1,641
    edited February 2014
    So the good news is I can confirm the bug, my iPad is doing the exact same thing with the force field as yours is.

    The bad news is it only looks like the first 3 steps or so is what's affected. If you click up at the "room exit" area, you'll ALWAYS get past only took me about 4 seconds of tapping to get around this.

    Given that this thread exists and has a work around (i.e. Just tap up farther) this is a "B" bug at best.

    That said, I'll go ahead and get one opened on this.

    7517 Created for this issue.

  • SkaffenSkaffen Member Posts: 709
    @Illydth What makes it bad is the fact that unlike other areas where you have to hunt for a responsive area to move (e.g. same dungeon past the double doors at the upper edge) here you get a very definitive feedback thst it's not working, discouraging any other clicking on other parts of the stairs. The natural course to alleviate is to reload and try again, not click on other areas of the stair when it tells you the forcefield is still there. Of course you try the projector again but that also doesn't help.

    With CrevsDaak and me two quite experienced players were completely stumped here. Yes, if you're good at googling you find the workaround now but I sure hope that's not the gaming experience you want to provide to your customers.

  • IllydthIllydth Member, Developer Posts: 1,641
    @Skaffen: Sorry to give you the impression this wasn't important...that's far from the message I was trying to put across.

    My comment was simply that it was unfortunate that I couldn't the bug at an "A" level, given the reports I've heard on this thread and the fact (as you put it) that even EXPERIENCED players are getting this issue and seeing it as a game breaking bug.

    I've got a post in the workarounds thread and we've got a "B" level bug open for it which is now tagged into the consolidated report. Not much else I can do to help this thing along, but we're all open to suggestions! :)

  • SkaffenSkaffen Member Posts: 709
    @Illydth Sure, just wanted to point out it's a bit different from other "just try again" type bugs.

    But please don't get me started on how important (or not) you take bugs - no patch since November speaks quite loudly on that. Maybe you even fix them internally, but unless you release patches that's academic... Obviously cash flow from a new release is even more important.

  • SkaffenSkaffen Member Posts: 709
    You're right, sorry, I am a bit frustrated here.

  • SkaffenSkaffen Member Posts: 709
    edited February 2014
    @Illydth Thanks for taking the time on this.

    Preliminary remark: I don't doubt for a second the intentions of Beamdog or Trent and don't equate them with EA or other Evil Empires on a get rich quick scheme - otherwise I wouldn't be here active in this forum also spending a considerable amount of my time helping others. I also certainly don't want to belittle the paid and unpaid efforts.

    Where opinions differ is the means on how to get the best game out there and build a lasting base and sustainable business.

    I work for a global enterprise where a core philosophy left by our founder is "Rather loose money than trust". And while I work for a multi-billion company, I lead a smallish team that needs to support existing products, develop new ones in a tough market environment, grow and be self-sustaining etc - I know the difficulties of juggling limited resources - send an engineer to fix the breakdown or have him work on the A+ important prototype? My daily bread, and I choose the customer first approach almost every time! Because without happy customers there won't be anyone to buy the prototype when it's done.

    My wife used to head QA and customer support in a small software startup (who incidentally also had a very active forum with volunteer support etc). So I can definetely relate (and had actually some time ago tried to build the business case for Beamdog based on some of Trents remarks on break even points, estimates for staff size & salaries etc...).

    And with all that I am still deeply convinced that Beamdog is doing the wrong thing and setting the wrong priorities. I am not saying that all bugs need to be weeded out and we need the be all - end all of all patches. Months ago I had argued for faster release cycles with incremental patches that tackle the low hanging fruits. But the current situation for me as a paying customer (Who bought 4 versions of the game from them so far) is not really acceptable.

    I think the much better course of action would have been to bring at least all versions of BG2 on one common level and not the 3 we have now (if Apple App store is still behind which it was last I checked - and before people argue that's Apple's fault you can't convince me that with some effort it wouldn't be possible to push the patched version out 3-4 months after it was given to them for release. It's just too low on the priority list to bother following up with Apple).

    Minimum would have been to bring PC and Mac to ipad level - this was actually hinted at last year in December before the ipad release got delayed in the app store and done similarly for BG1. Even better would have been another quick patch cycle for some of the glaring and hopefully easy to fix things (Watcher's Keep, Hexxat Romance, Vorpal Circus bug on ipad, ...).

    The core group here can handle console - but in 2013 you can't expect that of Average Joe customers any more and esp ipad doesn't even have that. And the app store reviews show it, last time I checked BG1 ipad had 2.5 stars. If you look at reviews, app store comments etc - the glaring bugs are the main criticism. This is not the way to build a sustainable business.

    Yes, resources are limited, but that makes it even more important to focus and get things on a stable level before tackling new, much bigger issues while leaving a lot of stuff undone - or probably even done but just not bundled and released. The ipad version is on a higher patch level than PC and Mac after all.

    I am pretty sure with 1-2 weeks of focused work all 3 platforms could have been lifted on a mostly stable and common level that would have satisfied a lot of people, removed some of the most gamebraking things and given peace on that front to attack the next big project. Because if i see the progress in "Road to Android" this is a long journey ahead of us and all the time people are having problems with the existing game. Not just here in the forum but just imagine how many more people (&paying customers) never bother to register here to post and just give up! It's not the 90s any more where buying a game is an investment and you tough it out - nowadays if something doesn't work you just move on to the next app with 5 star rating and BG doesn't deserve that fate.

    Yes, it wouldn't have solved all problems and yes there'd still be complaints and many more bugs to fix later. But especially the issues with the new content which many people are paying for should be fixed first before going to the next big thing which will introduce even more problems and complexity. Build from a (mostly) stable base and don't have too many open points and fronts at the same time. But the philosophy seems to be for the big "mega patches" instead of the by now industry standard sprint cycles of 2-3 weeks.

    So in summary - yes, everyone is working and motivations are good - but I think the work is done under wrong priorities.

Sign In or Register to comment.