Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Windows 7 - Audio problem - SFX/Voice sounds not playing.

DeefjeDeefje Member Posts: 110
I wanted to go through BG:EE again but I am having some problems.

I was using the same installation that had no problems before.

I have a new videocard, new CPU and bought a pair of headphones (spidf) since the last time i played.

The game sound however is going through my speakers, the amp for the headset is turned off.

I'm using an X-Fi titanium card with 5.1 speakers.

I tried:
- updating drivers but they are the latest creative release.
- Adding openAL32.dll to my baldur.exe folder
- installing openal.exe
- reïnstalling BGEE
- Disabling environmental audio through the ini.
- it also happens in BG2:EE


The problem:

When I load my (new) game sound first functions normally.

- whenever a soundeffect plays, for example:
- opening a barrel
- entering the menu through esc.

Some sound stop working, for example:
- PC/and NPC voice sounds
- Sound effects from barrels/chests
- Sound effects from menu buttons
- Weapon swing sounds

Sounds that do work are:
- ambient sounds (background sounds)
- Music
- spell vocals and effects


Upon entering a new area sounds work again. Also there seem to be certain triggers that make sounds work again but they seem random.


Can anyone help me? A BGEE playthrough is on my to-do list in my vacation. :)

Comments

  • TashTash Member Posts: 4
    edited July 2014
    Try this:

    1. Uninstall Creative Labs OpenAL through add/remove programs and remove any OpenAL32.dll from your BGEE directories.

    2. Download a different API implementation called OpenAL Soft here: http://kcat.strangesoft.net/openal.html#download

    3. Grab the appropriate package from the link above, extract it to wherever you want, go to Win32 (or Win64, if you have 64-bit OS) folder inside the package, rename the file "soft_oal.dll" to "OpenAL32.dll" (for both 32- and 64-bit OS,) and then drop it into your BGEE directory. It was enough for me to drop it to where BGEE.exe is (v1.2), but if it doesn't work on your game, drop it to where baldur.exe is, too.

    Alternatively, if it still doesn't work on your OS (works on my WinXP), drop the file into your Windows system32 (32-bit) AND/or systemWoW64 (64-bit) folder(s). Note that there's a readme on all of this inside the package.

    Try first with "Environmental Audio" set to "1", then try disabling it. My EAX soundcard doesn't like the default OpenAL and "Environmental Audio," too; OpenAL Soft solved this for me.

    Post edited by Tash on
    Deefje
  • DeefjeDeefje Member Posts: 110
    Fixed the problem for me Tash, thanks.

    I deleted the Creativelabs openAL from the software list as you said. But in hindsigh when reading the readme you mentioned I think it would also have been solved if I'd just put the renamed soft_oal in the installation directory.

    Not a 100% sure though and cba testing with it now. :)

    Thanks a lot. Now if I could only get over my 'play as mage or sorcerer' dilemma. ;)

  • TashTash Member Posts: 4
    No prob, glad I could help. A lot of people seem to be having issues with OpenAL. Most of these could be fixed by the developers if they enabled changing the OpenAL "device" through the baldur.ini. For example: 'Sound', 'device', 'Generic Software'. I think the game defaults to "Generic Hardware" which may cause problems with some soundcards/drivers.

    OpenAL Soft probably couldn't be used as an official replacement due to licensing, but I think it's still better than "Generic Software" mode of the default OpenAL. For instance, more channels and effects support. In any case, any sound issues can be now solved :)

Sign In or Register to comment.