Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Rasaad romance loop + Cespenar unserviceable

Raistlin82Raistlin82 Member Posts: 256
edited August 2014 in BGII:EE Bugs (v1.2.2030)
Ok, I don't know whether these two bugs are one and the same, or I just happened to find them at the same time.

Rasaad's Romance is stuck.
Everytime I sleep, after waking up he starts the conversation about the siege (the one that starts with "I did not sleep").
Notice that I had this conversation once before doing his ToB sidequest, but now, after finishing it, it just starts over and over after every rest.
Oh, and I did use CluaConsole to speed up real time (and proceed with Rasaad's romance) right after his quest... that might be worth mentioning.
UPDATE 4: after quitting the game and reloading, I tried resting a few times, in different situations, and apparently Rasaad isn't starting that conversation anymore. He's not starting any other conversation, either, though, so I'm wondering whether there's a way to check if his romance is working or not.

When that conversation happened for the first time (first BUGGED time, second time overall), I was in the personal plane and I was going to talk to Cespenar. Rasaad intercepted me for the conversation, and after I was finished talking to him... Cespenar wouldn't talk to me anymore. No matter how many times I clicked on him, he would just spew generic comments, without entering dialogue.
I reloaded the game, and this time I went to rest, and I waited for Rasaad to talk to me. After everything was done, I clicked on Cespenar.
I could talk to him once, to make an item (Shadow Dragon Scale armor), but then when I tried talking to him for the second time, he started with the random comments again (that's why I suspect it might be two separate issues).
Leaving the plane and re-entering didn't help, either.
UPDATE 1: I tried it again. I slept in the forest, had the conversation with the monk, then I went to the plane and made the Shadow Dragon Scale, then Cespenar stopped talking to me. I'm more and more convinced these are two separate bugs that just happened to pop up simultaneously. Lucky me.
UPDATE 2: I tried it again without resting. It seems that I can start conversation with Cespenar as many times as I want, as long as I don't make him do the Shadow Dragon Scale and just skip to the end of the list. However, after he makes that, he doesn't talk anymore. I don't have the ingredients at the moment to try and make him craft something else, so I can't tell whether it's because of that specific item or not.
UPDATE 3: Ok, I managed to craft other items without any problem, but as soon as I make him craft the Shadow Dragon Scale, Cespenar gets stuck.

Help?

Post edited by Raistlin82 on

Comments

Sign In or Register to comment.