Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Localisation of mods for BGEE

2»

Comments

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,340
    Guys I have a minor problem which drives me crazy. EE engine does automatically add usability statistics block to item description.
    I finished translating a mod with a lot of item descriptions and with each item usability block goes right after the last line of text, without an empty line. I tried to add empty line before the ~ that ending the line, without success. Original items (not modded) have this empty line and it is what I would like to achieve.
    It looks like that (the example is in English, but it's not important)

    Weight: 7
    Usable by:
    Cleric
    Cleric/Mage
    Mage
    etc.


    What I would like to achieve is this:

    Weight: 7

    Usable by:
    Cleric
    Cleric/Mage
    Mage
    etc.


    Anyone have an idea what's the problem? Yeah, I know it's minor thing, but it drives me mad....

  • ErgErg Member Posts: 1,756
    edited August 2014
    @Cahir, I can't reproduce the behaviour you are describing, i.e. in my case an empty line before the usability is added by default by the BG:EE engine, if the string ends with something like

    Weight: 7~

    I wouldn't know how to do the opposite, i.e. removing the empty line, but you can add additional empty lines if you want. The trick is to add at least a space on the last line, for example, and exaggerating for illustration purpose, with
    Weight: 20



    <- there is an invisible space here</code>~
    you will get what's shown by the image under the spoiler tag

    image

    N.B. the actual code is the one in yellow, the sentence about the invisible space is just to explain what I did :)

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,340
    Mamma mia, that actually worked, grazie mille @Erg :) Couldn't figured it by myself, that adding single space will be enough to get rid of this annoying thing.

    Anyway, without this single space, usability block goes right after the last description line - no matter how many empty lines I put after last description line, behavior was the same. Only when I added single space as you suggested, everything was as it should be. Can hardly call it a bug, but it's annoying nevertheless.

Sign In or Register to comment.