Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Crash after installer login, during "Checking System Files" phase

Hello all,

I'm having an issue where I download the Icewind Dale installer from the Beamdog website, log in to the installer with my credentials, and just as the program switches to the "Checking System Files" screen, my program freezes and Windows shuts it down. I've tried deleting all program files and re-downloading the installer, but to no effect. I've also tried updating my .NET framework, updating my SSL certificates, and restarting between each of these attempts. This is the first problem I've had with an installer from Beamdog, as BGEE and BG2EE both installed beautifully on my computer the first time around.

No crash dump folder has yet been created in my program folder or documents folder.

Game Version: Default installation version from Beamdog.com
System Information:
OS - Windows 7
CPU - Intel (R) Core (TM) i7 CPU 960 @ 3.20 GHz
GPU - NVIDIA GeForce GTX 285M
RAM - 6 GB
MOD Information: None
No Saved Games

Thanks so much for all your assistance!

-Aceldian

Comments

  • Gate70Gate70 Member, Developer Posts: 3,605
    @Aceldian
    Hard to say, so a few thoughts that might help you. Does running the installer as administrator make any difference. You could try the Beamdog launcher. Are you on the same internet connection as with the other games or behind an educational/corporate firewall.

    https://beamdog.zendesk.com/home?page=1 mentions a few other items such as Windows updates and checking your system clock has the correct date.

    Aceldian
  • AceldianAceldian Member Posts: 5
    Thanks for the prompt response, @Gate70.

    I got it to work by running it in compability mode, downloading to completion (despite Windows trying to shut it down), exiting, and then running normally. This worked and I've not had any problems since.

    I'm not behind any firewalls and I didn't have to run as administrator.

    Again thank you for the response, I hope that if anyone else has this identical issue that this discussion can serve as a resource.

    Gate70
Sign In or Register to comment.