Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BGII slooow on Samsung Galaxy S7 Edge

EledorEledor Member Posts: 16
edited July 2016 in Troubleshooting
Hi guys,

So I love BGII, defeated you know who in BGI and I have the Sword of Chaos to prove it, and would like to finish BGII as well. I got a new phone and copied over my saved game over to the new device but the game is just crawling...especially in combat. Phone is on Android 6.0.1

Game version is 1.3.2064

Killed various other apps running to save on CPU and memory but still slow. Is there a new build in development for Samsung Galaxy phone?

Hope so!!!

Thanks for a great game ..worked awesome on my old Sony Xperia Z and still runs kick ass on my Nvidia Shield.

Eledor

Post edited by Eledor on
thebaconburger
«1

Comments

  • thebaconburgerthebaconburger Member Posts: 3
    I'm also having the same issues on S7 edge. The game will start out running fine but after a few seconds it starts running slow.

    Eledor
  • elminsterelminster Member, Developer Posts: 16,008
    So its most noticeable in combat. Are there any other areas specifically where the game runs slowly? (playing movies, casting spells outside of combat, etc)

    Eledorlolien
  • EledorEledor Member Posts: 16
    edited July 2016
    Thanks for chiming in BaconBurger and Elminster! I also saw in the Google Play Store that someone playing Ice Wind Dale on the Samsung Galaxy S7 Edge has same issue... so we are not alone.

    I thought for a bit that clicking on my party members on the right hand side fixed the issue.. sadly, that was a false hope.

    The game starts out running fine but soon as I enter combat, when I cast spells, playing a movie it all gets sloooooow. So slow it is unplayable and not fun. I pretty much have to exit the game and then get back in and then it will run fine for about 3 minutes and then turn to molasses. Gotta be some sort of bug as this phone is bad ass spec wise...

    Please let me know how I can help troubleshoot!!

    Best Regards && Thanks for porting this game,

    Eledor

  • EledorEledor Member Posts: 16

    And yes, outside of combat too... just walking around the map becomes agonizingly slow also.

  • thebaconburgerthebaconburger Member Posts: 3
    Yep happens in and out of combat. Sometimes hitting the multitasking button then going back into the game will fix it for a few seconds but it never lasts.

    Eledor
  • EledorEledor Member Posts: 16
    Bump....

    I dont want to have to summon my Fire Elemental.... anybody on Beamdog looking at this?

    thebaconburger
  • CruxisCruxis Member Posts: 2
    Same for me, it's generally unbearable within 5 seconds.

    To elminster's questions:
    1) It is noticeable on any screen where the game is playing. Character and NPC movement is jagged and skips frames. In combat it is especially noticeable (and by noticeable I mean it takes 5-10 seconds for characters to attack, spells are just a waste of time).
    2) FMV sequences (such as resting), do not seem to be affected.
    3) When moving inventory items, the animation appears smooth (but the sprites have no animation).

    Hope that helps !

    Eledorelminsterlolien
  • NaugrinNaugrin Member Posts: 9
    Same here with a note 7. Similar but iirc it has a different processor. It ran pretty well on my old note 2. Kind of a bummer....i now have room for most anything but that doesn't help if the performance suffers lol.

  • NaugrinNaugrin Member Posts: 9
    I tried bg1 with the same results.

    lolien
  • NaugrinNaugrin Member Posts: 9
    I just registered and reported this via redmine. I was disappointed to see it classified as as a minor bug. It makes the game I played for unplayable. It seems rather major to me.

    I was not sure what version I should have put so put the most recent (I think).

    As this happened on both bg and bg2, I put it under infinity engine (not sure if that's the correct spot).

  • Spencer_HarrisonSpencer_Harrison Member Posts: 1
    Just wanted to add my name in here: Icewind Dale EE on a Note 7. Movement of the sprites is unplayably slow in every scenario, even though the menus and sound work great. Please fix!

  • EledorEledor Member Posts: 16
    So, howabout an update from the Beamdog devs?

  • elminsterelminster Member, Developer Posts: 16,008
    edited August 2016
    Naugrin said:

    I just registered and reported this via redmine. I was disappointed to see it classified as as a minor bug. It makes the game I played for unplayable. It seems rather major to me.

    "Minor" is just the default setting when anyone posts a bug report.

    lolien
  • RubiconRubicon Member Posts: 3
    Experiencing the same problem on the note 7, with both BG and BGII. It should be highlighted that the game is unplayable, not just slow. Unplayable.

    An update from the devs would be nice, or atleast acknowledgement that this is an issue that they are aware of. There are a lot of Samsung users that would love to play these beloved RPGs and losing that fanbase would leave many of us quite disappointed.

    I was looking so forward to playing it with the S Pen too

    Naugrin
  • jtw29gjtw29g Member Posts: 3
    Here is a current workaround:

    http://redmine.beamdog.com/issues/25834

    Minimize character bar

    lolien
  • EledorEledor Member Posts: 16
    Thank you jtw29g for posting that workaround... while not ideal it does allow us to play the game on our phones. I cast Bless and Chant upon thee!

    lolien
  • Il_Più_AnticoIl_Più_Antico Member Posts: 16
    on snapdragon 650 don't work

  • EledorEledor Member Posts: 16
    Actually, i thought it helped but it didn't (minimizing the character bar). It was a bit faster but combat is slow as molasses still on Samsung Galaxy S7 Edge.

    JuliusBorisovlolien
  • risborisbo Member Posts: 6
    Still no official word from devs?

    The issue will keep getting bigger & bigger as people get adreno 500 gpu..

  • Il_Più_AnticoIl_Più_Antico Member Posts: 16
    No patches so far really disgraceful behavior of Beamdog not buy never a game them...

  • RelSundanRelSundan Member Posts: 917
    Just want to add a thing or two.

    1. I believe the devs are in fact looking into the matter. They are not godlike beasts who can identify a problem the second he/she hears about it. The specific problem you have come up with is probably rather new. Let's take into account that the devs may not have access to a phone who uses the same GPU and specs as you at the current time. Thus preventing them to see the problem for themselves.
    2. Provocing the developers and other staff members is not how you get the attention you need. It will just make things worse. Insultings are never necessary.
    3. Let me come with a solution for you. Since you guys seem to be so impatient and in such a hurry, may I recommend that you just buy yourself a computer capable of running the game? A laptop for 200-300 dollars should suffice. It is not the cheapest solution, but it is the only one as of know.

    Thank you.

  • EledorEledor Member Posts: 16
    Hi RelSundan,

    I wanted to respond to your comments... I guess the first thing I would say is that I (we who own Samsung Galaxy S7 Edges) reported this bug on July 9th. It is now November 23rd. That is 4 and a half months of no official response from Beamdog. I do not think we are being unreasonable in being persistent.

    You suggest us buying a different device to play the game and then at the same time say that the company may not have our device to test. I do not think putting this on us is fair. We paid for the game, it should run on our devices.

    As to insulting the devs... I know I haven't and from quickly scanning this thread I do not see anything overly mean. We just want the game patched and even more than that some sort of official comment from Beamdog on our issue. Ignoring us is not the way to run a business.

    That being said, I love BGI and BGII and even just bought Siege of Dragonspear for my Mac to play over Thanksgiving... I support them but would just expect the same support from them.

    Cheers,

    Elder

    RelSundanlolien
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,459
    @Eledor, as I asked in a similar thread: When did the issue appear? Was it when you installed the game on the new hardware?

    RelSundan
  • RelSundanRelSundan Member Posts: 917
    Eledor said:

    Hi RelSundan,

    I wanted to respond to your comments... I guess the first thing I would say is that I (we who own Samsung Galaxy S7 Edges) reported this bug on July 9th. It is now November 23rd. That is 4 and a half months of no official response from Beamdog. I do not think we are being unreasonable in being persistent.

    You suggest us buying a different device to play the game and then at the same time say that the company may not have our device to test. I do not think putting this on us is fair. We paid for the game, it should run on our devices.

    As to insulting the devs... I know I haven't and from quickly scanning this thread I do not see anything overly mean. We just want the game patched and even more than that some sort of official comment from Beamdog on our issue. Ignoring us is not the way to run a business.

    That being said, I love BGI and BGII and even just bought Siege of Dragonspear for my Mac to play over Thanksgiving... I support them but would just expect the same support from them.

    Cheers,

    Elder

    Heya, I realized later the date of the post and withdraw my previous comment on that point. As for the insulting devs comments, you are not the one I addressed. Just above my first post you can see someone who did behave in an offensive matter.

    Cheers.

  • CruxisCruxis Member Posts: 2

    @Eledor, as I asked in a similar thread: When did the issue appear? Was it when you installed the game on the new hardware?

    For me, the issue started the very first time I ran the app on my Galaxy S7 Edge. As I haven't run the app on any other device, I cannot attest to whether it has worked correctly on older devices.

    JuliusBorisovlolien
  • RelSundanRelSundan Member Posts: 917
    edited November 2016
    Is there a minimum requirement for specs needed to run the games on the mobile version? @JuliusBorisov?

  • GallowglassGallowglass Member Posts: 3,356
    @Eledor, @risbo - Possibly you aren't aware, but you have had official responses. Both @elminster and @JuliusBorisov have engaged in this thread, asking for more details of the issue, and they're both Beamdog team members - you can tell by the blue background to their posts.

    You haven't yet had an official response which offers a solution (which is presumably because they don't yet have a solution!), but the fact that they're asking you questions shows that they're looking at the problem.

    JuliusBorisovRelSundanlolien
  • EledorEledor Member Posts: 16
    Hi,

    Yes, it was slow the first time I installed the game on the phone. This phone is bad ass spec wise....maybe it is a chip set issue or something. I dont know. I'm in DevOps not mobile phone app development.

    JuliusBorisovlolien
  • bobw82bobw82 Member Posts: 1
    I am having the same issue different phone though. Using a blu life one x2.
    Android OS, v6.0.1 (Marshmallow)
    Chipset Qualcomm MSM8937 Snapdragon 430
    CPU Octa-core 1.4 GHz Cortex-A53
    GPU Adreno 505
    MEMORY
    64 GB, 4 GB RAM

    lolien
  • RelSundanRelSundan Member Posts: 917
    Sadly I can't get my hands on any info regarding required specifications for running this game on any phone. If any dev could provide me with that info I could probably rule out the problem. This certainly seems like a lack of power in the phone. It's kinda unfair because (As far as I know) there is no way of knowing if you can run the game or not, until you actually bought the game..

Sign In or Register to comment.