Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

"Failed to save file" error when modding Baldur's Gate

Peter_PaladinPeter_Paladin Member Posts: 15
So I was going to make some custom items using DLTCEP, and things seemed to be going well. BUT! When I saved the file, it gave me an error message saying "Failed to save file". The same thing happened when I tried to save an unedited .itm file, and on NearInfinity. What am I doing wrong? FYI, I am using Windows 7 64 bit, with Baldur's Gate installed to C:\Program Files (x86)\Black Isle\Baldur's Gate, but some of the important files and folders (But none that the program asked for) are installed in C:\Users\Computer Room\AppData\Local\VirtualStore\Program Files (x86)\Black Isle\Baldur's Gate. Can any of the experienced users please help a noob and up-and-coming modder? Thanks ahead of time!

P.S., does anyone here know where I would put a custom inventory icon in .BAM format?

Comments

  • GusindaGusinda Member Posts: 1,588
    @Peter_Paladin, I would guess that there are permissions on the folder preventing you from saving. What you could try is to save the files outside of the folder (create a folder in C:\ or into My Documents or in another drive). This would at least test the save.

    In installing games, I rarely (only becuase some refuse to be installed anyway else) install into the default folder. I have a E:\Games folder in which they get installed into. This is to prevent any of the permissions problems and keep them away from my system drive.

    So far as the BAM goes, I think from the question, you are asking how to create one? If so, then I create or modify using a PNG format (41x41 pixels), then import into NearInfinity, convert there and allocate to item/spell using a previous BAM shell.

    Hope it works out.
    Gus

    Peter_PaladinRaduziel
  • Peter_PaladinPeter_Paladin Member Posts: 15
    edited June 2018
    Well, I tried putting it in My Documents, but it still didn't work. I got the same error message. The same thing happened when I tried writing the file to drive F:. What now?

    EDIT: I also tried saving a store, but to no avail. Same error message.

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    Those tools typically save to the override folder, which is located in the game folder for these old games.
    Since Windows Vista, C:\Program files and C:\Program Files (x86) are locked and prevent any change, unless you disable security checks or enforce access using an administration account.
    The "Virtual store" is the place that is used to store modifications if you somehow force changes to happen.

    For your save to work, you could probably run DLTCEP as administrator. However I suggest you reinstall the game outside of C:\Program Files (x86).

    For further reference read that tutorial. The core cause (protection of C:\Program Files) remains true with every version since Vista.

    RaduzielPeter_Paladin
  • Peter_PaladinPeter_Paladin Member Posts: 15
    Thank you so much. That fixed it! (But really, why didn't I think to run as an admin?)

    Gusinda
Sign In or Register to comment.