Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Multiplayer game session terminating when saving - v2.3.67.3

RadzieoonRadzieoon Member Posts: 1
edited July 2018 in Troubleshooting
Hi

The main issue are crashes on every save, so that is also occuring on location change, which is an autosave. By crash I mean the game hanging for a 10-20 seconds for both players and then 'game session terminated' disconnect for the joining player, but host usually stays in the game and the save is done. This makes it unplayable, because the moments there's location change or we need to save manually are frequent and it takes a minute to join and adjust heroes and permitions again and again. There are also disconnects when trying to modify the character but that's not that important for playability.

I know there is a common problem when saves don't show up, but this is not the case - the saves are there.

We use polish language, same version, no mods, my friend even bought the dlcs to have the same exact version as me and it didn't help neither.
We have to play trough hamachi, because the server doesn't show up in the game, so we connect through the hamachi ip. We ping each other on hamachi without a problem.

In the first day I hosted the game and everything went smooth, but the day after suddenly my friend couldn't join the server (he was showing up to me for a few seconds and then everytime he was getting game session terminated). It was only the case when I loaded the game, no matter if the heroes were loaded or deleted from the save or deleted and imported again. When I started a new game he could join, but there was the save issue so when after disconnect he had to join, he couldn't again. Then I sent him the save and we tried him hosting the game, I could join loaded games without a problem, but the save issue still existed.

We tried disabling all firewalls etc.; setting all options to the same values; setting the game to window mode; setting the admin on .exe; setting windows compatibility to Win7 and then to Win XP; tried the different player permition options in the game; copying some phrase to baldur.lua (although this was the solution for some old versions I think); clearing the baldur folder in documents; setting AI of all characters to standard attack and switching AI off: https://forums.beamdog.com/discussion/52986/work-around-2-1-multiplayer-crashes-when-saving-or-quick-saving
;switching the language to english and loading the saved game, saving it and the switching to polish and loading the new save; 2.5 beta; few other things. Nothing worked.

We'll try today to start the new game in english, change characters AI to none (we didn't try 'none' yet but in the link above the support said that apparently the saves don't like the 'none' value, however someone said that 'none' worked for him), save the game, switch to polish, load the game. If it doesn't work I'm gonna give up.

Comments

Sign In or Register to comment.