Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Installing Mods in OSX a quick tutorial

mlnevesemlnevese Member, Moderator Posts: 9,581
Hello People, as promised, here follows a brief tutorial on how to install mods in the Mac BG EE Version.

As you'll see it's not as straight forward as installing mods in the windows version, but it's doable.

First of all, get the mods you want. I have compiled a Quick list of all mods compatible with the EE announced in the forum HERE

Next step is navigating to your BGEE folder.

In Finder, go to Applications/Baldur's Gate-EE/Game Data/00777/. Right click on "Baldur's Gate - Enhanced Edition" and select "Show Package Contents." Go to Contents/Resources. The Override folder will be there, along with the game data.

Unzip all the mods you will want to use in this folder.

After unzipping your mod, copy dialog.tlk from the lang/your language folder, en-us, for instance to the Resources folder. I found out making a link is not actually that useful as it's just deleted on a game update.

Now we'll need a MacOSX compatible Weidu. Thanks to @Nifft we have one. I've attached it to this post, but go HERE and give @Nifft all the likes he deserves.

Now we'll need one Weidu copy for every mod you wish to install.

First unzip the weidu for OSX attached to this post.

Look for the setup-xxxx.exe in the mod you just uncompressed. That is the windows installer.

Rename Mac Weidu to the SAME NAME of the windows installer WITHOUT THE .EXE EXTENSION

So if you wanted to install BP-Series by @horredtheplague, for instance, you'd rename weidu-osx-intel into setup-bpseries.

Copy the renamed mac weidu into the resources folder above.

And now the last steps.

Open a terminal window.

Type, or just copy and paste the foollowing command:

cd /Applications/Baldur\'s\ Gate\ -\ Enhanced\ Edition/Game\ Data/00777/Baldur\'s\ Gate\ -\ Enhanced\

If you don't want to copy the dialog.tlk every time you install a mod type:

ln -s lang/en_us/dialog.tlk dialog.tlk

Remember to change en_us according to your language folder.

Type ./setup-xxxxxx

Keeping with my BP-Series example above, you'd type in the terminal prompt


Answer the questions Weidu will make.

Enjoy your mods ;)

If you have any doubts or ideas about this little tutorial, post them here.

If you notice any mods missing in the Quick Links thread, post there o PM me and I'll add it ASAP.

Once more my thanks to @Nifft for porting Weidu to OSX.

*IMPORTANT* You need administrative rights to install mods in OSX. If you get a permission denied error, make sure you're logged in with an Administrator account.

Post edited by mlnevese on


  • NifftNifft Member Posts: 1,065
    edited March 2013
    Original post updated with the new one from here:

    Enjoy! -- N

    --- original message ---

    Note that the WeiDU that I built was based off the Development branch (to get as many features as possible).

    I can and will do a build from the Stable branch eventually, but if there are any problems with this version I'll make that a higher priority.

    One note: I seem to have the binary in ".../Game Data/00777/..." rather than 00774, so the path in your post might not work for mere consumers like myself.

    Second note: what I do for the "setup" programs is just a symlink. This is nice because you don't have to keep track of what you've named what, and if you want to use a newer version of WeiDU, it replaces all "setup-XXXXXX" at once. That would work like:

    ln -s weidu-osx-intel setup-bpseries

    Cheers, -- N

    Post edited by Nifft on
  • mlnevesemlnevese Member, Moderator Posts: 9,581
    edited February 2013
    @Nifft You got me while I was still editing my post ;)

  • NifftNifft Member Posts: 1,065
    @mlnevese: One of your paths still has 00774, and the other path is just 0077 (one 7 too few).

    I do like how BG paths all seem to start with "007".

  • Avatar1138Avatar1138 Member Posts: 2
    1st off, much respect & gratitude to minevese (and Trent, Camdawg & all the devs) who have worked so hard to keep BG alive & playable on a Mac. Although I started playing D&D before their was an "A" in front, I missed out on BG the 1st time around. So a sincere thanks to all for letting me relive my youth.

    Regarding the simple experience cap removal mod, is it necessary to do a Weidu install on a Mac, or can the files simply be dropped into the Override folder, like on the Windows version?

  • NifftNifft Member Posts: 1,065
    Simply dropping in the files ought to work.

  • Avatar1138Avatar1138 Member Posts: 2
    Much obliged. I already downloaded the files mineverse posed on the Windows forum and thought that would work, but I though it would be prudent to run it past the experts. Running a Kensai to dual to a mage, and would like to pull the trigger at lvl 9 with some hope of being able to dual wield again before bg2ee comes out.

  • CamDawgCamDawg Member, Developer Posts: 3,394
    Please note that many mods do have an OS X version available for download--you'll still need to update the WeiDU executable, but they have install scripts you can double-click instead of command-lining it and (in some cases) have OS X-appropriate helper programs such as sox instead of oggdec.exe.

  • revaarrevaar Member Posts: 160
    Is there a guide anywhere for getting EE Keeper to work in OSX? I've downloaded the .rar file in the "getting shadowkeeper to work in BGEE" thread, but i do not actually know how to install it....

  • NifftNifft Member Posts: 1,065
    edited February 2013
    revaar said:

    Is there a guide anywhere for getting EE Keeper to work in OSX? I've downloaded the .rar file in the "getting shadowkeeper to work in BGEE" thread, but i do not actually know how to install it....

    Not yet.

    I've done some testing in this thread:

    ... and the Wineskin was trivial, but my setup seems to be different from more recent OS/X versions. I'm running 10.6 (Snow Leopard?), and the EE Keeper I've posed in that thread ought to work for any 10.6 users, but I don't know if it'll work for more recent OS/X versions, nor can I test them.

    EDIT: better diagnosis.

    Post edited by Nifft on
  • NifftNifft Member Posts: 1,065
    @mlnevese - there's a new binary for weidu, could you remove the old binary from the first post?

    I've edited the 2nd post to contain a link to the new binary.


  • mlnevesemlnevese Member, Moderator Posts: 9,581
    @Nifft updated the binary in first post and edited your second post to remove the warning. Thanks :)

  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    As you already know I translated your guide in the italian subforum.
    I just want to thank @mlnevese and @Nifft for your guide and for your support.

  • yhm2001yhm2001 Member Posts: 2
    any way to get the BGEE Autoroller v3 to work on the mac version? I tried this approach but it doesn't work for it because the mod doesn't require a setup (you just open the .exe file in a new window). Thanks!

  • mlnevesemlnevese Member, Moderator Posts: 9,581
    edited March 2013
    @yhm2001 Sorry it won't work. It's a windows executable and not a mod.

    Post edited by mlnevese on
  • RichieGroinstabRichieGroinstab Member Posts: 7
    I'm having trouble with XPCAP.2DA not being recognised in override with the App Store version.
    Worked fine under the Beamdog windows variant...

    Anyone had any luck with removing the XP cap in OSX yet?

  • mlnevesemlnevese Member, Moderator Posts: 9,581

    Just download the file from here and send them to override. xpcap.2da is not enough anymore.

  • RichieGroinstabRichieGroinstab Member Posts: 7
    Thanks buddy, will try that tomorrow.

  • BlinkkBlinkk Member Posts: 25
    My sister gifted me BGEE for my birthday through the itunes app store and it's been a nightmare trying to get it up and running. After waiting 9 hours for it to download, it finally finished. Then, I was unable to see the game anywhere on my computer. It doesn't appear in my Applications folder and I can't find it in the launchpad. I see it in the finder, but my laptop won't open it with any application. I'm not sure what to do from here.

  • mlnevesemlnevese Member, Moderator Posts: 9,581
    @Blinkk Something went wrong with the download then. Any app acquired through the App Store automatically goes to the Launchpad. Also it took too long to download unless your connection is quite slow.

  • subtledoctorsubtledoctor Member Posts: 11,394
    edited April 2013
    EDIT: see post below for a version of this that supersedes the info in this post!

    Post edited by subtledoctor on
  • subtledoctorsubtledoctor Member Posts: 11,394
    edited April 2013
    I made a post over in the modding subforum with a link to my OS X WeiDU launcher.

    This is a small app that uses a simple system of menus to:
    1) Create a symlink to the copy of dialog.tlk in the /lang folder of the user's choice (if it has not already been done;
    2) Allow the user to select from all available mods (based on the presence of .tp2 files in the BG folder or any subfolders);
    3) Create an appropriately-named symlink to the Mac version of WeiDU; and
    4) Launch Terminal and begin installation of the chosen mod.

    This should take away most if the annoying and/or difficult work mentioned in this thread, and make WeiDU a double-click affair, even a bit simpler than it is in Windows. It's pretty much a beta but it worked in testing on different mods with various file-naming and file-structure schemes.

    Post edited by subtledoctor on
  • joeyoakleyjoeyoakley Member Posts: 2
    firstly can i just say much love to all the modders for all the tinkering you do with one of my favourite games ever!! The problem I have is that I am not the best with computers and to be honest I cant figure out what to do. Basically what I am looking for is some weapons, some armour and the ability to tinker with the stats, thac0 etc.. I followed mlnevese, but could not find the exe. what am I supposed to see when it has been unzipped??? i seem to just create new shortcuts to the rar file. If somebody could help me I would much appreciate it - just imagine trying to explain it to a small child, i may get it then. Much love

  • subtledoctorsubtledoctor Member Posts: 11,394
    @joeyoakley Do you have a program to unzip .rar files? It's like .zip, just a different kind of compression. There's a free program to for it - google "UnRarX," it's something like that.

    Then try the link in my post just above yours.

  • sithlord344sithlord344 Member Posts: 6
    Ok, on the Neera expansion mod I have bgee_install_neera_setup.bat, a neera folder, and weidu.exe. What do I rename the file here to?

  • subtledoctorsubtledoctor Member Posts: 11,394
    edited April 2013
    @sithlord344 have you downloaded Mac WeiDU from Nifft's post? It should be named "weidu" with no extension. Then, if you're using my installer you shouldn't need to rename anything - the installer will do it for you.

    If you're running WeiDU from the Terminal manually, go into the 'neera' folder and look for a file with the .tp2 extension... if it is named "wxy.tp2" then you want to rename Mac WeiDU to "setup-wxy"...(if the .tp2 file already has "setup-" in the name then don't add it again, in that case give Mac WeiDU the same name.)

  • JBCJBC Member Posts: 4
    edited April 2013
    Hello there,

    First of all, thanks for this tuto.
    But I have a little problem. Like Blinkk my BG:EE is a gift, bought on App store, so the file is not exactly the same (I don't know if it's the same for you, but the save, character or Portraits files are in the Library)

    When I follow your tuto (with kitpack, wich is in the list of mod you gave), I enter: "/Applications/Baldur\'s\ Gate\ -\ Enhanced\" this message appears in my Terminal:

    "[/Applications/Baldur's Gate - Enhanced] WeiDU version 23107
    This is a non-stable version. Unless you're sure about what you're doing, consider downgrading.
    ERROR: Cannot perform auto-update, going ahead anyway!
    Sys_error("setup-kitpack: No such file or directory")

    ** ERROR ** [SETUP-KITPACK.TP2] not found.
    Make sure that you have unpacked the archive correctly and
    that you are not trying to run this file from inside an archive.
    ERROR: Unable to find CHITIN.KEY in:

    FATAL ERROR: Failure("Unable to find CHITIN.KEY: run me in an Infinity Engine game directory")

    Press ENTER to exit."

    Setup-kitpack.tp2 already exist (and chitin.key too...), I'm in the Resources folder, my mods are unziped and I changed the tp2 name, and weidu is updated and right named too... so I don't understand. I'm a new Mac user and english is not my mother language, to make things easier.

    Is it possible that my problem comes from App stope edition ?

    Thanks guys

    Post edited by JBC on
  • subtledoctorsubtledoctor Member Posts: 11,394
    Which edition you use shouldn't make a difference.
    JBC said:

    I'm in the Resources folder, my mods are unziped and I changed the tp2 name, and weidu is updated and right named too...

    FYI you shouldn't do anything to the .tp2 file, you want to leave it named as it was. It's WeiDu you want to rename.

    But I suspect the real problem is with that long-ass Terminal command. Try this: open Terminal and type "cd " (that's C, D, space). Then, in the finder, go into the /Contents folder, so you can see the Resources folder. Drag the Resources folder into the Terminal window, and press enter. Now just type "./setup-kitpack" and the mod should run.

    OR download my installer, put it in the Resources folder, and double-click it. Much simpler, and I'm curious to have someone test it on the App Store version...

  • JBCJBC Member Posts: 4
    edited April 2013
    Thanks for the answer. I tried your installer, just like in your video. It looks very easy, however the installation stops and a message appears: "In: /Applications/Baldur's Gate - Enhanced Pemission denied" (This is not in the Terminal, just a Mac error message), with two options: "Edit" or "OK"

    If I press edit, I'm sent on something that might be the console.

    I feel so stupid, unable to use my mac...

    With mlnevese tuto: I tried to do just like you explain (terminal, cd , etc): I tried with 2 diff mods (kitpack and BP series). Here is the error message on the terminal that I've got:
    Terminal said:

    new-host:Resources myname$ ./setup-kitpack
    [./setup-kitpack] WeiDU version 23108
    This is a non-stable version. Unless you're sure about what you're doing, consider downgrading.
    WARNING: unable to open log file [SETUP-KITPACK.DEBUG]: Sys_error("SETUP-KITPACK.DEBUG: Permission denied")[./chitin.key] 195 BIFFs, 34857 resources
    [dialog.tlk] 32141 string entries
    [./setup-kitpack] Using scripting style "BG2"
    [dialog.tlk] claims to be writeable.
    [dialog.tlk] claims to be a regular file.
    WARNING: parsing log [WeiDU.log]: Sys_error("WeiDU.log: No such file or directory")

    The KITPACK.TP2 mod has 34 distinct optional components.
    To save time, you can choose what to do with them at a high level rather
    than being asked about each one.

    What should be done with all components that are NOT YET installed?
    [I]nstall them, [S]kip them, [A]sk about each one? A
    [./DATA/OH9310.BIF] 387816 bytes, 9 files, 1 tilesets

    SKIPPING: [Compatibility adjustments for BG2, BGT and BG TuTu]
    Not BG2 so skipping this component

    SKIPPING: [Update default Helm kit? (BG2)]
    Not BG2 so skipping this component

    Install Component [Update default Helm kit? (BG:EE)]?
    [I]nstall, or [N]ot Install or [Q]uit? I
    Problem Unix.Unix_error(1, "mkdir", "kitpackbackup") on kitpackbackup:
    Problem Unix.Unix_error(20, "mkdir", "kitpackbackup/2") on kitpackbackup/2:
    WARNING: unable to open [kitpackbackup/2/UNINSTALL.2]: Sys_error("kitpackbackup/2/UNINSTALL.2: No such file or directory")
    Will be unable to UNINSTALL later.
    ERROR: Sys_error("kitpackbackup/2/ARGS.2: No such file or directory")"

    Any idea ? :(

  • subtledoctorsubtledoctor Member Posts: 11,394
    edited May 2013
    Sounds like a permissions problem - like you don't have write access to the Resources folder. Because when using the installer app, the WeiDu symlink ("setup-kitpack") does not seem to be executable; and when running from the Terminal, WeiDu does not seem to be able to create the subdirectories it needs.

    Are you the main user on the machine? Modding involves editing files within the main /Applications folder on the Mac; if you do not have an admin account, it might not let you edit them. I suppose this might also be an issue with Gatekeeper if you're on Mountain Lion... I don't know exactly how it works, but it could conceivably be by locking down permissions in the /Applications folder. Or it could just be that apps from the App Store don't let users mess with files within them... Bottom line is, this is all fixable (if you have an admin account).

    Try right-clicking on your Resources folder, choosing "get info," and look at the permissions at the bottom of the info window. Make sure you have read and write access to the folder.

    Post edited by subtledoctor on
Sign In or Register to comment.