Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

There's currently a forum problem with avatars not showing in reactions.
Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Great, stuck in Durlag's Tower 2 :(

WiduWidu Member Posts: 5
edited June 2014 in Not An Issue
Just to be sure it's not me doing something wrong, here's the walkthrough:

2- STATUE ROOM:

Now head southwest into a room with a number of statues and two secret doors. Two of the statues can be rotated. Activate the lower statue by rotating it to open the door to a bedroom that leads off the round room where you entered. You will get a message that says: The halls resonate with the sound of grinding stone. A door has opened somewhere nearby". While here also check out the pedestal at the far end of the room for loot, be careful its trapped and locked but contains a pearl, 346 gold pieces, four potions of healing, an antidote potion, a scroll of Greater Malison and five scrolls of Haste. Now head back to the NE and find the bedroom you just opened (we'll activate the other statue to open the Practice Chamber room later).


So far so good.


3- BEDROOM:

Colored Rune Stones: In this room you will find three colored rune stones. As you enter the room two more secret doors should be outlined in red. Neither will open at this juncture. In the center of the room there is a seating area with a chest. Open it and retrieve the red rune stone. As soon as you do this a secret door opens to the SW that leads back to the statue room. A figure appears in the corridor behind the secret door, now open, who is identified as Durlag Trollkiller. Don't be fooled. Durlag is long dead, so this must be a doppelganger. Get ready for a fight because as soon as the figure finishes his dialog he transforms into a greater doppelganger and launches a fireball into the room. Pummel this cretin and retrieve a diamond off its corpse. Be prepared for more doppelgangers in disguise on this level. Now you can enter the secret passage and pick up another book off the floor that reads:
�Foul mimic of the mortal man; �T was in my shape they killed Islanne'.

Now on either side of the bed you will find chests each containing another colored rune stone, one orange and one green. When you pick up the orange rune stone you should hear the Practice Chamber Room door open. If not, we can open it with the other gargoyle.

Also in the room is a locked closet containing an Adventurer's Robe, scrolls of Domination, Spirit Armor, Remove Curse and Monster Summoning II, Darts of Wounding, Darts +1 and Bullets +2.


Yep, door to the opposite room opens upon taking the stone.


4- SPARRING CHAMBER ROOM:

Getting In and Disarming the Traps: The doors to this chamber are opposite those of the bedroom leading off the round entry room. Do not enter at this time as the floor has seven closely packed traps and another doppelganger is waiting to ambush you. Rather, take your party back to the gargoyle room where the secret passage door should now be open as well. If not, you can open the main door by rotating the upper gargoyle, but notice when you do this that the doors to the bedroom simultaneously close.


No, it isn't open, neither does using the statue work. Nothing happens, and there's no doppleganger in the room either. No way to open any stupid door except for those already used. :(
...now I remember why I didn't like TOSC in the first place.
Any thoughts?

Post edited by Tresset on

Comments

  • GallowglassGallowglass Member Posts: 3,356
    Hmmm, never had that problem myself, turning the statues has always worked for me (i.e. opened and closed the specified doors), both in original BG1:TotSC and in BGee.

    Remember that there are 2 statues to turn, and at this point we're talking about the other one, not the one you used first. And to turn a statue, your character must be already standing right next to the statue - it'll ignore you if you're too far away. Otherwise, you can also manipulate some of the doors by placing the coloured wardstones in the practice dummies of matching colour to each wardstone (i.e. red wardstone in red dummy, etc.), which might (or might not, but worth trying) get you out of a stuck situation.

    If none of that helps, then ... it might be time to cast "Power Word: Reload" and re-enter the level.

  • WiduWidu Member Posts: 5
    Standing nearly on top of the statues doesn't help either. They simply don't work as supposed to, except for the bedroom and the dummy room, and the training dummies do nothing at all.

    Re-entering the level makes no difference either :(

  • GallowglassGallowglass Member Posts: 3,356
    Hmmm, sounds like you've got a bug, then. But it might be a difficult one to track down, because it doesn't happen to everyone all the time.

    I suggest sending a savegame which exhibits this problem to [email protected]

  • WiduWidu Member Posts: 5
    I do run the Mac version, so I suppose that makes a difference as well.

  • atcDaveatcDave Member Posts: 1,933
    Try shooting the sparring dummies. This will open the remaining door from the entry chamber.

  • nietzschelivesnietzschelives Member Posts: 36
    Sorry to resurrect an old thread, but I have encountered a similar problem. When I shoot the dummies, a dialogue appears stating that a door has been opened, and there is a sound effect for a door opening, but the northeastern chamber door does not open (nor do any other doors.) This prevents me from progressing further into the level.

  • IllydthIllydth Member, Developer Posts: 1,641
    I'm not sure if this was ever originally solved or not...the thread wasn't updated with the information.

    I would recommend to you to look up/find an online walkthrough for the level. This is one of the trickier levels in the entire game, and you may be missing a step. I can tell you that I got through this on the iPad version without a hitch a few weeks ago (pre 1.2 patch) but it was NOT trivial. There's A LOT you can miss.

    blackeyez
  • nietzschelivesnietzschelives Member Posts: 36
    I checked the walkthrough on Gamebanshee; pretty sure I did it right. I have played through this section before (not in EE) without problems as well. It's still definitely possible I'm just missing something. It's also possible the bug occurs if the doors aren't opened in the exact right order (shouldn't be a problem, but who knows?).

    For right now I'm just skipping Durlag's tower because I can't wait to get to BG2EE.

  • SivarSivar Member Posts: 53
    I experienced this bug as well. My workaround, until it is fixed, was to place the runes back onto the bedroom furniture. Note that this triggers a fireball each time.
    For some reason doing this returned the items to my inventory (without me getting them from the furniture) and opened the next door.
    I found this solution by searching these forums. It seems even at 1.2, BGEE is a bit buggier than the original. (I'm experiencing the "unkillable wolfwere bug" right now, too).

    sunset00
  • nietzschelivesnietzschelives Member Posts: 36
    ^ I attempted this. It works! Now I can continue with Durlag's Tower! Ugh, now I have to do Durlag's Tower.

    @Sivar, Seriously though, thanks for the tip.

  • nulspacenulspace Member Posts: 100
    Bumping this - was playing through Durlag's tower today and experienced this bug (northern statue in the first statue room not turning, therefore unable to access the northern hallway with the second doppleganger).

    My solution was to attack the training dummys (as per @atcDave), which worked to open the doors.

  • TressetTresset Member, Moderator Posts: 6,859
    What happened here is that whoever wrote that walkthrough on GameBanshee didn't know what they were talking about. The walkthrough is flawed in many ways. Let me set it straight now.

    Lets start at the point at which you have taken all the wardstones from the bedroom. Once you take all three wardstones two things should happen. First the wooden door to the target practice room should open (triggered by taking the orange wardstone). Second the doppelganger will start its dialog and teleport sequence (triggered by taking the red wardstone). The doppelganger's sequence itself triggers the closing of the wooden door to the bedroom and opens the secret door from the bedrom to the statue room. IT DOES NOT OPEN THE SECRET DOOR FROM THE SPARRING ROOM TO THE STATUE ROOM!!! The two statues in the statue room will ONLY OPEN THE MAIN WOODEN DOORS TO THEIR RESPECTIVE ROOMS!!! THE ONLY WAY TO OPEN ANY FURTHER DOORS FROM THIS POINT IS TO ATTACK TARGET DUMMIES!!! The target dummies will only open doors if you have the same color wardstone obtained from the bedroom in your possession! Attacking the red target dummy opens the wooden door to the bedrom if it is not already open. Attacking the green target dummy will open the door to the throne room if it is not already open. ATTACKING THE ORANGE TARGET DUMMY WILL TRIGGER THE ENCOUNTER WITH THE SECOND DOPPELGANGER AND OPEN THE DOOR FROM THE SPARRING ROOM TO THE STATUE ROOM.

    Thus everything is working as intended and this is not an issue. The walkthrough is, however, very stupid.

    MereinidMortinBishop
  • MereinidMereinid Member Posts: 43
    Tresset!!!! TThank you for clearing this up, I have been trapped for like 3 hours trying to get back into the damn throne room. I followed the guide on the GameBanshee which told me to run in, very fast and grab the helmet and run out. The door locked and I could not get back in.

    Let me know if you want to do an updated 100% factual walkthrough, I would be game.

    Luck and loot,
    Mereinid

    Aerakar
  • MortinBishopMortinBishop Member Posts: 1
    Tresset was spot on. If you are stuck at Throne Room door, read his post from June 2014.

Sign In or Register to comment.