Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

So Importing pictures still doesn't work...eh?

I tried and got blank pictures, did they fix this yet because I really want more pics?

«1

Comments

  • atcDaveatcDave Member Posts: 1,933
    edited March 2013
    I'm not sure what problems you're having, but I've got a folder full of usable portraits. Did you size them wrong or use the wrong format? (should be 169 x 266 pixel and 54 x 84 pixel. both in 24 bit BMP)

    Post edited by atcDave on
  • secretmantrasecretmantra Member Posts: 259
    Works for everyone else.

    Describe in detail what you are doing, and we can try to help.

  • wariisopwariisop Member Posts: 163
    Does anyone know a way to properly resize photos, I suck at Windows painter?

  • secretmantrasecretmantra Member Posts: 259
    Never tried Windows painter. I use Photoshop to create my portraits.

    There is a freeware program called Gimp, that works for this. I've never used it myself but I know a lot of other folks have used it successfully.

    Keep in mind you need to:
    A) size the images correctly (210x330 pixels for L, 169x266 pixels for M, and 54x84 pixels for S), and
    B) save them out as the correct file format (24-bit BMP).

  • wariisopwariisop Member Posts: 163
    Is it recommended to use Medium portraits because large portraits set at 210 x 330 seem not to work and it is driving me nuts.

  • FoggyFoggy Member Posts: 297
    edited March 2013
    You don't need 210x330 portraits for your protagonist, they are only for NPC epilogues in Throne of Bhaal. Use medium and small format only.
    You can easily crop pictures in Microsoft Office Picture Manager or Gimp for Png and Jpg, then save them as BMP in Paint to obtain the correct portrait format (24-bit).

  • wariisopwariisop Member Posts: 163
    Man these photos really don't like this game, I have it at 169 x 266 and bmp but they just keep coming up blank. This is really frustrating.

  • wariisopwariisop Member Posts: 163
    Ok, did that and reduced them down to 169 x 266 yet they still show blank, is the file size an issue for the pictures as they are 19 to 20kb a piece?

  • secretmantrasecretmantra Member Posts: 259
    That's not a file size issue, as 19-20 KB is very small.

    There is likely a problem with your file type not translating to BMP correctly.

  • mlnevesemlnevese Member, Moderator Posts: 9,711
    @wariisop make sure you're saving them in 24bits not 32 bits.

  • FoggyFoggy Member Posts: 297
    File size should be 132Kb for medium and 13.5 Kb for small portraits. Best convert by saving in Paint as BMP to correct the format. Then make sure you have the portraits in the right folder: go to Documents > Baldur's Gate Enhanced Edition. Create a 'Portraits' folder and put them there.

  • atcDaveatcDave Member Posts: 1,933
    wariisop said:

    Man these photos really don't like this game, I have it at 169 x 266 and bmp but they just keep coming up blank. This is really frustrating.

    Do you have them in a Portraits folder in the right place? It should be Libraries - Documents - Baldur's Gate Enhanced Edition - Portraits.

  • wariisopwariisop Member Posts: 163
    ^I have done all the above, and the files aren't anywhere close to that even for Large which are 70kb - 100kb. The game recognizes the folder and even that there are pictures there, but it does not show the actual picture just a silhouette head. It says in details that it is 24 bit, I don't even see a 32 bit option when you name the file bmp. Is there somewhere else I should be looking beyond details?

  • FoggyFoggy Member Posts: 297
    here's the correct size, hope this helps:

  • atcDaveatcDave Member Posts: 1,933
  • wariisopwariisop Member Posts: 163
    It seems these files are too small for the game go recognize them, I noticeced the file size difference after making the adjustments...is there a way to fix this from the original files so they fit correctly?

    Sorry to keep bugging everyone and thanks for your patience. How do you switch a picture's color mode from RGB TO indexed, this seems to be the problem but I don't know how to fix it?

  • wariisopwariisop Member Posts: 163
    There are better ones, that is why I am trying to figure out how you the other poster did that. I will post some more for others to share because they look awesome.

  • wariisopwariisop Member Posts: 163
    Foggy, how did you convert those images, sorry to bug you but I have about 20 and some are alot better than the ones I shared.

  • FoggyFoggy Member Posts: 297
    I simply changed the extension to JPG then opened the image with Paint - save as BMP picture. Easiest way to correct format. RGB to Indexed is more complex if you do not have access to Photoshop, there is ImageMagick but never tried it.

  • wariisopwariisop Member Posts: 163
    Uh, I want to apologize for my stupid question in advance but how did you changed it to JPG before opening it in Paint and how does that increase the file size so Baldur's Gate accepts the photo? Again, I am new when it comes to images thus I am learning as I go...sorry again.

  • FoggyFoggy Member Posts: 297
    No need to apologize, my bad if I was unclear. Follow these steps with every file:
    Right click, Rename, switch the extension from BMP to JPG, save, right click, open with Paint, save as BMP picture. The original format of your portraits wasn't set correctly, so this will reset it to the right 24bit BMP format. Voilà.

  • wariisopwariisop Member Posts: 163
    Uh, rename seems to do nothing when changing the bmp/jpg format. Am I supposed to open the picture in another program before opening it in paint?

  • FoggyFoggy Member Posts: 297
    edited March 2013
    No programs needed. When you right click the portrait go to rename and delete the bmp extension and type jpg instead, then change it back to bmp with Paint.

    Edit: In case you couldn't rename cause you didn't see the file extension:
    Open Folder Options by clicking the Start button , click Control Panel, click Appearance and Personalization, and then click Folder Options.
    Click the View tab, under Advanced settings, to display file extensions, clear the Hide extensions for known file types check box, and then click OK.

    Post edited by Foggy on
  • wariisopwariisop Member Posts: 163
    My MS Paint must not be working correctly because doing these steps did nothing to my file size, all this did was switch bmp for jpg and then back again with no change in size. I am sorry to waste your time, but thanks for showing me how to see my file names.

  • wariisopwariisop Member Posts: 163
    When you have the original file in paint, and you shrink the picture down using pixel adjustment to get it to 169 x 266 it reduces the file size from 77 kb to 19 kb, so how do you re-size without losing file data?

  • FoggyFoggy Member Posts: 297
    Thing is you never use MSPaint to resize or crop BG portraits -much less convert to JPG- pixels will be lost and you won't have the right format, that's why I told you to manually rename to jpg and the only thing you'll use Paint for will be its function to save as BMP (or hit B button) to automatically obtain the 24bit format needed.

    Use Photoshop (from start to finish), or Office Picture Manager to resize and crop pictures for BG then save as BMP with Paint. If you don't have access to either, google for freeware apps and converters to bmp, jpg, png and vice versa depending on the original file format. Once you have the right app, it's pretty basic stuff to customize your portraits to 24bit bmp files with the right BG size.
    If this doesn't work, compile the batch of pics in zip format and attach the file here, I'll customize them to BGEE or BG2 portraits for you to use.

  • wariisopwariisop Member Posts: 163
    Ah...that was my misunderstanding. So use Photoshop or Office picture manager. Thanks, that was my bad in reading what you were doing. The problem is MS Office Picture Manager works the same way or the file does stay the size I adjust it to. I don't have photoshop, thus I am not able to work with that.

  • wariisopwariisop Member Posts: 163
    Alright, it wasn't that I wasn't understanding you or not following directions, but you have to choose the BMP File selection offered by Windows Paint and not physically rename it BMP. This is why the files were not working. Everything else I had already done correctly the program is too stupid to realize when you say save it as BMP it is the same as choose the menu selection BMP. Sorry again for your assistance and thanks for the help. Everything else has I got to work, it was just the file size I couldn't fix.

Sign In or Register to comment.