Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Planescape: Torment: Enhanced Edition has been released! Visit www.planescape.com to purchase and check for details. Planescape: Torment: Enhanced Edition Official Soundtrack is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

rasaad quest "wheel of obliteration"

2»

Comments

  • XellosXellos Member Posts: 16
    edited December 2013
    OK, I've got a really weird effect going on - I beat the quest, I'm out, everything appears to be fine, but the 'shadow plane effect' where there's a noise and a purple-ish haze on the ground around each character seems to be continuing indefinitely, which is very annoying. Any idea how I make that stop?

    Edit: manually removed the 'OHRDARK' 3D effect in EEKeeper and it seems to be gone, if anyone runs into the same problem.
  • MilochMiloch Member Posts: 863
    Yes, already reported in other threads (and fixed for subsequent patches). Ctrl+R or Dispel Magic should remove the effect as well.
  • doublem7doublem7 Member Posts: 1
    Here is how it works:
    I skipped the fight with all of the warriors who accompany Alagorth outside of the Shadow Plane. If you feel confident go ahead and kill them all, however you should keep in mind that Shadows will keep spawning indefinitely.
    Now:

    1:Enter Shadow Plane

    2: Buff up and fight Shadow Dragon and Alagorth.

    3: Send a Party Member to loot dragon's corpse and attain the Wheel.

    4: After all of the dialogue (Alagorth complaining about you having the wheel and Rasaad yelling back) send a party member with the wheel equipped to a quick slot to open the portal. Be sure you are near the
    giant cluster of Shadow Crystals where you entered the realm.

    5: Bring your party member to reqroup with your entire party.

    6: Click on the portal to start moving towards it (like you are going to travel)***
    ***Make sure that your party has to move a significant distance to get to the portal! This way the cutscene and dialogue will activate. Alagorth will be overtaken by Shadows and killed (or so you hope).

    7: You will be transported back out to the main fighting area. All enemies who you left alive will be killed and the dwarves will be eternally grateful.
  • NaastriilNaastriil Member Posts: 60
    This was one of the most annoying quests ever. I had Viconia and Rasaad in the same party. After defeting the dragon I have to lose either one of them as they leave the party.
    The only way around was killing Viconia and 5 manning the dragon.
  • misteridmisterid Member Posts: 39
    This is the dumbest crap ever. The good shadow spawned but never said anything. Really damn annoying. I am giving it one more shot, and after that I am done trying to do the stupid quest. Why in the world do we need to be far away from the crystals?

    Maybe it is because I don't have Rassad in my party. He was my romance and in SoA with me, but I dumped him for Sarevok as soon as I could.

    Anyway, I have that little cut seen, Algorath says something like, "You'll never defeat me" but then the blue shadow (as in the circle at shadow's feet is blue) just stands there and says nothing. It will not even move. Too bad too, I thought it was looking pretty cool and the writing for the dialog was much better than BGEE's new area. Really disappointing.

    Id
  • leysleys Member Posts: 3
    Hello, I've got an other problem with the same quest: just after the party enters the shadow plane, while the interface is still missing due to the scene, the game stops going. The party stands there doing nothing even if the game isn't paused (the spells expire) and nothing appens. I tried changing something about the timing and the answers of Rasaad's dialogue that occurs just before entering the portal, but it did the same thing.
    If you have suggestion I'll appreciate it very much (I'm really curious to proceed also 'cause my charname is romancing Rasaad...)
  • maneromanero Member Posts: 364
    edited January 2014
    Ok i just finished Rasaad quest in TOB but since that moment i got unbelievable annoying bug with SILENCE animation on my whole party. Over and over... WTF?

    http://s8.postimg.org/blaytqcyd/Baldr002.png

    Above the pictures of this shit...
  • velorienvelorien Member Posts: 17
    leys said:

    Hello, I've got an other problem with the same quest: just after the party enters the shadow plane, while the interface is still missing due to the scene, the game stops going. The party stands there doing nothing even if the game isn't paused (the spells expire) and nothing appens. I tried changing something about the timing and the answers of Rasaad's dialogue that occurs just before entering the portal, but it did the same thing.
    If you have suggestion I'll appreciate it very much (I'm really curious to proceed also 'cause my charname is romancing Rasaad...)

    This happened to me too. What can I do?

  • kryptixkryptix Member Posts: 741
    This fight is super exploitable, as long as rasaad and Charname were far away the guys in the mines stayed blue I just had hexxat one shot them one at a time with backstab. Then if you don't see alorgoth the second room stays blue too so I just dropped a firestorm or two on then and let them die. For the dragon I just ran hexxat ahead with 3 spike traps, takes the dragon to near death instantly and when she comes around the corner I hit her and she dies.

    Then I picked up and used the wheel but when I left shadows kept coming so I went back in triggered the event and left again immediately...

    I did bug it out though by catching rasaad in an infinite loop of yelling alorgoth...
  • velorienvelorien Member Posts: 17
    Still Not working. Please, devs, help!
  • velorienvelorien Member Posts: 17
    Sorry if I'm getting angry, but this bug is really annoying. I'm freezed in this dungeon and I think this bug should be corrected. Please, do something
  • OrfuOrfu Member Posts: 5
    Ok.. so I beat the dragon, Alorgoth. Whole quest seemed extremely weird and bugged out to me, shadows spawning every second (and i mean massive numbers, impossible), so I took the portal back and forth a few times, then went back upstairs, rested, and tried again.

    Still alot of shadows. Then, the final battle was super easy. If Rasaad is still out of sight of Alorgoth, your other party members can just attack the dragon in human form and bring her HP down (and alorgoths). then bring in Rasaad, conversation (&portal stuff) triggers and dragon needs 1 more hit to die.

    Ok. so. got out, dwarves thanking me in the mines, some cash and then continuing their business like nothing happened. Then I get back to the camp outside and upon talking to meems dugdeep, she asks me how things are faring?! no thank you, reward, whatsoever. as if i didnt finish the quest. strange as hell

  • OrfuOrfu Member Posts: 5
    In addition to this. I just found out that if I commission cespenar to make shadow dragon scales (from the dragon with Alorgoth), he becomes impossible to talk to after he finishes. fantastic.
  • DinoDinDinoDin Member Posts: 42
    This quest remains majorly bugged and it seems like you basically have to thread a needle to get the quest to trigger properly. I got to the end and killed the dragon but then rushed out of the shadow plain too quickly and now the quest is basically screwed. Alorgoth is stuck there, immortal. Didn't make multiple saves since I didn't consult this board before playing. Definitely something major imo that needs to be fixed.
  • howmanyhourshowmanyhours Member Posts: 23
    Crikey - the ending of this quest line is a bit of a nightmare!

    Just managed to finish it off playing v1.3 - thought I might revive this old thread just to mention a couple of issues I had with trying to use the wheel of obliteration.

    1. After you kill the shadow dragon, do not immediately pick up the wheel! I did this on a number of attempts which meant that I skipped immediately to the dialogue where Alorgoth tells you to leave the wheel alone. If this happens, you can use the wheel to open up the portal, but it appears you won't be able to go through it (even though you get the wheel icon show up when you click on the portal). So you're stuck on the shadow plane fighting Alorgoth and his shadow minions forever...

    2. What you have to do is wait for Rasaad to engage in dialogue with you and then pick up the wheel. (I think you then need to pick certain options in the dialogue with Rasaad but I'm not quite sure on this and have now overwritten the save I had so I can't go back and check even if I wanted to....). When you pick up the wheel, Alorgoth will protest and Rasaad should tell you to use the wheel to open the portal.

    3. If you use just one party member to take the wheel up to where the portal originally was (as suggested above), you trigger some kind of cutscene which never finishes and you end up having to watch Alorgoth kick and punch your characters to death!

    4. If you take the whole party up to the original portal location, this appears to trigger the "correct" cutscene.

    5. I then had a party member equip and trigger the wheel and managed to get the hell out of the shadow plane once the other shadows turned up to attack Alorgoth.

    Boy, was I glad to be out of the shadow plane....and to think I was only doing the quest for the extra XP!
  • onebuttersonebutters Member Posts: 1
    edited May 2015
    Nachti said:

    The existing shadows dont turn on him. New Shadows appear that turn on him.

    You have to click on the portal. Not from close, but from far. So you dont change the map before the event can trigger.

    Feel free to upload a savegame.

    Thanks, this was the solution. After 10 minutes of potting and damage dealing I tried this and it worked. Such a dumb trigger....

    Also dispelling that effect, omg another 15 minutes to read and figure that out. Had to mute the speakers...
    Alpinia
  • FinnTheHumanFinnTheHuman Member Posts: 404
    edited February 2016
    I had the same problem and it was sooo frustrating. For me, as soon as i killed the dragon i would pick up the wheel before Rasaad had a chance to initiate a dialogue about the cave collapsing. It skipped to Alorgoth telling charname not to touch his stuff. The cave collapsed a little and I could open the portal, but couldn't use it. Only the first of the firestorm effects ever happened, and soon I was killing a shadow or two, kiteing Alorgoth, trying again and again to use the portal from different distances.

    So the answer was, wait before picking up the wheel.

    Kill the dragon first, punch up alorgoth a bit, wait for dialog, pick up the wheel, dialogue with Al, dialogue with Rasaad, enter cavern with the crystals, spin the wheel raggity man, shadows turn on alogoth, leave.
    Post edited by FinnTheHuman on
  • FinnTheHumanFinnTheHuman Member Posts: 404
    @[Deleted User], I had the opposite problem as you. How to get Rasaad to leave. One of the dialogue options after we were back was him wondering what to do next. Charname told him to go back to Selune, trying to let him off gently. He didn't take the hint or hit the road. Now I have to use the reform party button. Oh Rasaad, sorry buddy, bit we're the fearsome five, not the serious six. Ok. maybe you can come to Amkateran with us.
  • KhadinKhadin Member Posts: 5
    For several hours now I've struggling with the shadow plane.
    First I didn't pick up the fight with the Shadow Guards at the portal. After multiple reloads I've decided I will just sneak by with mass invisibility. I cross the shadow portal, there I kill only four of the infinite number of shadow creatures and rush to fight Algorth and his dragon. As soon as I kill the creature I pick up the stone, make my thief rush to the shadow crystals and spawn the portal. When the rest of the team joins the thief we cross the portal. When we are back home the portal doesn't disappear, nobody is starting any dialogues and shadow creatures keep spawning into material plane through the portal. I reentered the shadow plane, there appear some comments about the plane falling apart, but no dialogue is being started. Any solution now, or the only way is to let it go and leave the quest be now?!

    In my opinion this is the most imbalanced quest in the game. The siege is too easy, but the final fight is nearly impossible. And the bugs with the portal.
2»
Sign In or Register to comment.