Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Scimitar weapon profs freeze game

SjerrieSjerrie Member Posts: 1,075
edited January 2014 in Not An Issue
As per title. When trying to add a point to the scimitar weapon proficiency the game freezes. The last thing noted is the *click* heard when pushing the +-button, but it also happens when clicking the text to the left of that. It happens both during level-up and character creation. In both cases it is only the scimitar/etc. line.

When trying anything during the freeze (like clicking the mouse) the blue-circle-cursor appears, and if then clicking escape the "this program is not responding" choice menu appears (but not noticable since the game is still on the foreground). Baldur.exe uses 25 percent of total CPU power, which I assume is one full core.

I am running Win7 and have the banterpack, flirtpack, Unfinished Business and BG2Tweaks installed, though nothing that alters the weapon proficiencies. The only thing installed *since* all was working fine would be DungeonBeGone, which has since been uninstalled. Some minor tweaking to items, but not the scimitars.

I did have hardware trouble a little while back (power failure and graphics card trouble) and the computer crashed a few times, once while in-game. I can't find the crashdumps of these issues unfortunately...

Post edited by Illydth on

Comments

  • SjerrieSjerrie Member Posts: 1,075
    Yeah, maybe this should be in general support instead of bugs @Gate70, sorry. I have no idea what it could be so any pointers on things I could try are more than welcome.

  • SjerrieSjerrie Member Posts: 1,075
    @Gate70 Yeah I circumvented the problem for now with EEKeeper. Since my graphics card mishap I've been keeping a close eye on it and it's associated drivers, and the game runs as smooth "as an elven arse" otherwise so I don't think it's that. I'll try fiddling with the mods or a clean install when I finish this playthrough, I'm still having too much fun right now. :)

  • IllydthIllydth Member, Developer Posts: 1,641
    @Sjerrie: Sound Drivers would be my first candidate for checking this out. If the last thing you hear is the click before the crash, it's possible that's an issue.

    Otherwise everything Gate suggests is good. Going to move this to "not an issue" as I don't think we can repro this one any time soon. If you get a good condition where we can make this one happen, let us know and I can move the thread back or open a new one.

  • SjerrieSjerrie Member Posts: 1,075
    @Illydth If it were the sound drivers, would not the same problem exist with the other proficiencies?

    It wasn't really my intention to make an actual bug report of this, I was just hoping people with more knowledge of the engine than me could have some ideas what to try, or who knows maybe even have a solution. Thanks for the tips sofar though. :)

  • IllydthIllydth Member, Developer Posts: 1,641
    @Sjerrie: Driver issues can be REALLY weird. You would think that what you're suggesting is in fact the case (or that you'd be locking up in other parts as well). And with you mentioning that clicking on the name (instead of the + / - button) does it too, maybe it's not sound. It's not likely graphics either...anything's possible however.

    Go through some of what gate mentions if you're REALLY interested in figuring this out. It HAS to be something with your particular setup. I'd probably start with a clean install and go from there.

    Sjerrie
  • SjerrieSjerrie Member Posts: 1,075
    edited January 2014
    I just noticed something I didn't before. The ninjato is normally spelled with a Japanese-style 'o' with a dash on top of it (a "macron" as Wikipedia calls it).

    I think I do remember seeing those in-game, BUT in my game they are missing from both the weapon descriptions AND the proficiency screen. I have a close-to-clean install of BG1EE v1.2 where the character does show, I need some time to check out a clean install of BG2EE.

    Can this problem be character set related? If so, is it more likely that a mod messed this up or can it be that something's missing/broken in my Windows installation? Is there a .2DA or .IDS I can edit that handles the text in the proficiencies screen? The ninjatos themselves do still work...

  • SjerrieSjerrie Member Posts: 1,075
    *raises eyebrow* Fascinating. As an experiment I installed the BG2Tweaks component that moves ninjato proficiency to the short-sword proficiency. Suddenly, the game didn't freeze anymore when I tried to put points in the scimitar line. Neither does it freeze if I put points in the short-sword line. The changes this component makes do actually make sense, so I might stick with it. I'm not comfortable however not knowing what might have caused the problem... Thoughts, people?

  • IllydthIllydth Member, Developer Posts: 1,641
    @Sjerrie: I wanted to touch base back with you on this since you have a couple questions out.

    As to the Ninjato and the missing "macron", I can't say as I've ever seen this. I know English language on an English OS does not freeze out of the box. If you think this is a character set problem, feel free to identify what character set your OS and your game is using so we can verify whether we can repro the issue.

    The fact that the BG2Tweaks component fixed the issue IS interesting information. If you remove the tweak does the problem return? If it does you may be on to something about this being character related...on the other hand, BG2Tweaks could simply be "removing" ninjato's from the game and replacing them with Shortswords...what I mean by this is that if the tweaks component actually changes all NinjaTo's to ShortSwords in the game data (not name but actual type) then it's simply working around the problem. If, instead, the tweak is changing something related to the Ninjato's data (i.e. spelling or something of that nature) then we may have a broken game component.

    Of course, the other possibility is that uninstalling the Tweak fixes the issue also and it was just something corrupt within your copy of the game.

    Sjerrie
  • SjerrieSjerrie Member Posts: 1,075
    @Illydth thanks for the insights and getting back. Just to be 100% clear, it is not just the macron itself that is missing, it's the entire 'o'-character/letter.

    I checked both the readme of BG2Tweaks and a basic ninjato's item file, the proficiency of the ninjato with the component installed was in fact short-sword. Removing the component made the problem come back. In both cases the weapon description (right-click in inventory) looks the same: a normal 'o' in the weapon title, but a missing character in the description itself. Though when viewed in EEKeeper the proficiency line in the description would read -- Scimitar/Wakizashi/NinjatÅ? -- (in both cases).

    I am running Windows 7 Ultimate, standard system language is English. Under "Language for non-Unicode programs" (on the administrative tab in "Region and Language") my standard setting aka 'system locale' is Dutch, as it was when I installed BG2EE and the mods. I have tried to change this setting to Japanese to see if that would help, but it had no effect on game behaviour. I would be willing to try and change my whole system language to Japanese, but my western Windows version does not have that package. I don't really know what else I could try character-set-wise in Win7...

    I'm a little reluctant to try a clean install at this moment as I am having a great time in my current playthrough. Admittedly the BG2Tweaks "quasi-fix" helped. I also have a Windows XP installation I could try it out on, but the mere fact that it's XP would change a variable. Nevertheless I will try and see if this issue shows itself there in that environment, asap.

    I must admit, I find this an interesting mystery... :-p

  • IllydthIllydth Member, Developer Posts: 1,641
    @Sjerrie: So the good news is there's ABSOLUTELY NOTHING in the game files that would hose up any saves you're doing.

    Back up your entire BG2:EE Profile directory (My Documents/Baldur's Gate 2 Enhanced Edition) to another location and you should be able to do a complete wipe/reinstall without any problems at all. You won't lose any progress...just copy your saved games directory back when you re-install. Honestly I think this is just precaution because I don't believe an uninstall removes the saves, but backing up all that work is always a good idea.

    If you do happen to figure something out, don't hesitate to @ me, otherwise good luck and happy BG2'ing!

  • GraypGrayp Member Posts: 15
    Hey there, I had the exact same issue so I thought I would share my findings and resolution to this.

    My settings are:
    Windows 8.1, English (South Africa)
    Game Installation: English

    I also found that the BG2Tweaks change fixed it, but I did not want to play with that change so I uninstalled it and did a bit of digging.

    Using nearinifinty, I opened up the dialog.tlk and did a search for the scimitar/wakizashi/ninjato proficiency description (you can do this by simply searching for something like 'scimitar' and clicking next until you find it). Once you have it open you will notice some strange characters- simply removing these and replacing it with a standard letter in the dialog.tlk (then saving) fixed the issue.

    To be safe, I also did a search for all occurrences of Å? and replaced that with o.

    To confirm, it is indeed a language setting issue. Please let me know if you need more info or have any additional questions.

    -Grayp

    Sjerrie
  • SjerrieSjerrie Member Posts: 1,075
    Oh wow, I totally forgot about this topic.

    I am currently still playing with the BG2Tweak in place (seemed more logical to me anyway) and to be honest I don't even remember if I tried a clean install yet. Most likely that will only come after the 1.3 patch. Thanks anyway for your input @Grayp, should trouble rear its head again I will try your solution.

Sign In or Register to comment.