Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been announced! Visit nwn.beamdog.com to pre-order, apply for the Head Start and check for details. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Known 4605] Escape the asylum.

azzerb21azzerb21 Member Posts: 6
edited September 2014 in BGII:EE Bugs (v1.2.2030)
I have escaped the asylum and have been told to get the help of the crazy inmates, when i go up the stairs and talk to Lonk the sane i can finish talking with him but once i do Irenicus appears from a teleport. it is exactly the same as when i first entered the ayslum. He takes me into the room with all the tubes and people in them and tortures me and i go into the dream where i have to take baal into the library. Its like the game resets. I have tried to kill baal but he wont die. I have no save points before being in the lower levels of the asylum, I need help!

Post edited by Gate70 on

Comments

  • Gate70Gate70 Member, Developer Posts: 3,429
    Can you zip and attach a save please @azzerb21‌

  • azzerb21azzerb21 Member Posts: 6
    I would love to, how do i do that?

  • Gate70Gate70 Member, Developer Posts: 3,429
    OK, will looks later on today unless someone else gets there first :)

  • Gate70Gate70 Member, Developer Posts: 3,429
    Lonk is resetting variable AsylumPlot from 51 to 19 which brings Irenicus in.

    The area code (AR1515) is not in your save - did you edit an earlier save to remove the Spellhold entrance?

  • Gate70Gate70 Member, Developer Posts: 3,429
    edited June 2014
    Enabling the console, pausing the game as you transition to Lonk and setting a local variable sorts that area out.
    image

    You are then teleported to confront Irenicus but he doesn't appear. There is probably another variable for that. I suspect Saemon may also not show up. I don't have time right now to get through those parts, will look later. If you wanted to try something like consoling Jon in you could try
    C:CreateCreature("PPIREN2")
    I'm not sure what his creature code is but that might be worth a try.

  • azzerb21azzerb21 Member Posts: 6
    Thanks for your help, do you think it will only be that save game that is effected. I may just start over but don't want to if the problem will carry on occuring

  • Gate70Gate70 Member, Developer Posts: 3,429
    Your save has issues. Have you edited it, or already used the console to progress the Spellhold plot.

    The thieves are still alive so their sacrifice hasn't taken place.
    Console Command SetGlobal("ppdeadthief","AR1516") sees the Bhaal dream start.

    To kill Bhaal you need to reset a couple of variables while fighting him.
    Pause the game.
    Open the console and type the below but don't press ENTER
    C:SetGlobal("spoke","LOCALS",0)
    Move the mouse over Bhaal, then press ENTER.

    To get to where you are these should have been completed. While it can probably be reconstructed it would be helpful to know what has happened.

  • Gate70Gate70 Member, Developer Posts: 3,429
    edited June 2014
    Try this save @azzerb21‌ it is a bit rough but should get you through the plot critical parts.

    n.b.
    I consoled Irenicus in so he is slightly out of position.
    I didn't bother trying to kill the thieves off.
    I have removed the ring of free action from Korgan so the party could haste.
    I have already been upstairs and returned before Lonk dialogues.
    (You may have to talk to Lonk to activate him as a result)

  • azzerb21azzerb21 Member Posts: 6
    That worked perfectly thank you very much! Unfortunately however a similar thing has happened again. I am out of the underdark now thanks to your help but when i go back to Amn and the slums district Chapter 2 starts again and i am confronted by Galen bayle and everything is reset. if i got into the copper cornet it is as if i am going in there for the first time. On the attached file if you travel to the slums from my current location you will understand what i mean

    save.zip 259.9K
  • Gate70Gate70 Member, Developer Posts: 3,429
    edited June 2014
    Doesn't sound good. This sounds like a major issue that the first patch resolved.
    - What platform (PC / Mac / etc) do you have.
    - Is the game from Beamdog (launcher or standalone), Steam etc.
    - What is the game version, e.g. 1.2.2030.
    (load a game and check the options screen. Easier to see in a new ToB game than in an SoA game)

  • azzerb21azzerb21 Member Posts: 6
    I have just a laptop pc, its from beamdog i dont use steam to launch the game and it says version 2.1.0

  • Gate70Gate70 Member, Developer Posts: 3,429
    @azzerb21‌ sounds like you don't have the patch installed.

    If you had the Beamdog launcher there would be a yellow(ish) plus sign on the right of BGII:EE to update.

    I suspect you have the standalone launcher, I haven't got that installed or had it for some time but recall an icon on the bottom right with options such as "repair install" or "check integrity". Have a look at those and it should install the patch.

    n.b. installing the patch will remove any mod content.

    The bad news is that I don't think that fix was retrospective, i.e. your current game won't be fixed but future runs wouldn't have the issue.

Sign In or Register to comment.