Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Quick Save and Auto Save not accessible

zenseerzenseer Member Posts: 3
I saw some posts about this back in November of 2013. Nothing suggested impacts my problem.

The Auto Save and Quick Save directories under my ..\Users\\Documents\Baldur's Gate - Enhanced Edition\save directory exist, but are not showing up in the list of saves under 'Load'. They cannot be opened from Windows. Reviewing the Advanced security permissions as an admin account shows "Unable to display current owner" under the Owner, and I get "Access is denied" when trying to change the owner to an admin account or the Administrators group.

icacls cannot read or overwrite the permissions on either directory.

I cannot 'move' the save directory (as a support person suggested on one thread) because permission is denied.

This seems to be a pretty serious problem. As it stands, I don't see how I can even completely uninstall the product without formatting the disk. What exactly is getting done when these directories are being created?

Is there any real solution being offered for this problem?

Comments

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    edited July 2014
    If you are using Windows Vista or 7, then you should be able to take ownership from the command prompt. Click Start, type 'Run', launch the Run application and type in cmd. When the command prompt opens, type in takeown /f <foldername> /r /d y. Replace <foldername> with the save location (rather than the individual save game folder). Then you can use icacls to assign full control to whatever your user group is.

    Example:
    takeown /f "E:\Users\Administrator\Documents\Baldur's Gate - Enhanced Edition\save" /r /d y

    Post edited by Troodon80 on
  • zenseerzenseer Member Posts: 3
    Thank you for the reply, Troodon80. I should have mentioned that I had already tried a variant of that to take ownership (registry key option). The cmd takeown also returns an 'Access is denied' error, even when the command prompt is launched with 'run as administrator'.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    edited July 2014
    I have come across similar issues before that are linked to process handles (a currently active process that is accessing the folder, like, for example, the Windows indexing service). Make sure nothing is accessing that folder when you are trying to take control. Use something like Unlocker or Process Explorer to find out if it is such an issue. If it is, kill that process and try to take control of the folder.

  • zenseerzenseer Member Posts: 3
    Hmm. Well, this has become increasingly frustrating. I couldn't find signs of any process running that was preventing access. I stopped nearly every app and still received the error. So I rebooted.

    Now both directories are gone, so there's no way to troubleshoot this further. :-( Thanks, Troondon, for your assistance.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    Do you have any idea what might have caused it? Were the files moved from another computer or another user group (or Admin group on a previous installation of Windows)?

    This doesn't seem like a particularly prevalent issue that a lot of people are experiencing and it would be nice to at least figure out a potential cause. :-)

  • MathsorcererMathsorcerer Member Posts: 2,725
    edited July 2014
    Just out of curiosity, you don't happen to have any previous versions of your C:\Users\username\Documents\Baldur's Gate - Enhanced Edition folder, do you?

Sign In or Register to comment.