Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[not an issue] Dorn's bloody path not bloody updating. HELP!

AutistocratAutistocrat Member Posts: 4
edited September 2014 in BGII:EE Bugs (v1.2.2030)
Ok, so I have slain the rather unfortunate Guardian Terpfen (unfortunate to be in Dorn's bloody path) and the vile Hokkney-bastard. So much for their nobility. The dialogue between Charname and Dorn initiated properly after that. I then proceeded without thinking too much about the matter. I played quite far so there is no option to load an earlier save (which I do not have).

Here's the thing, the questlog is stuck on "Thanks to Telwyn we now know the paladin Terpfen can be found..." etc.

I tried googling the unholy shit out of Dorn and his "bloody path" but came up with nothing. I also tried to find a way to force-complete a quest through CLUA-console but only found answers for specific quests. I then proceeded to search DLTCEP in scripts under Dorn, OHD, ohdterp, etc. for something to use (and tried various improvised commands). This also resulted in nothing.

Neither spawning both of them in Athkatla or in the Helmite camp and killing them did nothing.

I think this happened due to the memory leak bug I encountered earlier in the game, where my save lost some data. I was able to load a functioning save right before it happened and just played on. I am probably wrong about this though.

Anyway, is there any way to force-complete the quest via console or some other way? Maybe the journal is just not set to update until Ul-Gothoz's next shenanigans? This is devastating to me as I'd rather start a completely new game from level 1 than finish the game without completing his questline (or any other NPC that is in my party for that matter).

If someone knows what I could do please post a solution, or summon someone who might know a solution. (I cant remember the names of anyone from the times I read through various posts here).

I'd say thanks in advance but as a chaotic neutral fighter/thief I am careful to give my regards in advance.
;)

Post edited by Illydth on

Comments

  • CrevsDaakCrevsDaak Member Posts: 7,135
    Some questions I must ask:
    -Is Dorn over level 12? And if he is, was he when you force-continuated the Quest?
    -Did you got ambushed when leaving the Helmite Camp?
    Also, which is your game version? It might be hard to see in SoA, but it's pretty easy to see in a new ToB of Black Pits game.

  • AutistocratAutistocrat Member Posts: 4
    edited August 2014
    Dorn is level 13, as he was when I tried the different commands. He was below level 12 when I killed Terpfen if I remember correctly. And yes I got ambushed. But I never force-continuated it, only tried to. Unsucceedingly I might add, so I reloaded a save untampered from my improvised commands.

    Edit: I now also started a new Black Pits game but couldnt find what version im in, how is it that im supposed to see this? ^^

  • CrevsDaakCrevsDaak Member Posts: 7,135
    After you killed Terpfen, did everything work Ok or was it there when it got stuck?
    Also, after you got ambushed, still in the same ambush area,
    did an NPC appear, offering Dorn a new patron? And then Dorn's actual patron teleported in and Resurrection Gorge got marked in your map?)

  • AutistocratAutistocrat Member Posts: 4
    Everything worked out ok, I had a dialogue with dorn and told him maybe his patron is keeping him from his real strength or something like that. And no, that this with his patron and the other guy did not happen. However, I remember Dorn was killed in the fight. The guys from the ambush started turning friendly but I kept on going (those bastards!) I then resurrected Dorn with a rod of resurrection and traveled on.

    It does sound like that is it doesn't it? ^^
    Now how do I solve it? :P

  • Gate70Gate70 Member, Developer Posts: 3,595
    @Autistocrat‌ I've zipped and attached some saves from meeting Dorn to killing Terpfen and meeting Azothet / Ur-Gothoz.

    If you look at these in EE Keeper you may find Dorn has local variables which you require. EE Keeper is handy as you can open your save plus another, and copy variables from one to the other.

    Hope that helps.

  • AutistocratAutistocrat Member Posts: 4
    Uhm, how do I find the attachment to the post you made? ^^

  • Gate70Gate70 Member, Developer Posts: 3,595
    You have to pretend I didn't click "Post Comment" before the upload finished @Autistocrat‌
    (hope it works this time)

    CrevsDaak
Sign In or Register to comment.