Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

modding permission failed [RESOLVED]

WonderpaulWonderpaul Member Posts: 32
edited August 2015 in General Modding
Hello to all,
I have a small problem with a mod, mod indeed all, to be installed on my iMac running Yosemite.

That is when I go to click on .command the mod tells me that I do not have the necessary permits.
At this point I tried to change the permissions of the file, but nothing more and the same message as I do?

Post edited by Wonderpaul on

Comments

  • AlmateriaAlmateria Member Posts: 257
    edited August 2015
    It's a common bug in OS X. Anyway, the solution is:
    1. Select all the mods that don't work, including the .command file, the directories, everything.
    2. Open the Terminal.
    3. Type "chmod 777 ", without the quotation marks.
    4. Drag the selected files to the terminal window.
    5. Press enter.

    It'll take care of all permits. You could also run it on the entire app, but it's really not necessary.

  • WonderpaulWonderpaul Member Posts: 32
    Almateria said:

    It's a common bug in OS X. Anyway, the solution is:
    1. Select all the mods that don't work, including the .command file, the directories, everything.
    2. Open the Terminal.
    3. Type "chmod 777 ", without the quotation marks.
    4. Drag the selected files to the terminal window.
    5. Press enter.

    It'll take care of all permits. You could also run it on the entire app, but it's really not necessary.

    Taking the example of the mod DungeonBeGone.

    I followed all your steps, I selected all the files of the mod above, open the terminal, wrote chmod 777, and dragged all the files inside.
    But when I go to when I click send says, invalid file.

    Then I tried to drag only the Setup file-DungeonBeGone.command, and says,
    Usage: chmod [-fhv] [-R [-H | -L | -P]] [-a | + a | = a [i] [# [n]]]
    mode | file entry ...
    chmod [-fhv] [-R [-H | -L | -P]] [-E | C | -N | -i | -I] file ...

    What does it mean?

  • AstroBryGuyAstroBryGuy Member Posts: 3,414

    Hello to all,
    I have a small problem with a mod, mod indeed all, to be installed on my iMac running Yosemite.

    That is when I go to click on .command the mod tells me that I do not have the necessary permits.
    At this point I tried to change the permissions of the file, but nothing more and the same message as I do?

    Did you get the game from the Mac App Store? Apps from the App Store ship with write-permission turned off inside the app package.

    Take a look at my guide to installing mods on OSX:

    https://forums.beamdog.com/discussion/31155/the-hitchhikers-guide-to-installing-mods-on-osx/p1

    Also, grab @subtledoctor's Mac WeiDU Launcher. It takes the place of using the .command files.

    https://forums.beamdog.com/discussion/17717/tool-easy-mod-installer-weidu-launcher-for-os-x/p1

    Oh, and if you're installing DungeonBeGone, the installation of the voiceovers won't work for two reasons:
    1. DBG ships with a version of sox (audio processing program) from 2002 - and it's for PowerPC CPUs, not Intel CPUs.
    2. Last time I tried, the audio installation scripts for OSX are bugged.

    If you really want the voiceovers, copy the .ogg files in jassy/Audio to your override folder and rename the extensions from '.ogg' to '.wav'. BG2EE can read .ogg files, but needs the extension to be '.wav'.

    elminsterWonderpaul
Sign In or Register to comment.